PDA

View Full Version : [SOLVED] KDE becomes not responding every time I close a window



heavensdevil690
21st March 2010, 10:04 AM
Hello. I am new to Linux. I'm using KDE. I installed codecs for playing songs today, and tried to play a song using amarok. It didn't work, rather flooded my tool bar and the system hanged and I rebooted. It was fine before, but after I rebooted, a new problem raised. Every time I close any window, something changes, and the windows lose their title bars (minimizing, maximizing, closing option), and neither it can be closed from the tool bar (bottom) panel, nor can be moved. The Kickoff Application launcher is also not working. Every time i close a window, I got to log out and re log in. :(

I tried to change in the System Settings>Appearance but nothing works, and even when I close that window, the same happens.

Please tell me what to do?

---------- Post added at 02:33 PM CDT ---------- Previous post was at 02:30 PM CDT ----------

The same is happening even when I open terminal and type 'exit'.

---------- Post added at 02:34 PM CDT ---------- Previous post was at 02:33 PM CDT ----------

I'm using Fedora 11

spoovy
22nd March 2010, 01:47 AM
I assume your system is up to date? I have had things like this in the past when installing a new distro and forgetting to do a full update.

In case you don't know what I mean, type in the following into a terminal -

su -c 'yum update'

and ok any prompts. Then reboot.

heavensdevil690
30th March 2010, 07:04 PM
Thanks... that worked...
But it installed a new version of the kernel... How do i disable the previous one?

spoovy
31st March 2010, 04:29 PM
Only one kernel is in use at any time, and 99.9% of the time you want to be using the latest one. So basically you don't need to do anything at the moment, you are using the latest version of the kernel.

Just so you know, your last two kernels (or more if you want) are always saved on your system, and if you needed to you could boot them instead of the default (latest) one, from your grub menu.

But it's highly unlikely you will ever need to to be honest. Best to cross that bridge if/when you come to it.

heavensdevil690
31st March 2010, 07:09 PM
Yes. I'm using the latest one... But how do I modify grub so that it doesn't even give me option to boot from the previous kernel at the time of booting, as its giving me now..
Do I need to delete vmlinuz<previous-version>.img and make some changes in grub.conf?

One more question.. although I have updated my system... I found that my kde is 3.5... and it didn't get ungraded to 4.x.. Is it efficient to switch to kde 4?

Thanks in advance. :)

spoovy
31st March 2010, 07:25 PM
Well I use grub1/grub-legacy, so I would just comment out a few lines in menu.lst to get rid of the unwanted grub entries.

But it sounds like you are using grub2. I hate grub2, and i have no idea how to do anything with it other than erase it.



With regard to your KDE problem, that sounds very strange indeed. How do you arrive at the conclusion that you are using KDE 3.5? Where does it say so?

heavensdevil690
31st March 2010, 09:09 PM
kded --version

Qt: 3.3.8b
KDE: 3.5.10-21.fc11 Fedora
KDE Daemon: $Id: kded.cpp 711061 2007-09-11 09:42:51Z tpatzig $

jdk82
31st March 2010, 09:39 PM
Hi heavensdevil690,

I'm running F12 over here, and

kded --version
returns

KDE: 3.5.10-21.fc12 Fedora
KDE Daemon: $Id: kded.cpp 711061 2007-09-11 09:42:51Z tpatzig $
Even though I am clearly running KDE 4. I can't offer an explanation, but I can tell you that Fedora has used KDE 4 since F9 and has never had the option to downgrade to KDE 3. So, you are definitely running KDE 4. To verify, run

rpm -qa | grep kdebase
and look at the version numbers.

Josh

---------- Post added at 03:39 PM CDT ---------- Previous post was at 03:36 PM CDT ----------

Quick follow up,

I googled kded, and it is a daemon that runs some tasks for KDE. Not sure why it would be a 3.x version, but it is not an indicator of what version of KDE you are using.

Josh

heavensdevil690
31st March 2010, 10:09 PM
Hmm..

Here's the output that I've got..


kdebase-runtime-4.4.1-1.fc11.i586
kdebase-workspace-libs-4.4.1-2.fc11.i586
kdebase-libs-4.4.1-1.fc11.i586
kdebase3-libs-3.5.10-8.fc11.i586
kdebase-runtime-libs-4.4.1-1.fc11.i586
kdebase-workspace-devel-4.4.1-2.fc11.i586
kdebase-4.4.1-1.fc11.i586
kdebase3-pim-ioslaves-3.5.10-8.fc11.i586
kdebase3-3.5.10-8.fc11.i586
kdebase-workspace-4.4.1-2.fc11.i586

But when I try
yum install kde*
its asking me for a 1.2 GB update.. Should I go for that?

jdk82
31st March 2010, 10:18 PM
No, you should not install that. Running

yum install kde*
will install EVERY package beginning with "kde" and all of their dependencies. You already have KDE 4 installed, and you have no need to install every single package that starts with those letters.

Josh

---------- Post added at 04:16 PM CDT ---------- Previous post was at 04:15 PM CDT ----------

Also, fyi, when you run

yum install
you are not updating something you are installing new packages.

yum update
updates packages that you currently have on your system.

Josh

---------- Post added at 04:18 PM CDT ---------- Previous post was at 04:16 PM CDT ----------

Also, please remember to mark your thread solved when you get a resolution to your problem

Josh

heavensdevil690
31st March 2010, 10:20 PM
Hmmm..
Thanks..

How to I delete older kernel entry from grub menu at boot time? I want only one option [the newer one] at the time of booting..

jdk82
31st March 2010, 10:35 PM
That is NOT recommended, and my current situation is a perfect example of why. I have an Nvidia gpu, which works fine with the 2.6.31 kernels, but does not appear to work with the 2.6.32 kernels. The backup kernels are there so that if something breaks when a new kernel comes out you can still use the old kernel. That being said, if you REALLY want to change the number of kernels kept on the system, edit /etc/yum.conf. The number after "installonly_limit=" represents the number of old kernels yum will keep around.

Josh

heavensdevil690
1st April 2010, 12:27 AM
Hmm..

Thanks a lot.. :)

spoovy
2nd April 2010, 12:26 PM
mark as solved?