View Full Version : OpenJava/Ameritrade working

14th March 2010, 06:06 PM
I use two of my Fedora boxes for trading stocks by running Ameritrades Command Center. It required the use of Sun's Java jre, another free but not open app that I had to install. After the update on 3/11 my F12 install started segfaulting Firefox, just as Command Center would have finished it's setup (I see in bugzilla others have had a problem similar #567385). So why am I telling you all this. Well, my F13 Alpha install was sitting next to the segfaulting F12 box, I was not home, so my wife turned on the F13 box, went into Ameritrade and ran Command Center from it, without Sun's Java installed. I confirmed this today by running it myself and checking to see what Java apps were installed. Openjdk is the only app there. None too soon, because I was going to experiment with Firefox 3.6, jre 1.6.0_18 and the revised plugin today. I never thought to check to see if Openjdk had improved to the point where I didn't need Sun's Java any more.

So much for 13 being an unlucky number. So far, I haven't had to use the Nvidia binary blob, and now Sun's Java doesn't need to be installed. Some more testing I guess to make sure, but F13 so far is making me a happy camper.

5th April 2010, 07:37 PM
I was going to experiment with Firefox 3.6, jre 1.6.0_18 and the revised plugin today.
I got to this thread searching the forum for clues to why FF 3.6.3, which I just installed a couple of hours ago, doesn't pick up the Sun JRE 1.6.0_19 browser plugin. Running the F12 installed FF 3.5.9 has no problems picking it up. FF 3.6.3 picks up all the other plugins in /usr/lib/mozilla/plugins/. I even created a symlink to the jre plugin in /opt/firefox/plugins/ (that's the 3.6.3 install location) and it's still a no show. Funny, because I only realized the java plugin wasn't working in 3.6.3 after logging into Ameritrade and then attempting to launch Command Center2, which rudely informed me I was missing a needed java runtime plugin.

Guess I'll try installing the F13 version of openJDK into F12 (if that's possible without running into dependency hell issues) and give that one a try with FF 3.6.3. But I'd be happier if I can figure out how to get the Sun java browser plugin to recognized in FF 3.6.3.

5th April 2010, 07:49 PM
Yes, I was pleasantly surprised by the advancements in OpenJDK. For me, FF 3.5.8 was the start of my problems with Sun's Java. If I remember correctly 1.6.0_18 needed a patch, and 1.6.0_19 had the patch included, or something like that. I made the mistake of removing the plugin while experimenting to get it to work, then not being able to reinstall it to a useful state after that. It seems that FF 3.5.8 and 3.5.9 are not compatible with the plugin, heh, but your having the exact opposite problem.
Funny, my FF is only 3.6.2, and there's nothing in the updates.
Anyway, there's no JRE here and we're using Command Center daily for business, hope OpenJDK works for you.

5th April 2010, 08:05 PM
Well that's good to know. I just found the solution on another thread though and checked it out. FF 3.6.x no longer supports the libjavaplugin_oji plugin. It's now necessary to use the /opt/jre1.6.0_xx/lib/i386/libnpjp2.so module as the browser plugin. Now, off to check out Command Center 2 again.

I downloaded FF 3.6.3 directly from mozilla.org. I didn't experience any problems with the 1.6.0_18 java plugin in either FF 3.5.8 or 3.5.9, so I don't know where your trouble with it was initiated from. I aborted the openJDK download.

5th April 2010, 08:28 PM
Yeah, I saw and the support structure of the different plugins/modules, and it's strange, F11 is up to FF 3.5.9 and Sun's JRE and the plugin are working fine there, and I think that version of JRE is 1.6.0_16. All my other machines are running F13 now and I haven't had to use anything but OpenJDK to get Ameritrade working. Whatever works I guess, good luck with the new module.

5th April 2010, 08:38 PM
Testing new module libnpjp2.so in FF 3.6.3 @ ameritrade with Command Center 2:

Not good. Two tries..... two strike outs. The CC2 window opens, loads data for several seconds, then FF crashes . Back to FF 3.5.9 for time being.

5th April 2010, 09:20 PM
That's exactly what happened to me in F12 with FF 3.5.8. Then I turned to my new F13 alpha install with FF 3.6.x (don't remember if it x=0 or 1) and it kept loading, without JRE. I haven't looked back since.
I usually use Dangermouse's instructions from his website to install Sun Java, but I couldn't find the BundleID for 32bit 1.6.0_19. I guess I was lucky not finding it.

7th April 2010, 07:13 PM
Followup report:

Probably stretching it a bit as this is really a F12 issue (in the F13 Development forum), but just to provide some finalization to my issue with F12 and the jre libnpjp2.so plugin for FF 3.6.3.....

I managed to crack the nut and get it all working. It's really an SELinux issue, though why I wasn't getting any setroubleshoot AVC popups when those FF crashes occurred, I don't know why. Some more googeling led me to the fix. First tried with selinux set to permissive and it all worked fine on the java.com "test your jvm" page. But leaving selinux in permissive mode wasn't acceptable to me.

Looks like the trick is to chmod the libjvm.so and libdeploy.so files in your jre install. There are 2 instances of libjvm.so, change them both, just to be sure.
sudo chcon -t textrel_shlib_t /opt/jre1.6.0_19/lib/i386/client/libjvm.so
sudo chcon -t textrel_shlib_t /opt/jre1.6.0_19/lib/i386/server/libjvm.so
sudo chcon -t textrel_shlib_t /opt/jre1.6.0_19/lib/i386/libdeploy.so
Using, of course, the actual path to your jre install location and version. This lets you keep selinux set to enforcing.