PDA

View Full Version : Wierd Nouveau Error with Kernel-2.6.34.0.10-rc1.git0 - 2.6.34-rc1



STEVE555
13th March 2010, 03:00 AM
Hi everyone,
I get a weird error message that locks up the 2.6.34.0.10-rc1.git0 - 2.6.34-rc1 kernel if I have AGP mode 8x with side-banding on in my bios settings.

I've taken some steps if it will boot with different bios settings for my motherboard.
I first tried AGP 4x,and that booted fine to the dektop.
I then tried AGP 8x with no side-band on and that booted fine as well.
I tried again with AGP 8x and side-banding on but I removed rhgb quiet from the kernel parameters and pressed b to boot and that booted fine as well.

The error occurs when I have AGP8x with sidebanding and I don't do anything to the kernel parameters.
The kernel runs a load of messages,but stops at the end of this:

[drm] nouveau 0000:01:00.0: unknown type, using 0xff
[drm] nouveau 0000:01:00.0: Parsing VBIOS init table 0 at offset 0xE754
[drm] nouveau 0000:01:00.0: Parsing VBIOS init table 1 at offset 0xEBFC
[drm] nouveau 0000:01:00.0: Parsing VBIOS init table 2 at offset 0xF26A
[drm] nouveau 0000:01:00.0: Parsing VBIOS init table 3 at offset 0xF3C7
[drm] nouveau 0000:01:00.0: Parsing VBIOS init table 4 at offset 0xF469
[TTM] Zone kernel: Available graphics memory: 431346 kiB.
[TTM] Zone highmem: Available graphics memory: 1027286 kiB.
[drm] nouveau 0000:01:00.0: 256 MiB VRAM
agpgart-sis 0000:00:00.0: AGP 3.0 bridge
agpgart: modprobe tried to set rate=x12. Setting to AGP3 x8 mode.
It seems the kernel thinks I have a PCI-Express slot:confused:
When I get that error message,I have to do a hard reset,and boot into my previous kernel(2.6.33-1.fc13.i686),but I don't have any problems with that one.My Graphics Card is a
1:00.0 VGA compatible controller: nVidia Corporation NV40 [GeForce 6800 GT] (rev a1) (prog-if 00 [VGA controller])
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 32 (1250ns min, 250ns max)
Interrupt: pin A routed to IRQ 16
Region 0: Memory at ce000000 (32-bit, non-prefetchable) [size=16M]
Region 1: Memory at b0000000 (32-bit, prefetchable) [size=256M]
Region 2: Memory at cd000000 (32-bit, non-prefetchable) [size=16M]
Expansion ROM at cfee0000 [disabled] [size=128K]
Capabilities: <access denied>
Kernel driver in use: nouveau
Kernel modules: nouveau, nvidiafb
My monitor is a ADI Microscan G1000.I compile the latest DRM,Nouveau Kernel Modules,Mesa and the xf86-video-nouveau driver all from the git repositories.I'll attach the relevant files to this post.
Regards,
STEVE555

leigh123linux
13th March 2010, 05:29 AM
I wasn't aware that AGP had a X12 mode :confused:



agpgart-sis 0000:00:00.0: AGP 3.0 bridge
agpgart: modprobe tried to set rate=x12. Setting to AGP3 x8 mode.