PDA

View Full Version : installator stops while running /sbin/loader



kamilsok
12th March 2010, 09:22 AM
Don't bash me for this post (I now, there are multiple threads on this issue, but believe me, I've checked and rechecked them all with no results), so here's the problem..

I have a Fedora 13 alpha x86-64 install DVD. Trying to run it on my HP 6710b (Intel Core 2 Duo T7100, GMA 965 chipset with integrated graphics.. I don't think any other info is needed). The DVD starts with a boot screen, on which I choose the standard 'Install Fedora' option. The bootloader starts.. and when it gets to '/sbin/loader/' and 'detecting hardware' part its freezes. Anaconda doesn't start at all. As I said, I've tried multiple options (including waiting abou 40 minutes for the installer to start).. nothing did help.

(I recently had openSuSE 11.3 installed but It didn't catch my mind so much, so now, after a long time, I've decided to sink back in to Fedora.. also was thinking about Gentoo, but I'm not on that level yet).

So.. if any of You guys has any ideas.. help;)

steelaworkn
12th March 2010, 11:59 AM
Just curious, what are you running for RAM and video card??

kamilsok
12th March 2010, 12:15 PM
What am I running for? I'm sorry but I don't understand the question:|

smr54
12th March 2010, 02:34 PM
He means how much RAM do you have and what sort of video card does it have?

kamilsok
12th March 2010, 02:37 PM
Aaa.. sorry for that;)

I have 3GB of RAM and a integrated Intel GMA 965 video card (didn't I mentioned it before).

steelaworkn
12th March 2010, 09:09 PM
Yes, sorry, I see your chipset in your first post. You have plenty of RAM. When you get to the boot screen, I'm pretty sure you can log off and do the install from command prompt (terminal). I've never done it, but I'll help you search for the method and get back to you.

Update: Is it as easy as opening a terminal and typing "cmdline" at the prompt? This is suppose to force a command line install with out the graphical interface.

kamilsok
13th March 2010, 08:42 AM
Ok..

I managed to run the installer with 'noprobe' option, and it worked.
But now it can't find the installation media. I've also tried the text mode, but I can't partition the drive in a custom way (I think this is a bug BTW).

After this I've tried to run the standard install options.. and this time it all worked;) I think this is a problem with detection of my video card (most of the time it isn't detected, but some time it works).

But.. after getting to the partition screen and setting up a couple of partitions the installer freezes (probably another bug).

Magickman
13th March 2010, 04:43 PM
The 'noprobe' option does not let Fedora installer look for your optic drive, so it is not visible. Every time I tried text mode install, all I got was a basic install, with no X. I think you may, just my inner voice talking here, you may have a bad burn. It has happened to me, on may occasions.

kamilsok
14th March 2010, 03:25 PM
Ha..

I've finally got it..

Here's the thing..

It turns out, that after running /sbin/loader and 'detecting hardware', when the screen goes blank the apps (CD/DVD check etc.) still do RUN! You just can't see it's running effects.on the screen.
I've discovered this while pressing Enter with the blank screen on. Suddenly the DVD drive started working.. after a while it stopped, and when I pressed Enter again the DVD was ejected. Then i realized DVD running was actually checked for errors, and then ejected waiting for the second CD. When I pressed the Right key and Enter again (so 'don't check another CD' and 'continue') DVD started running again and I SOW Anaconda running ON THE SCREEN (yes.. it was visible). And voila.. I was welcomed by the first installer screen.

So.. here is what You got to do (if You encounter a simiular motive, as I did):
- after /sbin/loader and 'detecting hardware' the screen goes blank, but actually it's running the CD/DVD check app in the background
- press Enter twice (to accept the check) or press Right and Enter once (to skip it)
- Your CD/DVD drive will start working
- when it stops (You will have to focus on Your hearing sense;)) press Enter once (the CD/DVD should eject, while the check app is waiting for another CD) and Right (to go from 'Check the second CD' to 'Continue' with the installation process)- You should hear the CD/DVD drive working again and after a while You should see the Anaconda welcome screen

smr54
15th March 2010, 03:12 AM
Thanks for this. In my case it was a USB install, and after hitting enter a few times, I got to the Anaconda screen.

I wonder if this is going to become a common bug, especially as so many netbooks use the integrated Intel video. (In my case, it wasn't a netbook, it was a two or three year old laptop.)

steelaworkn
15th March 2010, 03:51 AM
Wow, your patience has paid off. Hope all works well for you.

smr54
15th March 2010, 04:24 AM
I've made a post to the testing list about this. I have a similar card, GM965/960. I don't have the problem with a netbook that also has an integrated Intel card, but a different model, 945GME.

Hopefully, a few other people with the same card can test, and then someone can file a bug report.

(Probably not me, though, extremely busy these days, and probably wouldn't have time to follow up.)

kamilsok
15th March 2010, 09:25 AM
I've tested this for the current release (Fedora 12) and the installer loads the CD\DVD check screen with no problems but I remember having those problems with previous releases (Fedora 8/9) on my laptop.

Although after installing this alpha release seems very unstable for me (yum has some problems with packet dependencies, compiz not working very well - although this could be a bug concerning the video card driver etc), so I will probably play a little bit more (try to get this working - I was away from Fedora for 3 years I think.. now when I've changed my job learning it is a must almost as much as something that I want to do;)) and then go back to stable release and wait for the beta.

---------- Post added at 09:25 AM CDT ---------- Previous post was at 09:23 AM CDT ----------

On the other hand (I've just noticed) to avoid problems with graphics I might just turn off compiz.. then all should work fine;)

smr54
15th March 2010, 11:55 AM
No one has answered on the testing list. The trouble with filing a bug is that I don't have time to follow up--that is, if whoever gets it needs more info, or needs me to try patches, etc. The computer I used is one that I rarely use actually, just for testing--it's old and its battery lasts about 45 minutes. :-(

At any rate, thanks to you, I suspect that you (and I) will be able to help others if it comes up. Hitting enter a few times is a pretty simple solution. :)

Unfortunately, no doubt there will be that group who just tries it, sees the blank screen, mumbles, what a piece of cuss, and go on to another distribution--of course there's a reasonably good chance that it will be fixed by beta.

Lke you, Fedora is necessary for my job. Therefore, I use it and CentOS (also necessary), at home.
As for me, I think it's regressed quite a bit, but I'm a curmudgeon. :D

GoinEasy9
15th March 2010, 05:37 PM
When you file a bug with bugzilla, your email is sent a message when subsequent posts are made to that bug.

smr54
16th March 2010, 12:14 AM
Yes, I'm aware of that. My point when I say too busy means that if they want further research or testing of a patch, I may not have time to do so.

Someone on the testing list suggested booting with nohz=off as an option. I will give that a shot tonight. @kamilsok, if you have a chance, would you do the same? (We can always exit when it tells us it's alpha, do you want to continue).

---------- Post added at 07:14 PM CDT ---------- Previous post was at 01:50 PM CDT ----------

An update--I've added my comments to a bug already filed, at

https://bugzilla.redhat.com/show_bug.cgi?id=536721

I also found the nohz=off option to fix the problem.

AdamW
16th March 2010, 08:48 PM
If 'noprobe' fixes a problem like this, try 'ssb.blacklist=1'. If that works, you have https://bugzilla.redhat.com/show_bug.cgi?id=533746 .

mindcombatant
15th May 2010, 02:15 AM
So.. here is what You got to do (if You encounter a simiular motive, as I did):
- after /sbin/loader and 'detecting hardware' the screen goes blank, but actually it's running the CD/DVD check app in the background
- press Enter twice (to accept the check) or press Right and Enter once (to skip it)
- Your CD/DVD drive will start working
- when it stops (You will have to focus on Your hearing sense;)) press Enter once (the CD/DVD should eject, while the check app is waiting for another CD) and Right (to go from 'Check the second CD' to 'Continue' with the installation process)- You should hear the CD/DVD drive working again and after a while You should see the Anaconda welcome screen
Thanks, this worked for me! this is my first time using fedora, actually, previously i've used debian. even w/ this little glitch, though, i'm loving it!