PDA

View Full Version : Metacity or Gnome Window Manager is broken



bloodsugarwilks
3rd March 2010, 04:22 PM
This is a good one and extra kudos to anyone who can help me resolve it:

On a whim I installed an alternative Window manager for my Fedora 12 install called Enlightenment (http://www.enlightenment.org/) from here:

http://prdownloads.sourceforge.net/enlightenment/e16-1.0.2-1.fc11.i386.rpm?download

I logged out of my Gnome session and logged in using e16 which is the window manager. I thought it was awful. I logged out, and logged back in under Gnome. Then I uninstalled the package using:

# rpm -e <packagename>

I then logged back out and even attempted to reboot my machine and whenever I log into my normal desktop now, the windows surrounding applications are gone. For example the window border that contains the ability to drag the window or minimize, maximize and close are gone.

I figured out a very undesirable workaround by adding the command "metacity --replace" to my startup applications.

I am wondering if anyone can help me get the system (Metacity and/or whatever the gnome window manager is) back to working order.

Thoughts? Do you need more info?

silverglade00
3rd March 2010, 05:45 PM
You might want to try reinstalling Gnome and/or Metacity. That might reconfigure things the way you want. Are you running Compiz? If so, you could try
gtk-window-decorator --replace and/or make sure the Window Decorations plugin is activated. It also might be helpful if we knew what video driver and video card you use.

JohnJasonJordan
3rd March 2010, 05:45 PM
... now, the windows surrounding applications are gone. For example the window border that contains the ability to drag the window or minimize, maximize and close are gone.

I figured out a very undesirable workaround by adding the command "metacity --replace" to my startup applications.

You are correct in that Metacity is the window manager for Gnome.

I don't know for sure if this is the problem, but look in your home folder for a file called ~/.local/share/applications/metacity.desktop. If it exists, rename it, then log out and back in again.

I don't have any other ideas.

Nokia
3rd March 2010, 06:07 PM
Did you get the latest metacity update ?
http://fedora.univ-nantes.fr/fedora.redhat.com/fedora/linux/updates/12/x86_64//metacity-2.28.0-14.fc12.i686.rpm
http://fedora.univ-nantes.fr/fedora.redhat.com/fedora/linux/updates/12/x86_64//metacity-2.28.0-14.fc12.x86_64.rpm

bloodsugarwilks
3rd March 2010, 06:35 PM
I just checked that directory on my system and I do NOT even have a metacity.desktop file in that folder. Anyone have one I can copy?

I have logged out, logged in, reinstalled Gnome, and reinstalled metacity many times now. Nothing works.





You are correct in that Metacity is the window manager for Gnome.

I don't know for sure if this is the problem, but look in your home folder for a file called ~/.local/share/applications/metacity.desktop. If it exists, rename it, then log out and back in again.

I don't have any other ideas.

Nokia
3rd March 2010, 06:38 PM
Try
cat /usr/share/applications/metacity.desktop
[Desktop Entry]
Type=Application
Encoding=UTF-8
Name=Metacity
Name[ar]=مِتسِتي
Name[as]=Metacity
Name[ast]=Metacity
Name[az]=Metacity
Name[be]=Metacity
Name[be@latin]=Metacity
Name[bg]=Metacity
Name[bn]=মেটাসিটি
Name[bn_IN]=Metacity
Name[br]=Metacity
Name[bs]=Metacity
Name[ca]=Metacity
Name[ca@valencia]=Metacity
Name[cs]=Metacity
Name[cy]=Metacity
Name[da]=Metacity
Name[de]=Metacity
Name[dz]=མེ་ཊ་སི་ཊི།
Name[el]=Metacity
Name[en_CA]=Metacity
Name[en_GB]=Metacity
Name[es]=Metacity
Name[et]=Metacity
Name[eu]=Metacity
Name[fa]=متاسیتی
Name[fi]=Metacity
Name[fr]=Metacity
Name[ga]=Metacity
Name[gl]=Metacity
Name[gu]=મેટાસીટી
Name[ha]=Metaciti
Name[he]=Metacity
Name[hi]=मेटासिटी
Name[hr]=Metacity
Name[hu]=Metacity
Name[hy]=Մետասիթի
Name[id]=Metacity
Name[ig]=Metacity
Name[is]=Metacity
Name[it]=Metacity
Name[ja]=Metacity
Name[ka]=Metacity
Name[kn]=ಮೆಟಾಸಿಟಿ
Name[ko]=메타시티
Name[ku]=Metacity
Name[la]=Metacity
Name[lt]=Metacity
Name[lv]=Metacity
Name[mai]=मेटासिटी
Name[mg]=Metacity
Name[mk]=Metacity
Name[ml]=മെറ്റാസിറ്റി
Name[mn]=Metacity
Name[mr]=Metacity
Name[ms]=Metacity
Name[nb]=Metacity
Name[ne]=मेटासिटि
Name[nl]=Metacity
Name[nn]=Metacity
Name[oc]=Metacity
Name[or]=ମେଟାସିଟି
Name[pa]=ਮੈਟਾਸਿਟੀ
Name[pl]=Metacity
Name[pt]=Metacity
Name[pt_BR]=Metacity
Name[ro]=Metacity
Name[ru]=Metacity
Name[sk]=Metacity
Name[sl]=Metacity
Name[sq]=Metacity
Name[sr]=Метасити
Name[sr@latin]=Metasiti
Name[sv]=Metacity
Name[ta]=மெட்டாசிட்டி
Name[te]=మెటాసిటి
Name[th]=Metacity
Name[tk]=Metacity
Name[tr]=Metacity
Name[uk]=Метасіті
Name[vi]=Metacity
Name[wa]=Metacity
Name[xh]=Imetacity
Name[yo]=Metacity
Name[zh_CN]=Metacity
Name[zh_HK]=Metacity
Name[zh_TW]=Metacity
Exec=metacity
NoDisplay=true
# name of loadable control center module
X-GNOME-WMSettingsModule=metacity
# name we put on the WM spec check window
X-GNOME-WMName=Metacity
# back compat only
X-GnomeWMSettingsLibrary=metacity
X-GNOME-Bugzilla-Bugzilla=GNOME
X-GNOME-Bugzilla-Product=metacity
X-GNOME-Bugzilla-Component=general
X-GNOME-Autostart-Phase=WindowManager
X-GNOME-Provides=windowmanager
X-GNOME-Autostart-Notify=true

silverglade00
3rd March 2010, 06:39 PM
You could also try going into System - Preferences - Appearance and try to choose a theme again. That might reset your window borders.

Dies
3rd March 2010, 08:15 PM
Could you please post the output from


gconftool-2 -R /desktop/gnome/session

bloodsugarwilks
3rd March 2010, 08:18 PM
Could you please post the output from


gconftool-2 -R /desktop/gnome/session

gconftool-2 -R /desktop/gnome/session
required_components_list = [windowmanager,panel,filemanager]
default_session = [gnome-settings-daemon]
idle_delay = 5
/desktop/gnome/session/required_components:
filemanager = nautilus
windowmanager = e16
panel = gnome-panel


Wow.... looks like it is saying e16 still for some reason. Does a fix exist for this?

Dies
3rd March 2010, 08:23 PM
Run

gconftool-2 -s -t string /desktop/gnome/session/required_components/windowmanager "metacity"
then confirm that the change was made by running the last command I gave you, if it was changed successfully go ahead and log out and back in.

If for some reason it didn't change then do

gconftool-2 --recursive-unset /desktop/gnome/session

bloodsugarwilks
3rd March 2010, 08:45 PM
gconftool-2 -R /desktop/gnome/session required_components_list = [windowmanager,panel,filemanager]
default_session = [gnome-settings-daemon]
idle_delay = 5
/desktop/gnome/session/required_components:
filemanager = nautilus
windowmanager = metacity
panel = gnome-panel

This is what the output looks like now. It seems to have been fixed!

Thank you SO much. Kudos!

---------- Post added at 12:45 PM CST ---------- Previous post was at 12:35 PM CST ----------

Thanks again to everyone who contributed and a special thanks for Dies for letting me know how to reset the windowmanager.

I'm going to start teaching myself about GConfTool now!

va9709
4th April 2010, 09:15 PM
Thank you very much for bloodsugarwilks and of course Dies. Gnome Desktop has been fixed and the really boring condition has gone. Thanks again...