PDA

View Full Version : refresh rate at console mode



huanghuancn
1st March 2010, 02:35 PM
I use the integrated graphics card from intel -- Intel GMA3100.

At console mode, I set the resolution to 1024x768 through vga=ask.

But the refresh rate is too low at 60hz, and my eyes are uncomfortable.

I tried fbset utility, but it doesn't work on my machine. (There is no response)

Can anyone help me increase the refresh rate to 75hz?

Thank you very much!

JEO
1st March 2010, 05:41 PM
I am sorry but when you set the video mode using vga=ask it uses the vesa framebuffer driver and that does not support refresh rate setting.

You need a chipset specific framebuffer driver such as i810fb or intelfb. I do not know the state of intelfb but i810fb seems to be included with Fedora, although blacklisted in /etc/modprobe.d/blacklist.conf

huanghuancn
2nd March 2010, 02:56 AM
Thank you :)

I am new to linux. Can you tell me how to disable vesafb and enable intelfb/i810fb in fedora, and set the refresh rate to 75hz?

By the way, I find a module called i915.ko. Does it have anything to do with video setting?

Thank you very much!

JEO
2nd March 2010, 07:49 AM
i915.ko is for hardware 3d acceleration in graphical mode, it is not a framebuffer driver.

The way you control a framebuffer driver is through module parameters. You can see what parameters a module has with the modinfo command:

modinfo -p i810fb
mode_option:Specify initial video mode
ddc3:Probe DDC bus 3 (default = 0 = no)
dcolor:use DirectColor visuals (default = 0 = TrueColor)
sync:wait for accel engine to finish drawing (default = 0)
extvga:Enable external VGA connector (default = 0)
mtrr:Use MTRR (default = 0)
accel:Use Acceleration (BLIT) engine (default = 0)
vsync2:Maximum vertical frequency of monitor in Hz (default = 60)
vsync1:Minimum vertical frequency of monitor in Hz (default = 50)
hsync2:Maximum horizontal frequency of monitor in KHz (default = 30)
hsync1:Minimum horizontal frequency of monitor in KHz (default = 29)
vyres:Virtual vertical resolution in scanlines (default = 480)
yres:Vertical resolution in scanlines (default = 480)
xres:Horizontal resolution in pixels (default = 640)
bpp:Color depth for display in bits per pixel (default = 8)
voffset:at what offset to place start of framebuffer memory (0 to maximum aperture size), in MiB (default = 48)
vram:System RAM to allocate to framebuffer in MiB (default=4)

It looks like the parameters you need to increase are vsync2 and hsync2 (use values that your monitor can support) (if this driver works for your card). Also it looks like paramters xres should be 1024, yres 768, and bpp 24 (or maybe use the mode_option parameter instead). To enable this module you will have to remove it from /etc/modprobe.d/blacklist.conf. I don't know if it will work for your card or not you will have to modprobe it. See the man page for modprobe on how to specify module parameters. To disable the built in vesafb driver do not use a vga= parameter in the kernel command line.

---------- Post added at 10:49 PM CST ---------- Previous post was at 09:37 PM CST ----------

I just noticed that there is an "fbset" command that you can use to change the mode on the fly after you load the framebuffer driver. So you can try

modprobe i810fb
fbset 1024x768-75

You can view the man page for fbset for all the details.

huanghuancn
2nd March 2010, 09:16 AM
Thank you. I tried:

modprobe i810fb
fbset 1024x768-75

, but my screen becomes a blur/mess. Do you think it's because i810fb is not
compatible with my hardware? Or should I try intelfb? That would need recompiling
the kernel.

JEO
2nd March 2010, 09:33 AM
While it is blurry you could try typing fbset 1024x768-60 and then dmesg |tail to see what is going on. Also look at dmesg after you modprobe.

I have no idea about the intelfb driver sorry.