PDA

View Full Version : /etc/X11/gdm/gdm.conf



DanMachado
28th February 2010, 01:20 PM
Hi everybody!

I am running Fedora 12 and for some reason I need to disable the logout and reboot options from the GNOME logout menu. I found a solution in here http://forums.fedoraforum.org/archive/index.php/t-72709.html however I could not have found the file gdm.conf.

My question is where to find it or how to make one for my laptop.

Regards.

Dan

madhavdiwan
28th February 2010, 04:43 PM
your looking in the wrong place

the file is in /etc/gdm

su -c "gedit /etc/gdm/custom.conf"



its pretty much a blank file with sections ...

just add the tags you want to invoke, if the section is missing , add it in brackets

for instance


[greeter]

SystemMenu=false


next lock down your desktop reboot options by ( in Fedora 11 and 12 ) editing

/etc/event.d/control-alt-delete

to look something like this


# control-alt-delete - emergency keypress handling
#
# This task is run whenever the Control-Alt-Delete key combination is
# pressed. Usually used to shut down the machine.

start on control-alt-delete

echo " You should not be trying to turn this system off - The Management"

# exec /sbin/shutdown -r now "Control-Alt-Delete pressed"






You should also look into using the pessulus lockdown editor for Gnome

as root user run


yum install pessulus

and then run


pessulus


it will give you a lot of options to configure including screensaver and logout , and "enable/disable command line" functions that you can enable or disable


Keep in mind that when you disable CTrl-Alt-Delete .. you can still turn the system off .. just not as easily.
so , you may also want to harden the system down a bit more ...this all depends on what your typical users do .. IE if they are prone to using terminals and command lines or work only in gui based desktops , as well as on how much you trust them, etc.



Oh and you CAN edit menus

look in HELP in the GNOME Desktop System Administration Guide and look for

Custom Menus

you can also get to this via pressing the help button in pessulus

DanMachado
1st March 2010, 03:25 PM
Hi madhavdiwan,

Thanks for your reply. I followed your suggestion but the shut down option still appears in the logout menu. My custom.conf file jus has the following lines where I added [greeter] SystemMenu=false.



# GDM configuration storage

[xdmcp]

[chooser]

[security]

[debug]

[greeter]

SystemMenu=false

About pessulus, well it has son useful options but not that one about the shut down in the logout menu.

Dan

BugRocks1
1st March 2010, 05:37 PM
Did you try configuring the PAM modules for those apps?

http://www.kernel.org/pub/linux/libs/pam/Linux-PAM-html/sag-pam_succeed_if.html

Mikko
1st March 2010, 06:34 PM
Thanks for your reply. I followed your suggestion but the shut down option still appears in the logout menu.

Gdm has a bit of a history of ignoring documented config options in later versions (a not documenting the change). I've been bitten by this once or twice. I don't know if this is the case here, but you may want to check the Gdm developer's sites to see if others have complained.