PDA

View Full Version : Fiddlesticks on Fedora - Updating KDE Killed My GUI.



ReaperLove
25th February 2010, 03:27 AM
Time and time again, I run into numerous problems with fedora, some maybe self-inflicting, however, this most recent one is not, total random ***** up with fedora. Earlier today I was simply on my laptop watching videos, I finish, shut my PC down. I reboot hours later only to get greeted by the Fedora Boot Splash Screen and shortly after nothing but blackness, no login screen or nothing, I see the mouse cursor shortly after the boot splash for 2 seconds then it disappears. I made no recent changes to any files besides applying some updates via the package manager, what makes me more pissed off I had to recently reformat due to a self-blunder and lost crucical data, now a week has passed and I've managed to "rebuild" my data loss back up. Now this is hindering my college course work which is done online. I think it's time for a new linux distrobution or a work-around for this problem A.S.A.P!

Dan
25th February 2010, 03:34 AM
Okey dokey.

Two things. First, watch the language! Second, DANG! Might be time to default to MINT or something else which isn't a "bleeding edge" distro. Fedora is a heck of a distro, but for mission critical work, it just isn't the best way to go -- unless you run one or two releases behind.

Alternatively, RHEL or CentOS would be a better choice in that the likelihood of a vunderbork update is much lower.

bob
25th February 2010, 03:38 AM
You don't bother to look at the changes that may have happened with your updates. For instance, maybe it's graphics related? There's far too little here to work with so it's been moved to Rants, as that's what you're doing. If you want help, then give us the details of what went wrong. Check your dmesg, your /var/log/messages and see if you can find some clues.

Otherwise, realize that you're doing critical work with a testing distro and move on to something dead stable, such as CentOS or Debian.

Lastly, this is a family Forum. We have kids and guys and gals of all ages checking the posts. As stated in the Posting Rules, we're not about to tolerate the language you may have in your dorm room. Please think before posting.

Ummmm...yeah...like what Dan said while I was busy typing.

ReaperLove
25th February 2010, 03:48 AM
F11 is still a "testing" distro? I'm thinking of switching to gentoo. However, I cannot seem to find the proper hot-key combination to boot into terminal mode and check the dmesg, and I assuming it is graphics related because they had a few kde updates come through however, I do need something more stable for school work.

bob
25th February 2010, 03:56 AM
FEDORA is a testing distro, regardless of version and any update that's passed down has the potential to bork things for some people. Try 'ctrl-alt-F2' to get a login screen. And, if there's a prior kernel, have you tried booting into that to see if it also fails (probably will, btw). And, to check the updates, once in a terminal mode, I use " rpm -qa --last | tac " which lists the updates from oldest to newest.

Edit: Further aside. One of the versions I'm playing with is the Rawhide testing version (aka F14) which recently broke my kmod-nvidia. So, I went into terminal mode and used 'rpm -qa | grep nvidia' to find the kmods and assorted packages that might have been involved. Then, using yum, I removed them and made sure that I removed the 'blacklist-nouveau' entry on my kernel line. At least that got me back into a graphical mode, although I lost 3D for the moment.

dragonbite
25th February 2010, 04:41 AM
F11 is still a "testing" distro? I'm thinking of switching to gentoo. However, I cannot seem to find the proper hot-key combination to boot into terminal mode and check the dmesg, and I assuming it is graphics related because they had a few kde updates come through however, I do need something more stable for school work.

Gentoo? Ha, that's a good one.

Ok, you're mad because you lost data (did you do any backups?) so you are going to go from a testing distro to a complie-everything-yourself distro? I ran Gentoo a while back (right after Red Hat and before Ubuntu) and believe me... I'd take my chances with Fedora.

Is Cntrl + Alt + F2 (F2 through F6) the Hot Key combo you are looking for?

I haven't fooled around with Debian, but Ubuntu has served me very well so far. I usually try something else for non-technical reasons because the technical ones usually have a work-around.

CentOS is a stable one, though if you are using wireless and need codecs you'll have to do a little more work. I have a laptop with Intel wireless and Ubuntu, openSUSE and Fedora saw it out-of-the-box and ran with it, but CentOS didn't.:(

If you prefer KDE over Gnome, then you may want to look at openSUSE or Mandriva as KDE is their default desktop environment and most questions, answers and development time will be spent in KDE and less in Gnome.

I do, sometimes, wish there was a Fedora-based distro in-between the "testbed" Fedora and the "stable" Red Hat / CentOS for desktops. Kinda like an Ubuntu-for-RedHat. I haven't checked to see if "Hat Trick" Linux is taken yet...

ReaperLove
25th February 2010, 06:34 AM
Yes, I booted an older kernel version same thing, I'll try that hot-key combination. and run the rpm command you have given. Well how is openSuse? I use CentOS on the computer science's building lab for my cmps courses.

---------- Post added at 09:34 PM CST ---------- Previous post was at 07:56 PM CST ----------

I ran through several logs, all updates done today when the problem occurred, the updates being prior to the problem were

kde-settings
kde-settings-kdm
kdelibs-common
kde-settings-pulseaudio
shared-desktop-onotologies
webkitkde
qt

thats from the yum logs and rpm command that i was told to issue above.
After sorting through various files
I ran startx and was greeted by a cannot start kdeinit4 check installation I am looking for a fedora based solution

bob
25th February 2010, 12:16 PM
I don't use KDE, so others will have solutions for you if we move this over to the General Forum rather than leaving it as a Rant. Thread Moved. Also changed the Title to reflect a problem, rather than a statement.

forkbomb
25th February 2010, 02:04 PM
You don't want Gentoo. Trust me. I ran it for 8 months. It's an incredible distro - near perfect - but one that I would never under any circumstances recommend to anybody. I miss it, but "need" Windows on my main machine. If you have problems on Fedora and your first response is to hit the forums with a post like above...

What's worst is that if Gentoo breaks irrevocably, you're out for awhile. With Fedora, if you have a problem like the above, salvation is at most just a couple hours away if you just do a reinstall. If your data is backed up and something borks, you can shove the install disc in, start up the install, and just start clean. With Gentoo, if you bork your system by screwing up Portage or muck up a kernel without a backup, you pretty much have to rebuild the whole system from scratch. It probably took me a good 24 hours to get Gentoo installed totally from putting in the disc to having a usable desktop environment. Not that the compile jobs take that long, just that there are certain points where you need to wait and I just took my time. Somebody who really knows what they're doing? Maybe 8 hours from bare metal to usable install.

Just being honest. Go with Ubuntu (9.10 is a cinch) or Mint.

ReaperLove
25th February 2010, 07:11 PM
I simply booted into command line, set up a wired connection ran a few yum updates for the kde and kde libs and problem solved, I think im going to try out mandriva for a while