View Full Version : F12 x86 64 iso dell 530 optiarc dvd+/-rw dvd can't find driver

14th February 2010, 08:29 PM
I have tried both the i386 (worked) and x86 64 dvd iso installations. Both sha1sum results don't match. I got a torrent copy and it's sha1sum doesn't match either.

The problem is with the x86 64 iso dvd. It boots but takes a long time(2-3 minutes)to load ata_piix driver when the title bar says Loading SCSI driver. After it finishes loading that driver, when prompted for the installation method, if I select CD/DVD, I'm prompted to select a driver or install disk for driver. I've tried several different generic ata drivers from the list and end up with a strange memory map interwoven with a multi color(red, white and blue)

copied output as best I can.

======= Memory map: ========
0064600 r-xp 00000000 00:01 39 /sbin/loader
6000-00859000 rw-p 00246000 00:01 39 /sbin/loade
00859000-009ec000 rw-p 00859000 00:00 0 [heap]
aaaaaaae000-2aaaaaab1000 rw-p 2aaaaaaae000 00:00 0
2aaaac000000-2aaaac02c000 rw-
p 2aaaac000000 00:00 0
2aaaac02c000-2aaab0000000 ---p 2aaaac02c000 00:00 0
ac3f000-7fffcac540000 rw-p 7ffffffea000 00:00 0 [stack]
adfe000-7fffcae00000 r-xp 7fffcadfe000 00:00 0 [vdso]
ffff600000-ffffffffff601000 r-xp 00000000 00:00 0 [vsyscall]

All I can do at this point is boot again.

I've tried FTP and http instead of cd/dvd and that process fails because it can't find the file stage2.img.

I don't have a 4 GB USB drive. And I'm not well versed enough to figure out how to mount a hard drive partition and then install the software over it. :)

I'm trying to get a torrent copy of the x86 64 iso. But that is another 2 hours away. :( and I don't think it is going to help.


Inspiron 530 Intel Core2 processor Q6600 (2.40Ghz 1066FSB) w/Quad Core Technology and 8MB cache
4GB DDR2 SDRAM at 667MHz
Integrated Intel Graphics Media Accelerator 3100
750GB Serial ATA 2 Hard Drive 7200RPM
16X DVD+/-RW Drive (BIOS calls it an Opticarc dvd+/-rw) (I used DVD+r discs)

Anyone have any ideas?

14th February 2010, 10:10 PM
"...when prompted for the installation method, if I select CD/DVD, I'm prompted to select a driver or install disk"

Are you sure you read that correctly?

If you are choosing install method for the driver you should be able to choose a continue or done.(and this should not have shown up anyway because normal atadata scsi drvers are included. (Make sure you have the bios set for a normal ide legacy pata disk and not sata or raid or some other.)

If selecting system install method and you select cd/dvd, it should just start up.


15th February 2010, 12:07 AM

I have run into this same problem with a 530 I was installing CentOS onto some time ago. I know this sounds illogical but the fix to installing was to boot to bios setup > System Peripherals > SATA settings and this is the weird part: set it to RAID even if you are not going to use raid. I can't remember the exact reason why but had something to do with releasing some setting to OS.

Hope this helps,


15th February 2010, 05:48 AM
Reply to Slowjet

Box title is "Installation Method"

Choices are:
Local DC/DVD
Hard Drive
NFS directory

Local CD/DVD is highlighted
I tab to OK and hit enter

New window appears titled "No driver found"

Text reads Unable to find any devices fo the type needed for this installation type.
Would you like to manually select your driver or user a driver disk?

3 choices

Select driver
Use a driver disk
or Back.

If i select any driver, I get a memory dump and nothing happens. :(

---------- Post added at 11:48 PM CST ---------- Previous post was at 11:41 PM CST ----------

reply to kyryder

I found the BIOS setting. When I changed it to RAID. It opened the DVD and the following message appears.

Box title "Disc Not Found"

The Fedora disc was not foundin any of your CDROM drives. Please insert the Fedora disc and press OK to retry.

I tried swapping to the second DVD I made. Same message appears. Some progress, perhaps if I burn CD's instead of a DVD it will work. :(

15th February 2010, 10:07 AM
I tried the f12 unity re-spin dvd today and no such choices came up.


15th February 2010, 03:33 PM
Are you adding "linux askmethod" to the kernel line?

That is the only time I have seen those choices available


16th February 2010, 12:10 AM
I guess I'm not doing "linux askmethod" since I don't know what that means or how to edit the kernel.

I think it bears stating again.

I have installed F12 i386 on this machine.

I'm only having this issue with the F12 x86 64 installation iso DVD.

Trying the CD's shortly.[COLOR="Silver"]

---------- Post added at 06:10 PM CST ---------- Previous post was at 01:28 PM CST ----------

loaded from CD's and it completed. But when I rebooted it to use it I got
kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(9,0)

Going to check other posts to see if anyone else has that issue. I think I may have seen it. :(

Found one post pointing to a grub.conf file issue. but when I boot from rescue the grub files look ok. I did post to that thread as well.
Not sure policy for updating 2 posts. :(

I changed the /boot to 300 (which I thought I saw recommended somewhere for f12.) It didn't end on a cylinder boundary.
So I changed it to 301 and it booted up.

I think I may have uninstalled something while trying to get mysql installed/uninstalled/installed. and then it didn't boot. Trying a clean install again.