PDA

View Full Version : How to downgrade gdm?



alex95bg
13th February 2010, 10:40 AM
Hi guys.
Yesterday i installed CentOS, just to remember old Fedora releases, and to look at a normal gdm and kde 3.5. I'm a bleeding-edge distro user (i also have debian sid and sabayon), and i like Fedora. But some new versions of open source software really annoy me. The new, unfinished, unthemable gdm is awful for me, is there a way i can downgrade it in fedora 12?
I'd liike to use the themable one, with the gui. I really liked the autologin (yes, not waiting 5 seconds for timed login) and themes, there are so much out there.
Also, can i get Fedora 10 style gnome menus? I mean, in fedora 10 if i remember correctly the System menu had other sliding submenus, that kept the menu neat. Is there any way i can get them or are they just the result of an older gnome version? I really hope no dependencies will break

Also, one last question :) Any way to get PHP 5.2.12 without compiling it, i'd like to use the Fedora version since i don't want to fill my desktop machine with devel packages?

I've been using Fedora since 7 (Moonshine if i remember corectly) and i love it. I know that the fedora devs aren't responsible for the way some packages go in newer versions.

edit: and also any chance of getting rhgb?

second edit: I lost the error message so i had to repeat the procedure
http://forums.fedoraforum.org/showthread.php?t=193067 doesn't work in 12

Transaction Check Error:
file /usr/lib64/bonobo/servers/GNOME_FastUserSwitchApplet.server from install of fast-user-switch-applet-2.20.0-1.fc8.x86_64 conflicts with file from package gdm-user-switch-applet-1:2.28.2-1.fc12.x86_64
file /usr/share/gnome-2.0/ui/GNOME_FastUserSwitchApplet.xml from install of fast-user-switch-applet-2.20.0-1.fc8.x86_64 conflicts with file from package gdm-user-switch-applet-1:2.28.2-1.fc12.x86_64
I will try to remove all gdm* packages, hope i don't break something

alex95bg
14th February 2010, 11:11 PM
Bump, anyone? :(

Maryyy
15th February 2010, 01:50 AM
Well, it'll not help, but for the record, last themeable gdm was 2.20. Anything later can't use themes. With exception of background. :( But I just got used to it, as the background is the most important part of it for me anyway. :)