PDA

View Full Version : network in guest windows (kvm)



emilio
11th February 2010, 02:16 AM
Hi!

I installed a Windows 7 as guest os on my x86_64 fedora 12 using the virtual machine manager.
My problem is that I can't manage the guest to connect to the internet.
I connect from the host via wireless, and the 'default' network in libvirt is configured. The guest is seeing a network device, but it says, there is "no network access".

Could someone help me with this?

Thanks in advance!

cheerio158
27th February 2010, 07:51 PM
Sorry that I can't help you because I'm not so far yet!

How did you get past this supposedly "closed" bug (https://bugzilla.redhat.com/show_bug.cgi?format=multiple&id=547028) Also, there is a related post (http://forums.fedoraforum.org/showthread.php?t=236372) in this forum.

I'm currently stuck on the black screen after first reboot. (I tried building the Windows 7 Ultimate VM twice using virt-manager/kvm.)

What type of VM did you build? KVM? What graphics option did you use?

Any help is appreciated.


$ rpm -qa| egrep 'virt|qemu|kvm'
qemu-kvm-0.11.0-13.fc12.x86_64
virt-viewer-0.2.0-1.fc12.x86_64
gpxe-roms-qemu-0.9.9-1.20091018git.fc12.noarch
qemu-system-x86-0.11.0-13.fc12.x86_64
qemu-img-0.11.0-13.fc12.x86_64
python-virtinst-0.500.1-2.fc12.noarch
libvirt-0.7.1-15.fc12.x86_64
virt-manager-0.8.2-1.fc12.noarch
qemu-common-0.11.0-13.fc12.x86_64
libvirt-python-0.7.1-15.fc12.x86_64
libvirt-client-0.7.1-15.fc12.x86_64

emilio
27th February 2010, 09:45 PM
I installed the x86 version of Windows 7 Professional.
I used kvm, and if I remember correctly, I left every other options untouched.

So, the 32 bit version of Win 7 works.
But I'm still not able to use the network within the virtual machine.

cheerio158
28th February 2010, 12:29 AM
Thanks for the quick response. I tried again (for the third time) with slightly different parameters and no luck.

Doing a lot of Googling, it is apparent that this is a problem with Ubuntu too.

If I get it to work, I'll be sure to post how the networking configuration goes.

Thanks!

gja2
4th May 2010, 05:15 PM
My experience is with a XP as a guest machine. After some updates it quit connecting with the Internet. The XP is 192.168.122.35 and the Fedora 12 host is 192.168.1.100. Fedora had correct routes with a default gateway of 192.168.1.1 which is the address translation firewall for my network. However, the XP had the same default gateway but with no route to the 192.168.1.0 network.
On the XP a command like 'ROUTE -f -p ADD 0.0.0.0 MASK 0.0.0.0 192.168.122.1 METRIC 10 IF 2' allows IP to begin to work. At that point arp on Fedora show the proper interfaces.
The DNS servers are not set up properly on the XP. I suspect this may not be the most direct way to fix the problem and it requires some IP knowledge.