PDA

View Full Version : XP disappeared from Boot options



815T0
10th February 2010, 03:24 PM
Had dual boot with Fedora 12 which still is fine but after my hard disk failed (ntfs) with all my data have been unable to access XP which is installed on the same disc as Fedora.

Device Boot Start End #cyls #blocks Id System
/dev/sda1 0+ 1136- 1137- 9126912 7 HPFS/NTFS
/dev/sda2 * 1136+ 1161- 26- 204800 83 Linux
/dev/sda3 1161+ 9728 8568- 68816449 8e Linux LVM
/dev/sda4 0 - 0 0 0 Empty


default=0
timeout=5
splashimage=(hd0,1)/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.31.12-174.2.3.fc12.i686)
root (hd0,1)
kernel /vmlinuz-2.6.31.12-174.2.3.fc12.i686 ro root=/dev/mapper/vg_linuxamanda-lv_root noiswmd LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=uk rhgb quiet
initrd /initramfs-2.6.31.12-174.2.3.fc12.i686.img
title Fedora (2.6.31.5-127.fc12.i686)
root (hd0,1)
kernel /vmlinuz-2.6.31.5-127.fc12.i686 ro root=/dev/mapper/vg_linuxamanda-lv_root noiswmd LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=uk rhgb quiet
initrd /initramfs-2.6.31.5-127.fc12.i686.img
title Other
rootnoverify (hd0,0)
chainloader +1

In a mad experiment changed last three lines to read
root (hd0,0)
makeactive
chainloader +1
thinking it would help, but just proves a little knowledge can be dangerous!!
It still is working but would like to get into XP without having to do a complete re-install.

Thanks for reading :-)

stoat
10th February 2010, 04:01 PM
Hello 815T0,

Well, the boot loader files of a Windows system are not always on the same partition as the system itself. One possible explanation is that XP's boot loader files where in a partition that was on the failed hard drive. But for that to have happened, that hard drive that failed would have been the first drive in the BIOS boot order. Was it? Anyway, it happens all the time.

If you don't think that happened, then you can mount that lone remaining NTFS partition and simply look for the boot loader files to confirm their continued existence. That partition is the only possible place in what you posted for the XP boot loader files to be.

In a Fedora terminal...
su
mkdir /mnt/temp
mount /dev/sda1 /mnt/temp
ls /mnt/tempThat should list the boot loader files of XP if they are there (ntldr, ntdetect.com, boot.ini). If they are there, then your original grub.conf "Other" section should have booted XP. What exactly happens when you try that?

If the boot loader files are nowhere to be found, and the XP system is valuable, then it's not that hard to reconstruct those three files. I will help if that becomes necessary and if you need help.

815T0
10th February 2010, 05:45 PM
Cheers for replying, Stoat
This is what I get
boot.ini NTDETECT.COM pagefile.sys System Volume Information
Config.Msi ntldr Program Files toolkit_widget.gif
Documents and Settings NVIDIA RECYCLER WINDOWS
What must I try?

stoat
10th February 2010, 06:42 PM
So what exactly happens when you choose "Other" in the Fedora GRUB menu with this in the grub.conf?


title Other
rootnoverify (hd0,0)
chainloader +1While you're checking things out, what does that boot.ini file look like?
su
mount /dev/sda1 /mnt/temp
cat /mnt/temp/boot.ini

815T0
11th February 2010, 02:37 PM
Just comes up with Fedora option. Nothing interrupts the Fedora boot. I got this in the ini file,

[boot loader]
timeout=1
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOW S
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect /noexecute=alwaysoff

:(

stoat
11th February 2010, 08:59 PM
It all looks okay to me (grub.conf, boot.ini, fdisk). So if you're not seeing the GRUB menu, then edit the grub.conf file to comment out (with the # character) or delete the hiddenmenu command. Reboot after that and you should see the GRUB menu. Choose "Other" and see if Windows boots.

815T0
12th February 2010, 05:09 AM
Hi stoat,
Yes did that but there is still only the one option after #hiddenmenu. Shall I delete it instead?

Disregard that. Used gedit instead of nano and now grub.conf actually reads #hiddenmenu but now the three options appear but I cannot now interrupt fedora loading by default

stoat
12th February 2010, 05:18 AM
Yes did that but there is still only the one option after #hiddenmenu. Shall I delete it instead?No. It wouldn't make any difference.

So is the grub.conf different from what was originally posted? After all, you said you changed it. Maybe you should post it again. It could be misconfigured. It's extremely syntax sensitive. While you're at it, post the fdisk report, too...
su
cat /boot/grub/grub.conf
fdisk -l

815T0
12th February 2010, 05:25 AM
Disregard that last comment. Checked with gedit instead of nano and now grub.conf actually reads #hiddenmenu but now the three options appear but I cannot now interrupt fedora loading by default

#boot=/dev/sda
default=0
timeout=5
splashimage=(hd0,1)/grub/splash.xpm.gz
#hiddenmenu
title Fedora (2.6.31.12-174.2.3.fc12.i686)
root (hd0,1)
kernel /vmlinuz-2.6.31.12-174.2.3.fc12.i686 ro root=/dev/mapper/vg_linuxamanda-lv_root noiswmd LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=uk rhgb quiet
initrd /initramfs-2.6.31.12-174.2.3.fc12.i686.img
title Fedora (2.6.31.5-127.fc12.i686)
root (hd0,1)
kernel /vmlinuz-2.6.31.5-127.fc12.i686 ro root=/dev/mapper/vg_linuxamanda-lv_root noiswmd LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=uk rhgb quiet
initrd /initramfs-2.6.31.5-127.fc12.i686.img
title Other
root (hd0,0)
makeactive
chainloader +1

Ah, is it that the first boot line is commented out?

stoat
12th February 2010, 06:31 AM
Ah, is it that the first boot line is commented out?No, that is always commented out like that.

So now you are seeing the Fedora GRUB menu, but choosing "Other" results in Fedora booting? Do I understand the situation correctly? Can you choose either Fedora and boot into either Fedora? Try this to normalize that "Other" section (my only idea at the moment)...
title Windows XP
rootnoverify (hd0,0)
chainloader +1The title change is optional. You can change that to whatever you want to appear in the menu for XP. It is not the problem though.

The rootnoverify command does the same thing as the root command, but it causes GRUB not to try mounting the partition. Root still usually works with Windows, but there is no need making GRUB try to mount a partition that it cannot mount. That's why rootnoverify is usually seen in the Windows section of grub.conf

The makeactive command was omitted from the example because it is not needed with modern Windows systems. Throwing it in there usually does no harm, but I have seen cases where it seemed to derail things.

815T0
12th February 2010, 09:32 AM
Before I change Grub again I'll just say that the menu options appear but I cannot select any of them at all. It goes straight into default. I will lengthen timeout too.


Edit:Still no joy. Splash screen appears for longer now but still without me being able to interact with the selection process!?

stoat
12th February 2010, 03:17 PM
Splash screen appears for longer now but still without me being able to interact with the selection process!? To me, this is starting to sound like the keyboard is not enabled during booting. It happens sometimes. Is it a USB keyboard? If so, try looking around in your computer's BIOS setup for a setting to enable USB legacy support. It's worked for this before anyway.

815T0
12th February 2010, 05:48 PM
Yes it is Stoat, I'll fish around carefully in the BIOS and get back to you

Can't access support in the Bios for that, but I have never altered the Bios except for boot order. Can I change the default to load XP instead by changing it to
default=2?