View Full Version : Toshiba Laptop with NVIDIA

2nd February 2010, 07:31 PM
I just purchased a Toshiba Satellite A505-S6030 ( http://microcenter.com/single_product_results.phtml?product_id=0326047 ). It's a screaming machine with NVIDIA video and i7 processor. However, I'd really like to install F12 as a dual boot on the free disk space.

I tried the live iso disk. The "automatic boot" countdown completes and Fedora begins to load. The screen goes blank (NVIDIA problem I believe) and that's it. I know F12 will operate on the machine once installed with kmod-nvidia, however, how to get it in the machine is the problem.

I installed F12 within "Microsoft Virtual PC 2007" running on Windows 7. It has some limited functionality and is understandably a bit slow, but does indeed work.

I appreciate advice and suggestions.

Gul Dukat
2nd February 2010, 08:21 PM
Try giving it the boot-option: linux vesa

5th February 2010, 06:00 AM
What I do and see with Fedora12 64bit:
I boot from the live iso disk, At countdown, I press <enter>. At the F12 welcome screen, I press <tab> and see:
vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-12-i686-Live-KDE rootfs type=auto ro liveimg quiet rhgb rd_NO_LUKS rd_NO_MD noiswmd

I added: nomodeset xdriver=vesa vga=ask

to the end of the boot options line. The machine will now start to boot as normal with video. The boot proceeds to the point where the desktop would normally appear and then stalls.

I tried Kubuntu 32bit and Ubuntu 64bit installs. Both load and install without difficulty.
* However, I receive: "USB device not accepting address... ERROR 110, so no USB ports work.
* Ethernet works but no wifi. I installed the linux Realtek 64bit driver rtl8192se recommended for the 8172 device. The wifi adapter is now seen with ifconfig, lshw -C network and network manager, but it still doesn't function.
* I install the NVIDIA drivers and reboot. During boot, I receive messages saying that the system is unable to communicate with the NVIDIA card. I remove xorg.conf and all boots fine, but with no NVIDIA.
* The internal camera doesn't fucntion under Ubuntu.

I would prefer to install Fedora if I could get the system to load to the desktop and install.

I installed Fedora on a desktop about a year ago. It works perfectly and is nearly maintenance free. Absolutely perfect system. I also installed Fedora12 (with no difficulties) on a lower grade Toshiba laptop and also an older Gateway laptop with the same stability, speed and reliability as the desktop.

I am aware that the newest machines hardware may not yet be well supported by the Linux community, but I've found there is always a way to get things done.

Again, I certainly appreciate any assistance or advice.

Thank you.

5th February 2010, 06:10 AM
Have a llok at the nvidia thread in my signature. There are additional steps required to get the nvidia drivers working.

5th February 2010, 11:11 PM
Thank you OZJD. Very detailed thread you have. Most of your instruction I recall doing on my desktop to have NVIDIA function well. In my present case, I'm still unable to boot fully to a desktop from a Fedora 12 64bit live image in order to have an NVIDIA setup issue. Ubuntu is slightly different than Fedora, so I'll be patient for possible suggestions to successfully install F12. As for Ubuntu and NVIDIA, I installed the 185 package instead of the 173 listed in your thread. I believe the nouveau blacklist adjustment would make the Ubuntu NVIDIA work in my case. I'm not so interested in that since Ubuntu is only a test for me. I still await having F12 working.
Thank you again.

---------- Post added at 05:11 PM CST ---------- Previous post was at 11:22 AM CST ----------

Is there a way to control or see what's happening during boot of an F12 64bit live image? There are no logs and <ESC> doesn't allow a term window to view progress. How can I determine where a problem is or what causes the boot to stall just prior to when the desktop would normally appear?

6th February 2010, 01:25 AM
Is there a way to control or see what's happening during boot of an F12 64bit live image? There are no logs and <ESC> doesn't allow a term window to view progress. How can I determine where a problem is or what causes the boot to stall just prior to when the desktop would normally appear?

Editing the kernel line to remove rhgb and quiet will show you the full boot process.

6th February 2010, 02:50 AM
Removing rhgb and quiet did allow all text to be seen during boot. All went well past HAL and a bit beyond until the screen goes blank and boot stalls just about the time the desktop should be appearing. Any additional suggestions?

6th February 2010, 06:25 AM
If it is a graphics problem adding xdriver=vesa to the kernel line will force it to use a generic driver.

6th February 2010, 07:01 AM
Thank you, but if you reading back toward the top of my thread, I'm using vesa. Anything else come to mind?

6th February 2010, 07:23 AM
Thank you, but if you reading back toward the top of my thread, I'm using vesa. Anything else come to mind?

Doh! Sorry missed that.

Not too sure what else to try, you could try leaving out nomodeset.

Does the vga=ask work, I believe it should show you a list of options for various resolutions?

7th February 2010, 09:17 PM
I downloaded and used the full DVD version of F12 64bit. I used the basic video install. Everything installed well. There must be a difference between the full dvd limited video and using the "live iso" with "nomodeset xdriver=vesa vga=ask" picking 600x800x8 resolution.

Now I've installed kmod-nvidia as I've done with other machines easily with great success. However, with this laptop having:
NVIDIA® GeForce® 310M with 512MB GDDR3 discrete graphics
memory, plus up to 1755MB dynamically allocated shared graphics
memory using NVIDIA® TurboCache™ technology.
o Total Available Graphics memory 2267MB

I've not had success. xorg.conf is present and was created by the kmod-nvidia install. The blacklist is present and correct. I boot into runlevel 3 and startx with these results:

NVIDIA could not open the device file /dev/nvidia0 (input/output error)
The NVIDIA kernel module does not appear to be receiving interrupts generated by the NVIDIA graphics device

Thank you

8th February 2010, 03:55 AM
There are a number of steps to installing the nvidia driver and all must be followed for it to work. See the nvidia thread in my signature. Plus there is an additional optional step of removing nouveau which is also mentioned there.

This how to is almost the same but has a couple of extra suggestions. - http://fedorasolved.org/video-solutions/nvidia-yum-kmod/

8th February 2010, 11:55 PM
I've found that the NVIDIA card in this laptop is not supported within the UNIX/Linux community. I've also found that the USB ports, built in camera, realtek wireless and etc. are not supported. As much as I love the perfect world on my desktop computer with a K desktop in Linux, I realize that Microsoft and computer makers have a hand in hand relationship difficult to be broken without monetary reward with Microsoft.

Windows 7, NVIDIA, and this Toshiba A505-S6030 are an example of a manufacturer and Microsoft working together. This machine works as fast as any machine I've ever seen.

I called tech support with Toshiba prior to my purchase. They seemed unconcerned of anything unrelated to Windows. I suppose I could return this computer, but what would be my option?

What is needed for Linux developers to be hand-in-hand with manufactures is to be aware, informed and have the same opportunity to develop code as does Microsoft. Linux is MUCH more efficient and would give their (computer manufacturers) products such a greater representation and marketability. Just like our President and Microsoft today, what is popular and a star is not always best.

I don't completely understand who or what the developers are or how they acquire the information (as does Microsoft) from manufacturers to create drivers, but I am certainly wishing to help.

I feel this a battle that needs to be won within the Linux community. I have programming experience, have owned and was network engineer of an ISP as a BSDI and Red Hat of summit.net before "X" was more than a feeling. What can I do now?

Please pardon me if this is not the forum category to post this. I feel it directly related to my original post and all should know the battle between Linux developers and the giant money and it's developers that have "privilege" to new manufacturer's releases.

With any "encouragement", I'll return this computer to Toshiba. Also, with encouragement, I'll fight to achieve a better relationship and support to manufactures of UNIX/Linux.

Thank you.

9th February 2010, 04:07 AM
"I've found that the NVIDIA card in this laptop is not supported within the UNIX/Linux community. I've also found that the USB ports, built in camera, realtek wireless and etc. are not supported."

That sounds rather odd. Where exactly did you 'find' this?

Are you sure this may not be a case of:



"I don't completely understand who or what the developers are or how they acquire the information (as does Microsoft) from manufacturers to create drivers, but I am certainly wishing to help."

Microsoft rarely creates drivers. It ships some drivers provided directly by manufacturers in Windows releases; otherwise, manufacturers provide their own drivers when shipping the systems. So for Microsoft the relationship is the other way around; hardware manufacturers do not provide Microsoft with information so Microsoft can write a driver, Microsoft provides hardware manufacturers with Windows API documentation so hardware manufacturers can create drivers.

Some hardware manufacturers, such as Intel, provide their own drivers for Linux as well. Some provide documentation to Linux developers - usually simply via the lkml mailing list, sometimes via efforts like http://www.linuxdriverproject.org/foswiki/bin/view . Many simply don't bother, as they don't perceive it to be worth the effort (in financial or any other terms). Drivers for hardware from these manufacturers have to written from scratch.

Linux driver developers mostly work for hardware companies (Intel employs several people to work on Linux drivers; so do, for instance, NVIDIA and ATI) or distributors, mostly Red Hat and Novell.

"What can I do now?"

Write drivers, really. That's about it. There's plenty of people trying to persuade manufacturers to care more about Linux drivers, but as long as writing them requires a reasonable level of Linux-specific expertise (which it does) and the Linux userbase is vanishingly small (which for most consumer-level hardware it is), this is not likely to get very far.

As far as I can tell, the latest released NVIDIA driver indeed does not yet support the 3xx series. However, the latest beta - http://www.nvnews.net/vbulletin/showthread.php?p=2178512 - is listed as supporting two variants of the 310. It's possible it may work for you.

14th February 2010, 02:18 AM
Thank you AdamW. This laptop was only just released during Jan 2010. I realize the driver problem issues, but it is most evident that most computer and hardware manufacturers sleep together with MS. However, on this computer, running a dual boot of Windows 7 and Fedora, at system idle with both systems fresh and nearly unaltered, Fedora uses only about 10% of the total systems resources that Windows 7 does.

I've decided to postpone additional attempts to install NVIDIA drivers. I currently use vesa @ 1360x768 and will pursue the wifi adapter, the next issue of priority.


I've downloaded from Realtek and installed the linux kernel driver (rtl8192se_linux_2.6.0010.1020.2009_64bit) I found to be recommended for the 8172 wifi device. I rebooted and find the following:

# cnetworkmanager -d
Interface | Type | State


# ifconfig
eth0 Link encap:Ethernet HWaddr 00:26:6C:3E:83:41
inet addr: Bcast: Mask:
inet6 addr: fe80::226:6cff:fe3e:8341/64 Scope:Link
RX packets:4294 errors:0 dropped:0 overruns:0 frame:0
TX packets:3288 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:4146367 (3.9 MiB) TX bytes:582128 (568.4 KiB)
Interrupt:35 Base address:0x4000

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:14 errors:0 dropped:0 overruns:0 frame:0
TX packets:14 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1308 (1.2 KiB) TX bytes:1308 (1.2 KiB)

wlan0 Link encap:Ethernet HWaddr 70:1A:04:B0:97:59
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:10 Memory:ffffc90005188000-ffffc90005188100


# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 802.11bgn Nickname:"rtl8191SEVA2"
Mode:Managed Frequency=2.422 GHz Access Point: Not-Associated
Bit Rate:300 Mb/s
Retry:on RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=10/100 Signal level=0 dBm Noise level=-100 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0


# lspci|grep controller
00:16.0 Communication controller: Intel Corporation Ibex Peak HECI Controller (rev 06)
00:1f.2 SATA controller: Intel Corporation Ibex Peak 4 port SATA AHCI Controller (rev 05)
01:00.0 VGA compatible controller: nVidia Corporation Device 0a75 (rev a2)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)
03:00.0 Network controller: Realtek Semiconductor Co., Ltd. Device 8172 (rev 10)
04:00.0 SD Host controller: Ricoh Co Ltd Device e822 (rev 01)


# iwlist wlan0 scan
wlan0 No scan results

(4 feet from a dlink g/n wireless router that connects perfectly on this machine while running Windows 7)


wlan0 now exists, but will not scan or connect. If I missed something or there are any additional suggestions or steps to cause success, I would greatly appreciate.

16th February 2010, 09:49 PM
Check /var/log/messages . Is there no driver for the adapter in the stock Fedora kernel?

17th February 2010, 12:15 AM
Attached is the start-up messages from /var/log/messages.

Along with the WIFI problem, maybe problems with other hardware could be spotted ie NVIDIA, USB hub/ports, and etc.

Thank you.

18th February 2010, 01:31 AM
Interestingly, there's a lot of ACPI errors in that log, which generally indicates a crappy BIOS the kernel is having trouble with. Can you check if there's a BIOS update available from your system manufacturer?

18th February 2010, 01:28 PM
I understand that this computer was just released January, 2010.

Toshiba A505-S6030
from http://laptops.toshiba.com/laptops/satellite/A500/A505-S6030

The BIOS is:
Version 1.10
EC Version 5.29
Revision 3.5
from http://www.insydesw.com/services/services-embedded.htm

18th February 2010, 10:35 PM
Can't find an updated BIOS anywhere for that model, nope. I'll ask some kernel people if they can advise on this situation.

19th February 2010, 12:42 AM
The simple problem is that Linux sits in the background for hardware support, but hardware manufacturers sell themselves to the what's popular, easy but less efficient and more costly, just as many politicians are elected.

I emailed the support email address for Linux provided by Realtek, but with no reply as of yet. I used the online support and was given a phone number to an advanced support line. I called that and was pleased with the person's help, but they had no experience with Linux. I was told that a trouble report would be created and I would receive an email within 3 minutes. Nothing as of 2 hours. I posted a message on the NVIDIA Linux forum. http://www.nvnews.net/vbulletin/showthread.php?t=148006

I await "anything" and hopefully useful.

Thank you.

PS I only wish I could take a detailed picture of the desktop computer I use with Fedora 12 and the KDE desktop. If this could be easily duplicated and installed on similar hardware, support staffs could be nearly eliminated and computers would be as easy to use and maintenance free as a refrigerator.

5th March 2010, 05:32 PM
Just adding a "me too" to this thread. I just purchased the same laptop. Runs great with Windows 7, but I need Fedora to run on it. The ehci_hcd driver complains constantly, wifi doesn't work out of the box and I can't get a display using anything but the vesa driver. So far it's been a complete PITA but I am determined to get it working as well as my 4 year old HP laptop.

---------- Post added at 10:32 AM CST ---------- Previous post was at 06:45 AM CST ----------

While google'ing this message in the Toshiba's messages file:

ACPI Error (psargs-0359): [MIy] Namespace lookup failure, AE_NOT_FOUND

I stumbled across this bug reported by somebody with (surprise) a Toshiba laptop:


I'm curious if the video and usb problems could be caused by this same issue.

5th March 2010, 05:33 PM
forgot to update this thread. David Woodhouse says:

The ACPI stuff all looks like BIOS bugs. Might be worth filing in Intel's ACPI bugzilla though. Not sure about the HPET WARNING -- that might be bug-worthy. Is there an actual problem?Is there an actual problem?"

I explained that, yes, there's an actual problem, nothing works :). So basically it does look like a bad BIOS, but you can file bugs against kernel and hope for something to happen if you like.

Intel's ACPI Bugzilla is at http://www.lesswatts.org/projects/acpi/bugzilla.php .

5th March 2010, 06:23 PM
rigsc: it wouldn't surprise me, the fundamental takeaway here is that the BIOS on these machines is a great big pile of fail. It's probably worth posting some info on your issues into that bug report, yeah.

6th March 2010, 03:08 AM
Not a very encouraging assessment:


---------- Post added at 08:08 PM CST ---------- Previous post was at 01:44 PM CST ----------

Ok, booting with "pci=noacpi" I was actually able to use the Nvidia driver, the wifi driver from Realtek, and the usb appears to be working (at least I was able to hook up a mouse). Obviously power management doesn't work. I haven't had a chance to try anything else to see what might still be broken.

6th March 2010, 08:57 PM
I await "anything" and hopefully useful.

I see there's a 195.36.08-1.fc12 akmod waiting in rpmfusion's non-free updates repo today...
(for an integrated-video desktop that has previously been cranking along fine on the 190.53-1 driver).

Did you try that yet?

6th March 2010, 09:06 PM
I see there's a 195.36.08-1.fc12 akmod waiting in rpmfusion's non-free updates repo today...
(for an integrated-video desktop that has previously been cranking along fine on the 190.53-1 driver).

Did you try that yet?

The problem isn't the Nvidia driver, it's with the BIOS in these laptops. I installed the beta driver from Nvidia's website but it still wouldn't load until I booted with "pci=noacpi". Unfortunately it's still unstable as hell and it's a coin flip whether the laptop will boot at all. The rt kernel is even more unstable.

I'm debating whether I should return it now or hang onto it hold out hope that support improves.

7th March 2010, 09:33 PM
I used your pci-noacpi and most all is working great... like night and day. Very stable with the latest kernel using akmod-nvidia. USB ports work... at least with a mouse (as you). I had to disable "network-manager" because the wifi would connect and disconnect all the time. I've been using the utilities from the realtek package to start the wifi on my home unsecured wireless network.

iwconfig wlan0 essid [name]

Still issues with that to be resolved. It takes a few minutes for the connection to transfer any data, but seems to work well after that.

7th March 2010, 09:44 PM
It's better but it's still far from ideal. The wifi is mostly solid for me. I booted into a realtime kernel and tried to use the firewire with no luck at all.

AdamW, can you provide suggestions as far as where we should go for support? I saw you mention "Intel's ACPI Bugzilla". Are you talking about the acpi sourceforge page? What type of information should we collect for them?

9th March 2010, 01:21 AM
Remind me to learn how to read:

Intel's ACPI Bugzilla is at http://www.lesswatts.org/projects/acpi/bugzilla.php .

---------- Post added at 06:21 PM CST ---------- Previous post was at 09:10 AM CST ----------

If you're not afraid to patch and install a brand new kernel, there's a patch attached to comment #35 here:


It applied cleanly to 2.6.33 for me. Running this patched kernel I was able to successfully boot with no additional options and everything *looks* normal so far aside from one stack trace during bootup. I don't believe it's a fix, but if you're like me and dying to get your new laptop going it should tide you over until the problem is fixed for real.

23rd March 2010, 10:43 AM
I'm sorry, I have used linuz just once and couldn't answer youre question. But I belive that you'll find someone, who could help you!
Good luck!