PDA

View Full Version : yumex 'not connected to a network' error



wt6g
23rd January 2010, 05:59 PM
After doing updates a few days ago yumex stopped working. I started getting an error message when I try to run it, "no connected to a network". This is of course not true.

I've looked at yumex.conf and don't see anything wrong, and I downgraded the GTK2 packages from a post indicating a segfault issue with one of those packages.

yum works fine from the command line, so my system is fully updated.

I removed yumex and then reinstalled it with no joy.

Anyone else have this problem or a solution?

Thanks.

tashirosgt
26th January 2010, 10:15 PM
I don't have the problem or the solution. I suggest that your run (from the command line) an
ltrace yumex
or
strace yumex
Perhaps the reason why it errors will be discovered.

Does yumex have any options that make it run with debug print out?

wt6g
27th January 2010, 01:32 AM
I found the solution!

There is a bug in network manager. This was causing firefox to come up with the network disabled and yumex to think that there was no network. I tried enabling and disabling network manager for the connection, static and dynamic ip address and no joy.

I finally used system/admin/services and stopped the network manager daemon and then disabled it and the problem with yumex and firefox went away.

/Len

sidebrnz
27th January 2010, 07:57 AM
Ever since the last "upgrade" to yumex, it's been claiming to be off-line, and finding no updates. Checking from the command line, there are a large number of them. My F 11 box doesn't have network manager running. What else can it be?

Note: I tried running it from a terminal. Among other things, it reported that it's not connected to a network, but no other usable debug info.

wt6g
27th January 2010, 02:16 PM
You can fix this problem by stopping the Network Manager daemon and then disabling it. As long as you are not using a laptop this should have no effect on your use of the system and it restores the functionality of Yumex and Firefox.

If you are using a laptop, you can still use the network its just a little more cumbersome. Certainly you can shut down network manager prior to running yumex. Firefox gives you the ability to ignore the bogus status, but its a pain in the neck.

I found out a lot about yum when I was unable to run yumex. My primary use for yumex is to explore the available applications in addition to the install/upgrade/remove functions which are standard.

You may find these commands useful while you still have trouble, especially if you are using a laptop:

yum search XXXX where XXX is a string you are looking for in the descriptions.

yum search XXXX | grep YYYY where XXX is a string you are looking for and YYYY is a filter string to cut down the number of results.

examples:

yum search edit
yum search 'mbox edit'
yum search 'mbox' | grep claws

Also

man yum
yum erase XXXX
yum install XXXX

These will keep you going until you solve the problem in your configuration or Network Manager is fixed.

sidebrnz
27th January 2010, 06:32 PM
Thank you, but what part of "My F 11 box doesn't have network manager running" didn't you understand? I removed it long ago, and only use Network.

tashirosgt
27th January 2010, 07:24 PM
My suggestions don't work because yumex is a python program. So the python expert (which I am not) would probably use the python debugger "pdb" to run yumex. I can't fgure out how to do that at the moment! http://docs.python.org/library/pdb.html

sidebrnz
28th January 2010, 12:23 AM
Checking Bugzilla, I found that this is a known bug: https://bugzilla.redhat.com/show_bug.cgi?id=558382 and I've added some information to it.

wt6g
28th January 2010, 06:29 PM
You never said you removed it. No running it could mean that you did not check the box in network manager for your connection, which is what I concluded based on a conservative assessment of the information as presented.

In fact, I was "not running" Network Manager on my connection either, but since I had not removed it, and the daemon was active, I examined the situation and found the reported consequence of killing that daemon on my system.

Since you seem to still have this problem outstanding, I have noticed that there is interaction between Python and FC12. I have a lot of Python apps typically running on my system, and there is some issue either with memory management or library sharing that I still have not figured out. These issues slow the system down significantly depending on the processing requirements of one or more of the Python apps - even though there should be no issue at all (the system is still lightly loaded and all of this worked in FC10/FC11).

It could be that this anomaly is causing Yumex to assume a default negative answer to its query based simply on response time, meaning that removing NM is only a second order solution that is really more of a factor of system performance. Removing NM may cause me to fall below a threshold where the problem presents.

Based on that, I've started to move away from Python apps temporarily. You may want to try this. Don't forget to check out your applets too. There has been a substantial increase in system response here as a result with no more unexpected pauses.

PS

If you are running gnome you may see this problem at boot when the control panels seem to come up far too late as the desktop initializes.

sidebrnz
28th January 2010, 09:58 PM
I'm beginning to think that either you don't read my posts, or you're ignoring parts of them. My issue is strictly with a desktop machine running F 11; my laptop with F 12 runs yumex just fine, and this is the first time on this thread that I've even mentioned any version of Fedora other than 11. I also suspect that either you didn't read my post about bugzilla, or didn't check the link because if you did, you'd realize that your entire last post was redundant.

OralDeckard
19th April 2010, 02:53 PM
Thank you wt6g. Your solution was exactly what I needed. And if it had not been, I still wouldn't have insulted you for trying. I had this problem on an F12 installation and never did find the solution. It just started working one day. Its good to know the reason so I can control it, not wait to get lucky. Thank you very much

---------- Post added at 08:53 AM CDT ---------- Previous post was at 08:46 AM CDT ----------

Would you care to elaborate on the ill effects of disabling Network Manager on a laptop ? I'm about to return my aunts laptop and don't want it to be cumbersome for her in a way I did not anticipate and head off.

aleph
19th April 2010, 03:09 PM
I found the solution!

There is a bug in network manager. This was causing firefox to come up with the network disabled and yumex to think that there was no network. I tried enabling and disabling network manager for the connection, static and dynamic ip address and no joy.

I finally used system/admin/services and stopped the network manager daemon and then disabled it and the problem with yumex and firefox went away.

/Len

I know your feeling because the same issue also affects Pidgin the instant message app which I use frequently.

I even filed a bug report against this and got the (IMO unthoughtful if not outright ridiculous) "CLOSED, NOTABUG" response from a dev member, Stu Tomlinson (http://www.nosnilmot.com/). The original bug report can be found at the URL --> https://bugzilla.redhat.com/show_bug.cgi?id=576441

When I saw that "resolution" I immediately jumped to the bugzilla site and started typing a flaming reply. Just before I hit the "Save Changes" button I realized that it would have been unfair to my FOSS peer. I took a deep breath, removed the message I just typed in, and wrote a much more modest version of it, which is the one appeared in comment #3 of the bugzilla report.

OralDeckard
19th April 2010, 03:41 PM
I'm using F12 and testing F13, but keep installing F8 for little old ladies at church. I know Fedora is experimental, cutting edge, and don't mean to whine about experimental software having problems. But some of the problems just remain from one release to the next. Why stick to a 6 month release schedule if the problems in two releases back are still present ?

And part of it is not really Fedora. I like KDE. But I can't switch users in KDE. I can in Gnome, but KDE loops me back to re-log into the same account I was trying to switch FROM. And here I am with a fresh install of 13, and can't swtich users in KDE. But this this thread was about a solution to Yumex not finding the network, so I think I'll shut up about other things. Fedora is still the best distro, in spite of its problems, because it has the most dedicated developers, even if they don't achieve perfection.