PDA

View Full Version : glxglue problem



iraniangirl
23rd January 2010, 01:38 PM
Dear All,

I wrote a simple code using Open Inventor(OpenGL) classes to print a Sphere in a .png file.I tested it on Windows and it worked well.But when I run it on Fedora 10, I got the following error with no output .png file:


Coin error in glxglue_init(): Couldn't open NULL display.
Coin warning in SoOffscreenRenderer::renderFromBase(): Could not set up an offscreen OpenGL context.
Segmentation fault


Could anyone help me on this problem? Should I set any special thing in Fedora?

Thanks in advance

szihs
26th January 2010, 09:11 AM
I think it is whining about not able to find display server...

you could try using installing Xephyr... and then setting env variable DISPLAY
http://moblin.org/documentation/moblin-image-creator/installing-and-using-xephyr

though I maybe be best person to answer about graphics.

BugRocks1
26th January 2010, 10:07 AM
Did you use glxinfo to see if the GLX module is running?

When you use glxgears does it work?

If no then probably is a driver problem.

Could also be a permission problem.

You could use strace to see where it is failing maybe it shows up.