PDA

View Full Version : Running the XScreenSaver daemon on startup



Noosentaal
23rd January 2010, 12:46 PM
Hi all,

I'm having some problems getting my screensaver to work automatically.

If I start the screensaver config program then it gives me this message: "The XScreenSaver daemon doesn't seem to be running on display ":0.0". Launch it now?" If I click yes then my screensaver works exactly as expected.

How can I get the XScreenSaver daemon to start automatically?

Thanks for any help in advance!

tashirosgt
29th January 2010, 02:58 AM
Which version of Fedora is this? Which program is the screensaver config program? The one launched in the Gnome desktop by System->Preferences->Screensaver?

Noosentaal
29th January 2010, 11:10 AM
Hey,

Thanks for the reply - I should have mentioned that really. Its F12 and I'm running KDE.

I've managed to solve this problem (using google and a bit of experimentation). I did this: (for anybody else that may come across this with the same problem)


3: Make xscreensaver be an Autostart program.
Create a .desktop file in your autostart directory called xscreensaver.desktop that contains the following five lines:

[Desktop Entry]
Exec=xscreensaver
Name=XScreenSaver
Type=Application
X-KDE-StartupNotify=false



Which is taken from the man page of xscreensaver which can be found here (http://www.jwz.org/xscreensaver/man1.html).

Thanks again for the reply.

Regards,

Noosentaal

tashirosgt
29th January 2010, 06:36 PM
Thanks for posting your solution!