PDA

View Full Version : Setting GDM back to default



LinuxR
20th January 2010, 05:55 PM
Ok the issue:
I tried changing my Theme via MAC4LIN and it didnt work i get an error messege that shows:

cp: cannot stat `/etc/gdm/gdm.conf': No such file or directory
sed: can't read /etc/gdm/gdm.conf: No such file or directory
sed: can't read /etc/gdm/gdm.conf: No such file or directory

Previous to this i had tried installing KDM but it didnt appear to do anything (as in change any of the display management settings)
The guide that i was reading to install MAC4LIN just uses GDM so i decided not to pursue KDM anymore. I Get the following read out:


[Jason@Echo ~]$ yum info gdm
Loaded plugins: presto, refresh-packagekit
Installed Packages
Name : gdm
Arch : i686
Epoch : 1
Version : 2.28.2
Release : 1.fc12
Size : 4.4 M
Repo : installed
From repo : updates
Summary : The GNOME Display Manager
URL : http://download.gnome.org/sources/gdm
License : GPLv2+
Description: GDM provides the graphical login screen, shown shortly after boot
: up, log out, and when user-switching.

[Jason@Echo ~]$ yum info kdm
Loaded plugins: presto, refresh-packagekit
Available Packages
Name : kdm
Arch : i686
Version : 4.3.4
Release : 3.fc12
Size : 1.9 M
Repo : updates
Summary : The KDE login manager
URL : http://www.kde.org/
License : GPLv2
Description: KDM provides the graphical login screen, shown shortly after boot
: up, log out, and when user switching.

[Jason@Echo ~]$

It appears that i dont have a gdm.conf file in my folder:


[Jason@Echo ~]$

[Jason@Echo etc]$ cd gdm
[Jason@Echo gdm]$ dir
custom.conf gdm.schemas Init PostLogin PostSession PreSession Xsession
[Jason@Echo gdm]$


The goal is to set all my GDM settings back to normal so i can have that gdm.conf file. Anyone know a way to set the GDM back and repair any damage ive done?

vallimar
20th January 2010, 07:00 PM
To refresh GDM, I would try:
rpm -e gdm --nodeps
rm -rf /etc/gdm /var/gdm /var/lib/gdm /var/run/gdm
yum install gdm

In order to switch to using KDM, you have to edit /etc/sysconfig/desktop.
You may have to create it. So you can either edit and change the DISPLAYMANAGER variable
or just try the following: sudo echo "DISPLAYMANAGER=KDE" >> /etc/sysconfig/desktop

LinuxR
20th January 2010, 07:03 PM
the goal is to not use KDM and just GDM. lll try that when i get home and see if that does anything. Will keep you all posted with results.