PDA

View Full Version : Help - disaster after running yum update



satimis
20th January 2010, 03:35 AM
Hi folks,

Fedora 12 64bit - host
KVM

Through difficulty and pain I succeeded update Fedora. However today when I boot the PC only a black screen resulted (gui booting). I can type on the black screen. Pressing Ctrl+Alt+Del reboots the PC.

The PC is working. I have another HD running Windows Vista. It can boot without problem. I'm now running it posting this thread via IE.

Pls help. TIA

B.R.
satimis

bob
20th January 2010, 03:56 AM
Just a shot in the dark here, but I'd first log in 'init3' or normally but ctrl-alt-f2 to get to a login. Then run

rpm -qa --last | tac
to list your updates from oldest to newest and try to pick out the offending bugger. I made it through fine, but if I had a problem, I might be tempted to tie it to xorg-x11-drv-ati and might try to do a 'yum downgrade xorg-x11-drv-ati' as a possible solution.

Of course, once logged in, you can check your /var/log/messages or dmesg for valid clues and probable causes.

Good luck.

satimis
20th January 2010, 04:58 AM
Just a shot in the dark here, but I'd first log in 'init3' or normally but ctrl-alt-f2 to get to a login. Then run

to list your updates from oldest to newest and try to pick out the offending bugger. I made it through fine, but if I had a problem, I might be tempted to tie it to xorg-x11-drv-ati and might try to do a 'yum downgrade xorg-x11-drv-ati' as a possible solution.

Of course, once logged in, you can check your /var/log/messages or dmesg for valid clues and probable causes.

Good luck.

Hi,

Thanks for your advice.


# rpm -qa --last | tac

....
xorg-X11-drv-nouveau-0.0.15-19.20091105gite1c2efd.fc12
....



# tail /var/log/messages

not dumpting repeating crash in '/usr/bin/Xorg
....
Warning: GdmLocalDisplayFactory: maximum number of X display failures reached: check X server log for error



# tail /var/log/Xorg.0.log

Fatal server error:
Caught signal 11 (Segmentation fault). Sever aborting

Please consult the Fedor Project support at http://bodi.fedoraproject.org/ for help
Please also check the log file at "var/log/Xorg.0.log" ofor additional information



B.R.
satimis

Maxtorete
20th January 2010, 09:04 AM
Try the nomodeset kernel param at boot. I have suffered the same problem, and fixed with the nomodeset option.

satimis
20th January 2010, 07:08 PM
Try the nomodeset kernel param at boot. I have suffered the same problem, and fixed with the nomodeset option.

Hi Maxtorete,

Thanks for your advice.

Having tried half hour unable to start interactive mode.

Press 'I' (shift+i)
Press 'i'
Holding 'i'
Press [ESC]

all did not work.

B.R.
satimis

---------- Post added at 02:08 AM CST ---------- Previous post was at 12:24 AM CST ----------

Hi folks,

Problem solved after running update. There are many packages cleaned and reinstalled.

B.R.
satimis