PDA

View Full Version : Eclipse IDE for php



gusamasan
19th January 2010, 10:16 PM
Hello, all.

How i can get/install Eclipse IDE for php?.

Thank you in advance.


------------------
gusamasan

giulix
20th January 2010, 10:52 AM
Basically, you're looking for PHP Development Tools (PDT) (http://www.zend.com/en/community/pdt) (zend.com) and, optionally, the Zend debugger.

gusamasan
20th January 2010, 12:23 PM
Thank you, giulix.

How i can install it?. I need a link/direct access from "MainToolBar/Applications/Development" menu. Exists a yum command to install it?.

-------------
gusamasan

pedromatiello
20th January 2010, 12:54 PM
There's phpeclipse on the repository. I never used it, but you can install it by running:


# yum install eclipse-phpeclipse

gusamasan
21st January 2010, 06:13 PM
Thank you, pedromatiello.

I used the command:


yum install eclipse-phpeclipse

I have the EclipseIDE ready.


--------------
gusamasan

TheMadIndian
22nd January 2010, 09:00 PM
Thank you, pedromatiello.

I used the command:


yum install eclipse-phpeclipse

I have the EclipseIDE ready.


--------------
gusamasan

I use this alot and it works well but be advised when you receive updates from the repo for eclipse IDE it will cause the php plugin to fail and you will have to reinstall everything...

pedromatiello
22nd January 2010, 09:10 PM
As I said, I'm not familiar with phpeclipse. But I use a lot of plugins (including cdt, pydev and dltk-ruby) and they are working fine after the updates.

Updates used to break stuff in F11 (Eclipse 3.4), but they haven't caused any harm for me in F12 (Eclipse 3.5). If something goes bad, try starting eclipse this way:


eclipse -clean

This fixed all the problems I've ever had with Eclipse updates from the repository.

gusamasan
22nd January 2010, 09:10 PM
Thank you, TheMadIndian.

if yum update eclipse-phpeclipse is not working, Can i use these commands to update my PhpIDE?:


yum remove eclipse-phpeclipse

next


yum install eclipse-phpeclipse


--------------
gusamasan

TheMadIndian
22nd January 2010, 09:49 PM
Thank you, TheMadIndian.

if yum update eclipse-phpeclipse is not working, Can i use these commands to update my PhpIDE?:


yum remove eclipse-phpeclipse

next


yum install eclipse-phpeclipse


--------------
gusamasan

last update I had to remove eclipse-phpeclipse eclipse-platform eclipse-pde

but I would try what pedromatiello posted above first if you run into issues as I havent tried that step and just do what I said above based on past experience under F11

---------- Post added at 03:49 PM CST ---------- Previous post was at 03:36 PM CST ----------


As I said, I'm not familiar with phpeclipse. But I use a lot of plugins (including cdt, pydev and dltk-ruby) and they are working fine after the updates.

Updates used to break stuff in F11 (Eclipse 3.4), but they haven't caused any harm for me in F12 (Eclipse 3.5). If something goes bad, try starting eclipse this way:


eclipse -clean

This fixed all the problems I've ever had with Eclipse updates from the repository.

I just tried it on my laptop that was having issues with php files after the last update as I dont really need it on here and I didnt bother with the whole exercise yet

eclipse -clean worked like a charm

thanks

gusamasan
22nd January 2010, 11:35 PM
Thank you, pedromatiello and TheMadIndian