PDA

View Full Version : Dual Monitors - Fedora 12



smithm2
18th January 2010, 10:49 PM
I just installed Fedora 12, I am very new to Linux. My dual monitors are not working properly, i have the same image on both monitors. I have researched the problem extensively and cannot fix this bug. Using YUM i have installed system-config-display but when i try to run it from either the terminal or the GUI I get an error. Something like the following. I have an ATI video card (Radeon x300). No one has been able to help yet, any suggestions are very appreciated.


UUID: 899ffa3f
architecture: i686
cmdline: python2 /usr/share/system-config-display/xconf.py
component: system-config-display
executable: /usr/share/system-config-display/xconf.py
kernel: 2.6.31.9-174.fc12.i686.PAE
package: system-config-display-2.2-1.fc12
release: Fedora release 12 (Constantine)
uuid: 899ffa3f

backtrace
-----
Summary: TB899ffa3f xConfigDialog.py:640:__init__:IndexError: index out-of-bounds

Traceback (most recent call last):
File "/usr/share/system-config-display/xconf.py", line 378, in <module>
dialog = xConfigDialog.XConfigDialog(hardware_state, xconfig, videocard.VideoCardInfo())
File "/usr/share/system-config-display/xConfigDialog.py", line 640, in __init__
if len(self.xconfig.layout[0].adjacencies) > 1:
IndexError: index out-of-bounds

Local variables in innermost frame:
count: 4
current: 3
available_resolutions: ['640x480', '800x600', '1024x768', '1280x1024']
screen_list: <XF86GenericList object at 0x85cf1e8>
vc: primary: 0
vidCards: [<videocard.VideoCard instance at 0xb73e07cc>]
Primary Video Card Info:
device: None
driver : radeon
descr : ATI Technologies Inc RV370 5B60 [Radeon X300 (PCIE)]
vidRam: None

xml: <gtk.glade.XML object at 0x839952c (PyGladeXML at 0x8457c60)>
res: 1280x1024
self: <xConfigDialog.XConfigDialog instance at 0xb73c29ac>
available: [8, 16, 24]
monitor_list: <XF86GenericList object at 0x85c97a0>
videocard_list: <XF86GenericList object at 0x85cf410>
item: <gtk.MenuItem object at 0x839966c (GtkMenuItem at 0x8502da8)>
depth: 24
iconPixbuf: <gtk.gdk.Pixbuf object at 0x8399554 (GdkPixbuf at 0x849fcf8)>
res_menu: <gtk.Menu object at 0x83992d4 (GtkMenu at 0x84e45e0)>
videocard_menu: <gtk.Menu object at 0x839975c (GtkMenu at 0x84e46d0)>
hardware_state: <xhwstate.XF86HardwareState instance at 0xb74270ec>
xconfig: <XF86Config object at 0xb77badd0>

jbs1136
18th January 2010, 11:13 PM
xrandr --output DVI-0 --mode 1400x1050 --output VGA-0 --mode 1280x1024 --right-of DVI-0

I use this command when I want to use dual monitors. My second monitor is shared with another computer used as a server. I only use this occasionally but it works well. xrandr --output VGA-0 --off turns off the 2d monitor when I am finished. I have shortcut launchers on my panel. HTH

john

GoinEasy9
18th January 2010, 11:18 PM
If you have both monitors showing the same thing, you're in dual mode. Change the setting to Twinview and they will be one long screen. If need be you can make the changes in xorg.

smithm2
18th January 2010, 11:43 PM
how do i change to twinview? again im really new to linux

thanks for the help

GoinEasy9
19th January 2010, 04:36 AM
Sorry, was at work, but, since I'm a Nvidia user, I'm not that up on ATI graphics cards. I know I had to set the twinview mode when setting up Nvidia. I tried to find some info on the ATI setup with dual monitors but came up short. It seems like you can set the dual mode by using the aticonfig command. Unfortunately I have no experience using it. You'll probably have to look whether you card can use the Radeon or RadeonHP drivers, since the proprietary catalyst drivers don't work on F12. Here's a couple of links that might be helpful:
http://fedorasolved.org/video-solutions/radeon-xorg-tweaks
https://fedoraproject.org/wiki/Common_F12_bugs#radeon-misc-gfx

If your card can handle it, installing the mesa-dri-drivers-experimental package might be useful. Sorry I can't be more helpful, maybe someone else will see the thread and offer some better suggestions.

trix160
19th January 2010, 05:02 AM
I am having a difficult time setting up dual monitors with my hp tx2000 Pavilion. The display prefrences applet recognizes the monitor, but the monitor is receiving no signal from the laptop. When I check 'mirror screens' the 'no signal' message on the monitor switches to a 'config input - please wait' message. I used yum to look for drivers, but to no avail. Any help? I'm very new to linux

steve42t
19th January 2010, 05:56 PM
To get twinview and dual monitors working on my computer, I had to install the nvidia linux driver directly from there website (since I had an nvidia video card). After that it worked easily through nvidia's driver's gui. But it never worked properly through System->Display since it didn't support my video card properly otherwise. Before that, I had similar issues as you have now

frantaylor
19th January 2010, 08:01 PM
And you don't need to install the drivers from nvidia.com. Use rpmfusion and your drivers will be automatically upgraded with the kernel. I believe this is true for ATI drivers as well.

The rpmfusion package installs 'nVidia Display Settings' in the 'System Tools' menu, you can configure TwinView with a few mouse clicks. I was up and running in seconds.

GoinEasy9
19th January 2010, 09:10 PM
But I believe the OP is trying to get ATI card up and running with twinview, Nvidia setup is different.

jbs1136
19th January 2010, 11:21 PM
@smith2,

I posted earlier about using Xandr which will work with ATI cards. I use the x1600 and the open source driver which was installed when I installed fedora. Xandr is part of Xorg and is on your computer by default. it is really easy to use and doesn't require any editing of config files. ATI doesn't have the same stuff as nvidia, which is what everyone else is talking about. You issed the command and you have dual monitors. The second monitor is an extension of the first monitor.

john