PDA

View Full Version : Yum problem



RajaShekhar
17th January 2010, 05:54 AM
Hi .. I am new to fedora..!!
After installation of fedora ...I cant update it through yum ..!! please help me in this.

I am gettting these error .. Can you suggest one method to update




[root@nsl151 Documents]# yum clean all
Loaded plugins: fastestmirror, presto, refresh-packagekit
Cleaning up Everything
Cleaning up list of fastest mirrors
[root@nsl151 Documents]# yum update
Loaded plugins: fastestmirror, presto, refresh-packagekit
Determining fastest mirrors
* rpmfusion-free: ftp.upjs.sk
* rpmfusion-free-updates: ftp.upjs.sk
* rpmfusion-nonfree: ftp.upjs.sk
* rpmfusion-nonfree-updates: ftp.upjs.sk
adobe-linux-i386 | 951 B 00:00
adobe-linux-i386/primary | 12 kB 00:00
adobe-linux-i386 17/17
local-update | 4.4 kB 00:00
local-update/primary_db | 4.5 MB 00:00
localrepo | 3.8 kB 00:00
localrepo/primary_db | 8.4 MB 00:00
rpmfusion-free | 3.8 kB 00:00
rpmfusion-free/primary_db | 297 kB 00:00
rpmfusion-free-updates | 3.3 kB 00:00
rpmfusion-free-updates/primary_db | 121 kB 00:00
rpmfusion-nonfree | 3.3 kB 00:00
rpmfusion-nonfree/primary_db | 87 kB 00:00
rpmfusion-nonfree-updates | 3.3 kB 00:00
rpmfusion-nonfree-updates/primary_db | 40 kB 00:00
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package qt.i586 1:4.5.3-9.fc11 set to be updated
--> Processing Dependency: libssl.so.8 for package: 1:qt-4.5.3-9.fc11.i586
--> Processing Dependency: libcrypto.so.8 for package: 1:qt-4.5.3-9.fc11.i586
---> Package qt-sqlite.i586 1:4.5.3-9.fc11 set to be updated
---> Package qt-x11.i586 1:4.5.3-9.fc11 set to be updated
--> Processing Dependency: libcrypto.so.8 for package: 1:qt-x11-4.5.3-9.fc11.i586
--> Processing Dependency: libssl.so.8 for package: 1:qt-x11-4.5.3-9.fc11.i586
--> Finished Dependency Resolution
1:qt-x11-4.5.3-9.fc11.i586 from local-update has depsolving problems
--> Missing Dependency: libcrypto.so.8 is needed by package 1:qt-x11-4.5.3-9.fc11.i586 (local-update)
1:qt-4.5.3-9.fc11.i586 from local-update has depsolving problems
--> Missing Dependency: libssl.so.8 is needed by package 1:qt-4.5.3-9.fc11.i586 (local-update)
1:qt-x11-4.5.3-9.fc11.i586 from local-update has depsolving problems
--> Missing Dependency: libssl.so.8 is needed by package 1:qt-x11-4.5.3-9.fc11.i586 (local-update)
1:qt-4.5.3-9.fc11.i586 from local-update has depsolving problems
--> Missing Dependency: libcrypto.so.8 is needed by package 1:qt-4.5.3-9.fc11.i586 (local-update)
Error: Missing Dependency: libssl.so.8 is needed by package 1:qt-4.5.3-9.fc11.i586 (local-update)
Error: Missing Dependency: libcrypto.so.8 is needed by package 1:qt-4.5.3-9.fc11.i586 (local-update)
Error: Missing Dependency: libssl.so.8 is needed by package 1:qt-x11-4.5.3-9.fc11.i586 (local-update)
Error: Missing Dependency: libcrypto.so.8 is needed by package 1:qt-x11-4.5.3-9.fc11.i586 (local-update)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest
[root@nsl151 Documents]#


Thank you in advance.

Demz
17th January 2010, 08:40 AM
did you try using these commands
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest then try an update?

RajaShekhar
17th January 2010, 09:48 AM
sorry !
I tried now .. But still it is showing same thing as above.

thank you for your fast response. Please tell me what to do !!

leigh123linux
17th January 2010, 11:14 AM
Thread split as you problem isn't compiz related.


Please tell me what to do !! Update your local repo's as there incomplete or connect to the proper repo's.