PDA

View Full Version : Fedora 12 Freezing. X?



Quartonite
17th January 2010, 12:07 AM
I recently installed Fedora 12 over an old Kubuntu Hardy installation. So far, I am very pleased. My wifi card was detected and supported out of the box, installation was easy and yum is quite pleasing to use.

However, I have been having regular freezing problems. These problems, as you can imagine, make doing pretty much anything difficult as my entire computer could freeze up at any time.

Freezing is more common when I'm doing anything intensive (particularly graphic intensive), such as a game or video. Also, I have as of yet had absolutely no freezing while in the virtual console, even when doing intensive operations such as running Make. For this reason, I am inclined to think that perhaps the problem lies with X or something to do with video.

But past this point, I really have no idea how to go about pinning down the problem or fixing it.

Here system specs that I think might be useful:

Dell Dimension 2400 (this is quite an old machine)
768 mb memory
ATI Radeon 9200 PRO
and 2 gb swap space

I am using the out of the box video drivers, not anything proprietary.
I ran memtest on the ultimate boot cd and passed.
When a freeze occurs, all keyboard and mouse input stops working (including caps lock and the like), I cannot switch to virtual console, sounds repeat a few times then stop and all video stops.

Any help is much appreciated! I have been using various linux distros for a while, but I'm still rather clueless. This freezing is really making things difficult.

SlowJet
17th January 2010, 02:28 AM
The is no 3D native video drv for linux so when you use the ati drv with KMS the rendering is done by the cpu, not the gpu (except for a couple of functions to pust the results to the gpu. Thats why glxgears even works.)

All you can do is update.


su -
<rootpassword>
yum clean all
yum update

After take a peek in updates-testing

yum update xorg-x11-drv-ati xorg-x11-server xorg-x11-server-Xorg xorg-x11-server-common kernel --enablerepo=updates-testing



xorg-x11-server-Xorg-1.7.4-3.fc12.i686
xorg-x11-server-common-1.7.4-3.fc12.i686
xorg-x11-drv-ati-6.13.0-0.20.20091221git4b05c47ac.fc12.i686

Quartonite
17th January 2010, 04:10 AM
Alright, I ran these commands and everything seemed to go well. I did get the following message with the last command:

No Match for argument: xorg-x11-server
No package xorg-x11-server available.

But all of the other packages updated fine.
What exactly is this supposed to show me? The freezing problem isn't fixed. Would it be a good idea to just go ahead and install the proprietary drivers? I'm sure they're years and years out of date.

Thanks for the reply

Quartonite
17th January 2010, 11:30 PM
Bump. Would switching to 11 fix the problem?

leftoflexo
18th January 2010, 01:01 AM
i had the exact same problem with the fedora 12 install from the live cd when 12 first released as stable, i erased my disk and installed from the multiple cd method using the PAE kernel and i havent had a problem since. for other drives i also tried to use the network install method and had the same freezing issue. i also burned a different copy of the live cd from a download made a few weeks ago and had the same issue. my box is pretty old as well and the specs are similar to your own machine. although the brands are different we have similar chipsets. as i can see yours is:

Processor: Intel Celeron 2.4 GHz processor, 400Mhz FSB (100MHzx4)
Chipset: Intel 845GV
Videocard: Integrated Intel Extreme graphics
Sound: Integrated Soundmax Sound

mine is:
Processor: Intel Celeron 2.5 GHz, 400Mhz FSB
Chipset: Intel 845GL
Videocard: Integrated Intel Extreme graphics
Sound: Integrated AC97

i never had a problem with the normal kernel in f11, but for 12 only the PAE will run stable. on the download page try either the dvd install media or the 5 cd install media as that is the only way ive ever wound up with the PAE kernel.

---------- Post added at 06:01 PM CST ---------- Previous post was at 05:55 PM CST ----------

also when you use the pae kernel be sure to install the PAE specific video drivers from the repository. here is some info about PAE http://www.linux.com/distrocentral/distroblogs/11978-fedora-11-kernel-pae-and-what-it-means-for-your-x86-32-system

lovenemesis
31st January 2010, 07:21 PM
Similar problem on a Gateway T2390 laptop with ATI HD2400XT.

When it freezes, neither the keyboard nor mouse click works. However, the music still goes on.

Now trying the PAE kernel.

daytooner
4th March 2010, 11:49 PM
This is all great info. But for me, I'm still on F11, and don't want to upgrade (re-install) unless absolutely necessary, since this is a 24x7 system.

Granted, also, that I have REALLY old hardware, this problem got really worse only after I installed the latest kde updates.

My system:

Dual PII-400GHz, w/ 256M RAM (I said it was old :-), but it is still great for a network server)
ATI Radeon 7200

When Xorg loads, I get this message at the end of the log:

RADEON DRM CS failure - corruptions/glitches may occur -12
bufmgr: last submission : r:0 vs g:266334208 w:5935104 vs v:16880022


I am running Gnome desktop, although I use some kde apps. I won't go into detail about what happens when, but basically whenever a window (or even part of one) needs repainting, CPU usage goes to 100% and all other processes stop for that to finish.

Would it be better to run the kde desktop instead? I still use some Gnome apps, but the kde ones are more important.


I have the following packages installed:
xorg-x11-server-Xorg-1.6.4-0.1.fc11.i586
xorg-x11-server-common-1.6.4-0.1.fc11.i586
xorg-x11-drv-ati-6.12.2-14.fc11.i586

which seems to be the latest (no updates available) for F11.

Any suggestions?

TIA

ken

lovenemesis
5th March 2010, 12:22 AM
My problem was solved by add nomodset to the kernel set line.

daytooner
5th March 2010, 04:03 AM
My problem was solved by add nomodset to the kernel set line.

Been there, tried that :-( .

The biggest problem with this box is that it only has 256M RAM - which is max for that CPU. But things were just bearable until the last upgrade I did that included all new kde libs and apps.

I was wondering if using the kde desktop would help with the kde apps. I also have a better video card, but it is an NVidia, and I've had nothing but grief trying to get them to work.

Thanks for the reply.

ken

jbuckley2004
23rd March 2010, 11:30 PM
My problem was solved by add nomodset to the kernel set line.

I feel really ignorant because I have not been able to apply this solution, though I've seen something like it many times. Clearly, I'm missing something.

I've seen references that say to add nomodset to menu.list, but that doesn't seem to be a file on my F12.

Where can I find, please, the procedure to add a kernel parameter? Not asking "how is this done" (unless it's a real trivial procedure) but where can I find this.

daytooner
24th March 2010, 05:59 AM
I feel really ignorant because I have not been able to apply this solution, though I've seen something like it many times. Clearly, I'm missing something.

I've seen references that say to add nomodset to menu.list, but that doesn't seem to be a file on my F12.

Where can I find, please, the procedure to add a kernel parameter? Not asking "how is this done" (unless it's a real trivial procedure) but where can I find this.

Edit the file "/boot/grub/grub.conf" (as root), append to the "kernel" line " nomodeset" (notice the space before). Reboot. Voila. Check the boot logs ("dmesg") if there is still a problem.

We all feel really ignorant. Why should you be any different :-).

ken

jbuckley2004
24th March 2010, 11:05 AM
Thanks, Daytooner.
Appreciated.