PDA

View Full Version : Packet Loss



Minase
16th January 2010, 10:56 PM
hello there,im currently running fedora 12 as a server but i have 1 weird problem :| im loosing packets out of nowhere at send and receive doesn't matter what i loose packets...

--- google.ro ping statistics ---
12 packets transmitted, 7 received, 41% packet loss, time 11598ms

can anyone help me with tips to trace what's causing this?? thank you
sometimes the machine freeze and only a hard reset will do it here is what top is saying me
i will post them later :| cause it works soo hard..
anyway CPU usage is not high ....
any info ??
thank you

here is the top


top - 00:00:39 up 3:16, 3 users, load average: 1.06, 1.03, 1.05
Tasks: 139 total, 1 running, 137 sleeping, 0 stopped, 1 zombie
Cpu(s): 0.2%us, 0.2%sy, 0.0%ni, 99.5%id, 0.2%wa, 0.0%hi, 0.0%si, 0.0%st
Mem: 1026808k total, 912568k used, 114240k free, 102304k buffers
Swap: 2064376k total, 0k used, 2064376k free, 517184k cached

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
1 root 20 0 2028 856 636 S 0.0 0.1 0:01.13 init
2 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 kthreadd
3 root RT -5 0 0 0 S 0.0 0.0 0:00.01 migration/0
4 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 ksoftirqd/0
5 root RT -5 0 0 0 S 0.0 0.0 0:00.00 watchdog/0
6 root RT -5 0 0 0 S 0.0 0.0 0:00.03 migration/1
7 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 ksoftirqd/1
8 root RT -5 0 0 0 S 0.0 0.0 0:00.00 watchdog/1
9 root 15 -5 0 0 0 S 0.0 0.0 0:00.07 events/0
10 root 15 -5 0 0 0 S 0.0 0.0 0:00.07 events/1
11 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 cpuset
12 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 khelper
13 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 netns
14 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 async/mgr
15 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 kintegrityd/0
16 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 kintegrityd/1
17 root 15 -5 0 0 0 S 0.0 0.0 0:00.03 kblockd/0
18 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 kblockd/1
19 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 kacpid
20 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 kacpi_notify
21 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 kacpi_hotplug
22 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 ata/0
23 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 ata/1
24 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 ata_aux
25 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 ksuspend_usbd
26 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 khubd
27 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 kseriod
28 root 20 0 0 0 0 S 0.0 0.0 0:00.00 khungtaskd
29 root 20 0 0 0 0 S 0.0 0.0 0:00.00 pdflush
30 root 20 0 0 0 0 S 0.0 0.0 0:00.09 pdflush
31 root 15 -5 0 0 0 S 0.0 0.0 0:00.09 kswapd0
32 root 25 5 0 0 0 S 0.0 0.0 0:00.00 ksmd
33 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 aio/0
34 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 aio/1
35 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 crypto/0
36 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 crypto/1
42 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 scsi_eh_0

Zotter
17th January 2010, 02:05 AM
Packet loss is a networking issue. Likely to be answered by your ISP.
But then, may be considered 'normal' depending on your available infrastructure.

Minase
17th January 2010, 12:19 PM
thats not a problem with ISP,i have a dedicate line with high speed.
but the problem is in fedora somewhere... maybe bind...
it's like a bottle neck somewhere but dont know where :|
the system is slow,unresponsive,and to make a complete suite after all this struggling it does crash.
Now it's weird i have added auto restart on kernel panic,but it doesn't restart :|
Maybe someone know something about this
my ethernet is from Youkon marvell 10/100/1000 Mb/s
Thank you