PDA

View Full Version : Strange Login Display



Fender Strat
16th January 2010, 03:07 PM
Hello.

I boot Fedora 12 to run-level three. Sometimes I get a string of output that follows the login prompt. Here's an example:

Fedora release 12 (Constantine)
Kernel 2.6.31.9-174.fc12.x86_64 on an x86_64 (tty1)

Home login: type=1305 audit(1263650220.847:13307): auid=4294967295 ses=4294967295 subj=system_u:system_r:readahead_t:s0 op="remove rule" key=(null) list=4 res=0type=1305 audit(1263650220.847:13308): audit_enabled=0 old=1 auid=4294967295 ses=4294967295 subj=system_u:system_r:readahead_t:s0 res=1

*** I enter my username, here. Then, ***
Password:
Last login: Fri Jan 15 10:25:45 on tty
*** and I'm logged in. ***

================================================== ==

As you can see, it does not prevent me from logging in (at which point I manually enter run-level five), and it does not happen every time I boot the machine.

Does anyone know why it prints this string after the login prompt, and what I can do to get rid of it?

Thanks.

drykod
1st February 2010, 06:40 AM
it comes from auditd, the audit daemon, and I guess you probably disabled SELINUX, why don't you also disable auditd? chkconfig auditd off

---------- Post added at 01:40 AM CST ---------- Previous post was at 12:52 AM CST ----------

u might also try just enable selinux if u want it
or try disable both of them on the kernel command line
vi /boot/grub/menu.lst (if u use grub)
then append to the kernel line :
selinux=0 audit=0

Fender Strat
1st February 2010, 02:57 PM
it comes from auditd, the audit daemon, and I guess you probably disabled SELINUX, why don't you also disable auditd? chkconfig auditd off

---------- Post added at 01:40 AM CST ---------- Previous post was at 12:52 AM CST ----------

u might also try just enable selinux if u want it
or try disable both of them on the kernel command line
vi /boot/grub/menu.lst (if u use grub)
then append to the kernel line :
selinux=0 audit=0

I have SELinux enabled. It's in "enforcing" mode. It hasn't given me any problems.

kyryder
1st February 2010, 06:03 PM
Hello,
You can change the primary command prompt to display what you want it to. For a example the following command will change the command prompt to display the username, hostname and current working directory:


PS1="\u@\h:\w <\:>\$ "

Hope this helps,

Ky

lkatkinsmith
1st February 2010, 06:11 PM
Here is a question that I have, it is not about fedora but it is about (content deleted by Admin - post is out of bounds) I used to be able tthe only other programmer in my school reported it to the system administrator of our school, now the exploit is fixed, (again, improper question - deleted)???? Also, the problem with the startup screen in fedora, you can search on google, you will find that it pops up with like.... A million results. Thanks, this is just about all for now, does any1 here know how to become an administrator of this forum???? Thanks

lkatkinsmith

---------- Post added at 09:11 AM CST ---------- Previous post was at 09:11 AM CST ----------

is any1 here???

bob
1st February 2010, 07:10 PM
On the Admin position, you spend thousands of hours for free, blackmail a few people, kill a few more and presto! You're in Charge! :D

Now, as to your illegal activity. We don't condone or accept any such posts. This is a Forum designed to assist people with good, valid uses, not illegal ones. One more such post and you'll go elsewhere very quickly. :mad:

jonshouse
1st February 2010, 07:42 PM
What "illegal activity" - if it refers to a post thats been removed then also remove this comment.....

Hlingler
1st February 2010, 07:55 PM
The deleted content (in Post #5) was about "cracking", which is prohibited. Post #5 was auto-moderated (invisible to public view) by the Forum filters, prior to edits.

V

Fender Strat
1st February 2010, 11:14 PM
Hello,
You can change the primary command prompt to display what you want it to. For a example the following command will change the command prompt to display the username, hostname and current working directory:


PS1="\u@\h:\w <\:>\$ "

Hope this helps,

Ky

Thanks for the reply. My issue, however, has nothing at all to do with the shell prompt.

kyryder
1st February 2010, 11:45 PM
Thanks for the reply. My issue, however, has nothing at all to do with the shell prompt.

Oops, I did that twice today after lunch. No more martini lunches for me. :D