PDA

View Full Version : My sata dvd/witer doesn't work.



12235322
12th January 2010, 02:30 PM
when i press the button of the dvd ,the door opened and closed at the same time.

my dvd/witer is SATA driver.

i wish you help me.

thanks.

scott32746
12th January 2010, 02:43 PM
For starters check the cables inside make sure the are plugged in all the way.
Has it worked before ?
does Linux see it ?
# hwbrowser
or
# lshw > /tmp/lshw.output , then look for DVD

If not there you drive could be bad

12235322
12th January 2010, 03:18 PM
For starters check the cables inside make sure the are plugged in all the way.
Has it worked before ?

yes, i tried it at windows and it work.


does Linux see it ?

yes.

scott32746
12th January 2010, 03:26 PM
Not totally sure what the problem you are having.
You did write something about it open/close fast.
try from command line
eject to open
eject -T to close

12235322
12th January 2010, 03:51 PM
eject to open
eject -T to close
Reply With Quote

it's opened and suddenly close.

12235322
3rd May 2010, 01:15 PM
hi there,

i have problem in my cdrom :

the door refused to open .

i tried to type the command " eject " ;
the result was that the door was opened and suddenly closed again " this operation took 5 seconds" .

what shall i do ,

i tried it on fedora 12 and on fc13-beta but didn't work but ,
when i tried it on windows , it worked normally.

note : my cdrom type is ::

sony
dru-870s
sata
-------------------------------------------------------
and this it all information :

http://www.sony-optiarc.eu/products/retaildrives/dru870s.html

scott32746
3rd May 2010, 01:27 PM
Hello,
see post http://forums.fedoraforum.org/showthread.php?t=243689&highlight=eject

12235322
3rd May 2010, 02:29 PM
sorry ,
but didn't work,
i read the all page ,
but didn't work.
---------------------
if i lost some steps , please write steps to excute it,

i will wait you >

scott32746
3rd May 2010, 02:33 PM
From command line

> su -
# echo "# disable auto close on cdrom/dvd" >> /etc/sysctl.conf
# echo "dev.cdrom.autoclose = 0" >> /etc/sysctl.conf
# reboot

12235322
4th May 2010, 12:32 AM
sorry , but it didn't work.

Dan
4th May 2010, 01:08 AM
Threads merged. Please read the forum posting rules.

12235322
5th May 2010, 08:21 AM
i shocked when i saw your reply,

but so what ,
i read the rules ,
i searched for this problem ,
i wait fc-13 as to be sure that the problem was solved " but it's not" .

i wrote this problem along ago but with no reply,
--------------------------------------------------------------------
tell me what i should do to do

Dan
5th May 2010, 11:33 AM
Perhaps instead of breaking the rules by starting multiple threads on the issue, you might simply append the results of any further research you have done yourself to this thread.

12235322
5th May 2010, 11:42 AM
you are completly right ,

but , i had problem , and i have searched into the forum and no result.

i tried each solution in this page :

tell me what i should do .

Dan
5th May 2010, 11:49 AM
tell me what i should do . Ok. Here's a starting place.

1) This is a user-helping-user support forum. It may be a language issue, but it always works best to ask instead of demand. The forum staff and membership are all volunteers. They, (we) tend to respond to demands by ignoring the one demanding.

2) Please read the forum posting rules. All olf them. And fully comply with them.

3) There have been at least two threads about this issue within the last two weeks. Try a more careful search using the google search option in the search box drop-down link above.


Once you've done that, post back with your results.

Alternatively, you can file a bug report against this driver at bugzilla. The links are in my signature.

12235322
5th May 2010, 12:57 PM
ok ,, sure,,

thanks,

---------- Post added at 03:41 AM CDT ---------- Previous post was at 02:54 AM CDT ----------




[root@localhost ~]# eject -v cdrom
eject: device name is `cdrom'
eject: expanded name is `/dev/cdrom'
eject: `/dev/cdrom' is a link to `/dev/sr0'
eject: `/dev/sr0' is not mounted
eject: `/dev/sr0' is not a mount point
eject: checking if device "/dev/sr0" has a removable or hotpluggable flag
eject: `/dev/sr0' is not a multipartition device
eject: trying to eject `/dev/sr0' using CD-ROM eject command
eject: CD-ROM eject command failed
eject: trying to eject `/dev/sr0' using SCSI commands
eject: SCSI eject succeeded







i tried this ---> and this is the result ;;

---------- Post added at 03:57 AM CDT ---------- Previous post was at 03:41 AM CDT ----------

it seemed that someone has made a patch :

Comment 26

https://bugzilla.redhat.com/show_bug.cgi?id=453095#c26

------------------------------------
but i don't know how to do that > " help "

CiaW
5th May 2010, 04:29 PM
Comment 80 and 81 on the above bugzilla is what fixed the problem for me in F12 (and I know I posted about that in another thread on this forum).
Try that and to be specific, it is:

# mv /lib/udev/rules.d/70-anaconda.rules
/lib/udev/rules.d/70-anaconda.rules.old

However, if you read further down on the bugzilla you'll see that didn't work for some, but deleting anaconda completely solved the issue for them, I believe.

Lastly, I'm using Fedora 13 right now and haven't had that issue at all and it's a clean install of the beta.

12235322
6th May 2010, 02:27 PM
70-anaconda.rules


i don't have this file

12235322
7th May 2010, 06:47 PM
Lastly, I'm using Fedora 13 right now and haven't had that issue at all and it's a clean install of the beta.

unlikely me ,

i have fc-13 but no change

CiaW
8th May 2010, 01:35 AM
The only other thing I would suggest is to try removing anaconda. Just make sure that yum isn't trying to remove other things at the same time, because you'd probably need those other things.

The other thing you could try is to read the bugzilla and see what other people have suggested, or file your own bug report if your problem is different. You haven't really told us much except 'it didn't work' or that a particular file isn't on your system.