View Full Version : vpnc on F12 somewhat broken

9th January 2010, 01:28 PM

I put this out there as a warning as well as a question.

I'm having problems with vpnc on F12 that work fine on F10 and F11. On F12, I can connect and can do some activities, but so far I noticed the following (show-stopping) issues:

Attempting to connect to an Oracle database using either sqlplus or TORa hangs and eventually times out. I tried both the 11G and 10G instant clients.
Copying a file to the host via a smb:// mount in nautilus freezes. An empty file is created though.
A rdesktop client opens a "black" window and goes no further.

I attempted to downgrade vpnc on my F12 workstation from vpnc-0.5.3-4.fc12.x86_64 to vpnc-0.5.3-3.fc11.x86_64 to no avail. I also downgraded libgcrypt too and this didn't help either. Moreover, I upgraded these to the F13 rawhide version - still no luck.

I also confirmed on a F11 virtual machine that these work and that it doesn't work on 2 x64 and 1 x386 F12 machines. (The configuration and the host are the same in all cases.)

Any ideas would be appreciated.

9th January 2010, 01:41 PM
I think that if you can confirm it, it merits filing a bug. The only one of those that I tested (and this is on rawhide, not F12,) was rdesktop on a machine that doesn't have gnome. It's also on an i686 system, not 64 bit. It worked for me without problems

However, as you've tested on 3 machines and found the same issues on all 3, it's probably worth filing a bug against it. Doing a quick look at


doesn't seem to indicate any other reports about the problem. (I just did a quick scan of the subject lines of the 40 plus bugs listed. )

I wonder if, as I don't have the rdesktop problem in F13, there's a possibility that it's a Gnome or NetworkManager issue, rather than a vpnc issue? (I don't use NM either, I set up my network manually.)

9th January 2010, 02:55 PM
Thanks for the quick response and the information!

Just to be clear, the three issues I cited normally work fine on F12 but not when run across a vpnc connection.

Also, I also tried running vpnc as root from the command line as well as being configured from NetworkManager. No luck. Typically, I set up a "gateway" Fedora virtual machine to a remote site whereby users run a vpnc script as sudo and multiple users can share the same connection. This issue arose on my first F12 VM.

Further, I've run vpnc with --no-detach and --debug 3 and could see no obvious problems or error messages.

Before filing a bug, I think I will play with it some more and confirm on another host. Meanwhile, I'll use F10 for my gateway.