PDA

View Full Version : About the Wireless Card



agapetom
1st January 2010, 07:08 AM
Hey Guys!

I am using my laptop with TP-Link WN310G on Fedora 12.

The Problem is,

there are two lights, one is Status, another is Activities.

When I finish my Fedora setup, the Status is always turn on, but the Activities is not.

But I can connect the WIFI! But! When I go to google, it is fast! but when I click the item by Google, it has to wait for long time, or do not.

Why?

Is my Wireless card so old or what? What should I do? Thank you very much!!

bbfuller
1st January 2010, 12:03 PM
Hello agapetom

Welcome to the forum.

I assume you are running Firefox, otherwise you'll need to try something different to my proposal below.

It may be that you are having a problem with the preference of Fedora for using the new ipv6 form of addresses to ipv4. It seems to happen to some people and not others.

In the Firefox address bar type:


about:config

Go there and promise to be careful as the screen says. In the filter bar type:


ipv6

It should filter down to one line that says:


network.dns.disableIPv6; false

Double click on it. That will cahnge the False to True. See if you are able to surf any easier.

You "may" need to restart the browser for this to take effect.

EDIT: If it's working, don't worry too much about the lights on your wireless card. They are usually the last things a driver developer worries about.

agapetom
1st January 2010, 01:47 PM
Well, I don't say it is best, but it is better. But only the Firefox can work? I installed the Google Chrome, it is slow or doesn't work also.

Is there any setting for the system? Or something else? Should I setup the IPV6 on my system setting too? Anyway, thank you somuch!

bbfuller
1st January 2010, 03:23 PM
Hello agapetom

Yes, there is a setting for the whole system if it improves the performance enough to make it worthwhile.

It's becoming rarer though to need to do it and although I've seen it more recently, this is the latest reference I can easily find to it on the forum:

http://forums.fedoraforum.org/showthread.php?t=205141

I suppose one other course of action may be to try changing your dns server if that is a course open to you.

The open dns servers seem to work pretty well.