View Full Version : yum broken [Errno 14] PYCURL ERROR 7

27th December 2009, 06:54 PM
hello, yum is completely broken . I cannot install or update any software. yum is always throwing:

Loaded plugins: presto, refresh-packagekit
Could not retrieve mirrorlist http://mirrors.rpmfusion.org/mirrorlist?repo=free-fedora-12&arch=x86_64 error was
14: PYCURL ERROR 7 - ""
Error: Cannot retrieve repository metadata (repomd.xml) for repository: rpmfusion-free. Please verify its path and try again

I have tried globally to disable the gpg check as stated in other threads. I have no proxies or such in yum.conf or in my bashrc. If I manually click on the link it will resolve in firefox so I am sure it is not my net connection per se, it seems yum or curl is adding a : to the end of the url thats why it wont resolve properly . I have done a yum clean all , which didnt really help either. reinstalling the rpmfusion repos isnt an option either as I start getting curl errors in the terminal. I am really at a loss here and am completely out of ideas as I cant install any updates or software , at first I thought the repositories were having problems with the holidays but this has been going on for 4 days now. /var/log/messages isnt showing anything either. Any help would be greatly appreciated.

my /etc/yum.conf


27th December 2009, 07:11 PM
It just means the mirror list is not available.
It has been discussed on several threads.

What are you trying to do as far as updating?
You could add to the yum --disablerepo=romfusion for a one time yum update.

or yum clean all (with only RPMFusion repo enabled.

Several thing to try but it will most likely be working in later.


27th December 2009, 07:20 PM
hey cool thanks for the reply . Yeah it seems like they have updated the repo, imported the new key , and stuff and its working again . Is there any place on their website (rpmfusion) where the announce stuff like this ?

29th December 2009, 08:51 AM
I faced the same problem, due to the presence of two yum.conf files. One was under /etc and another one was under /etc/yum. All the settings were there in the former and the latter was empty. It seems, yum gives priority to the /etc/yum/yum.conf file (which was empty in my case). So, once I moved the /etc/yum.conf into /etc/yum/yum.conf, yum started working.