PDA

View Full Version : Calendar is broken after update



Bad2theBone
18th December 2009, 11:20 PM
Just got today's F12 updates, which included changing Firefox, Thunderbird & Lightning from Beta to full releases (FF=3.5.6; T'Bird=3.0; Lightning=1.0-0.16.20090916hg.fc12.x86_64). My remote calendars from Google come up fine but my local "home" calendar now gets the following errors:

Error: Error updating timezones: Error: mozIStorageStatement::step() returned an error
DB Error no such column: recurrence_id_tz

Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [mozIStorageStatement.reset]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: file:///usr/lib64/thunderbird-3.0/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calStorageUpgrade.jsm :: ensureUpdatedTimezones :: line 380" data: no]

I had some events scheduled that I can't access anymore on the local calendar. Any ideas or work-arounds?

---------- Post added at 05:20 PM CST ---------- Previous post was at 03:54 PM CST ----------

Found fix in following bug report: https://bugzilla.redhat.com/show_bug.cgi?id=542736#c5. Apparently there is a problem with sqlite.local not being created correctly on the update. You can just cut and paste the commands from the web page onto the terminal window. Works great now.

erroneus
19th December 2009, 03:30 PM
Confirmed! Thanks for posting the answer here!


SOLUTION:

There is a schema problem with the lightning database.
Do the following:

-Stop thunderbird

-Go to the calendar-data in your thunderbird profile:

cd .thunderbird/???????.default/calendar-data

-Load up sqlite client on database file:

sqlite3 local.sqlite

-Add a few missing columns to two tables:

sqlite>ALTER TABLE cal_relations ADD recurrence_id INTEGER;
sqlite>ALTER TABLE cal_relations ADD recurrence_id_tz TEXT;

sqlite>ALTER TABLE cal_attachments ADD recurrence_id INTEGER;
sqlite>ALTER TABLE cal_attachments ADD recurrence_id_tz TEXT;

-Leave client

sqlite>.exit

-Rstart thunderbird

r1d1
19th December 2009, 05:43 PM
Thanks for this guys, it worked perfectly for me in both Thunderbird/Lightning and Sunbird.

DZ*
19th December 2009, 09:03 PM
That fixed the local calendar.

The network "google calendar" stopped working after the last Thunderbird/Lightning update. When I click on it, it says "the provider for this calendar could not be found."

---------- Post added at 12:03 PM CST ---------- Previous post was at 11:43 AM CST ----------

P.S. I can make the google one work "read-only" as follows but the writing fails; gives
"error code: "MODIFICATION_FAILED". Any ideas?

The previous access address (that worked before) was under

http://www.google.com/calendar/
Settings -> Calendars -> (name) -> Private Address -> XML

Now the remote calendar needs to be of iCalendar type and the address should be
Settings -> Calendars -> (name) -> Private Address -> ICAL

netsuvi
20th December 2009, 07:49 PM
hi erroneus.
Same thing here. Do you know if there is going to be an automatic update that is going to fix this as well?
just asking.

---------- Post added at 07:49 PM CST ---------- Previous post was at 07:35 PM CST ----------

In every case. the workaround works great. I am happy to have my going to a concert dates back.

Emphyrio
20th December 2009, 09:32 PM
This did not.... REDACTED





Never mind....I'm just not as smart as I think I am.

Bad2theBone
20th December 2009, 09:39 PM
[QUOTE=netsuvi;1308515]hi erroneus.
Same thing here. Do you know if there is going to be an automatic update that is going to fix this as well?
just asking.[COLOR="Silver"]

Just found this bug report, the link will take you to the actual report. https://bugzilla.redhat.com/show_bug.cgi?id=548380 By checking it you will see any updates to the status of it. They generally will have a comment that "patch has been posted on {RELEASE}/updates/ and so on or something like that, to indicate that an update is or shortly will be available. Hope that answers your question.