PDA

View Full Version : Helping a Friend



rosswmcgee
17th December 2009, 04:01 PM
I am helping a friend who has no audio using Ubuntu 9.10. I read and tried most forum fixes to no avail. So I installed F12 which I use on my own computer and have the same problem. In sys/pref/ sound/ thardware here is no device. That was the same in Ubuntu. I know the sound card is there and that it works, because if I remove the monitor and just boot up I hear the boot up sound. Some how there must be an easy way to find the driver for this sound card.

kyryder
17th December 2009, 04:11 PM
Hello,
You might want to take a look at the output from lspci and see if the sound card is listed. If it is not a pci type try dmesg and it should be listed. Post back the appropriate lines from the commands I listed and maybe someone can help you.

Best of luck

Ky

rosswmcgee
17th December 2009, 05:05 PM
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 741/741GX/M741 Host (rev 03)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SiS AGP Port (virtual PCI-to-PCI bridge)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS964 [MuTIOL Media IO] (rev 36)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev 01)
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.2 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet (rev 91)
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV100 QY [Radeon 7000/VE]

PatMcLJr
17th December 2009, 05:06 PM
maybe rest the bios, like the jumper thingy or unplug the box and take the battery out for a while to get the bios to reset?

seems like you might have a pci conflict with your video card?

all guesses, good luck.
Pat Jr.


MuTIOL Media

OK guess not

PabloTwo
17th December 2009, 05:59 PM
Checking on my F12 install for a kmod for an SIS audio chip, I only find:

/lib/modules/2.6.31.6-166.fc12.i686/kernel/sound/pci/snd-sis7019.ko

You could check to see if that module is being loaded, which it probably isn't. lsmod | grep snd

If not, you could load it and see what happens, if anything: modprobe snd-sis7019, as root.
The worst that could happen is the entire block you live on could expolde.

rosswmcgee
17th December 2009, 07:26 PM
I followed your tip. Now f12 will not boot completely. I get the msg unexpected inconsistency run fsck manually.


Do not know how to do that.

PabloTwo
17th December 2009, 07:51 PM
Well, sorry to hear that. But loading the snd-sis7019.ko kernel module manually should not in any way have effected the filesystem, which seems to have a problem now since the error is telling you do a filesystemcheck.

I don't recall if fsck must be run on an unmounted file system or not, but since you can't boot, you'll need to get the advice from someone who knows more about how to run fsck on partitions from rescue mode, as I don't know the details on how to do that as I've never had to do so, yet. Knock on wood. Or search the forum, there should be plenty of threads with instructions on how to do that.

Have you tried booting more than once? How far into the boot up process do you get when that error appears? Is it before the graphical boot screen comes on?

rosswmcgee
17th December 2009, 08:01 PM
I get about 75% up the boot process. Is there a way to get into the bios to do a recovery? I try escape and the F keys but
always get to grub. I need to do a sys recovery somehow.

PabloTwo
17th December 2009, 08:20 PM
Is there a way to get into the bios to do a recovery? I try escape and the F keys but
always get to grub. I need to do a sys recovery somehow.
If the problem is a messed up file system, there is nothing in the bios that will remedy that. You are probably not pressing the right key(s) early enough in the boot up process to get to the cmos setup (bios) program. The key or key combination you press to do that varies from bios vendor to bios vendor. If you are using an LCD monitor, they are cold start responsive enough you should see on the screen what key or keys to press to enter cmos setup. Many crt displays are so slow to "warm up" before they actually display an image, that early screen message is already been and gone. The DEL key works for me.

If you can't find or figure out the right key(s) to press to enter cmos setup, if what you want to do is "reset" the bios defaults, most motherboards have a two pin jumper, usually labelled "CMOS" or "BAT" that can be removed for a minute or two then replaced. That will set the bios back to factory default. If you try this, be sure everything is powered down and the power supply is unplugged from the AC outlet. But again, nothing in the bios will fix a borked file system.

Your other option, since this is a new install, is to just reinstall.

How old is this machine, and in particular, the hdd? My thinking is that all that SIS chipset stuff kind of dates this as an older motherboard, and if the hdd is old too, it may be going south.

rosswmcgee
17th December 2009, 10:23 PM
Mui Bueno Pablo! The delete tab got me to the bios. I am going re- install his Ubuntu and give his machine back!

---------- Post added at 01:23 PM CST ---------- Previous post was at 11:55 AM CST ----------

By the way here is the bottom line. I removed the telephone modem, removed the sound card/ put sound card in the telephone modem slot/ and Ubuntu recognized it. Voila! I must say the f12 forum help is the best and my favorite distro.

PabloTwo
18th December 2009, 12:35 AM
A little while ago I was out on the deck of the house, eating some pistachio nuts and watching our cat out in the yard, and thinking... "wonder if that guys sound card is a pci slot card and if it is I should have suggested to reseat the card." This is a not so uncommon occurrence, expansion slot cards can suffer from "creep", where, little by little they basically creep upwards out of the slot until at some point a critical contact is lost and the card "disappears" from the system.

That's the main reason both AGP and PCI-E video cards have those additional hold-down locks on the motherboard. Your changing slots probably wasn't so much of the cure as the fact that doing so reseated the card properly when you did it.

rosswmcgee
18th December 2009, 02:51 AM
I am a retired 70 year old. Computers are a way to keep the mind from going stale. I know this is nuts, but I offered to help the man with his computer. The night before I was to get his computer I tossed and turned with various ideas on how to fix it. I went through so many Ubuntu how to fix threads, followed, the directions all to no avail. The card was seated properly I had checked that. I think there was some interference, as the video and sound card were so close. Another man had tried to fix this computer and actually replaced the sound card. again to no avail. Any way I almost bought some pistachios myself today, but ended up buying some spicy soy nuts instead. lol The great thing about the Fedora forums are the email, replies. With Fedora I have had few posts, because the help I needed with the new F12 install was quick and accurate. Thanks again! Ross