PDA

View Full Version : RPM "Read-only file system"?



texplorer
17th December 2009, 03:06 PM
[root@Fedora-VM Packages]# rpm -ivh gcc-4.* glibc-devel-2* />glibc-headers-2*
bash: glibc-headers-2.11-2.i686.rpm: Read-only file system


Hi, I ran the above command and get 'Read-only file system'. what is going on here?

Thanks,

scott32746
17th December 2009, 04:37 PM
Not sure what the command is to do, but it looks lke you are trying to write over/into glibc-headers-2.11-2.i686.rpm

If that is something you want may need to check the file with
# lsattr filename
if you something like ---i----e , the i stops any one from over writing it.
to change that
# chattr -i filename

PabloTwo
17th December 2009, 05:44 PM
The problem is that you typed "/>" in front of the glib-headers-2* filename. Why did you do that?

texplorer
24th January 2010, 12:43 PM
Sorry about the confusion. I was away during Xmas time, and was very busy.
I just try to do a excise in the book.
I was just trying to install Gcc-4.* then I got more failed dependencies than the book has anticipated in red text below. I would appreciate someone can walk-through this with me.


[Tom@Fedora-VM Packages]$ rpm -ivh gcc-4.*
warning: gcc-4.4.2-7.fc12.i686.rpm: Header V3 RSA/SHA256 signature: NOKEY, key ID 57bbccba
error: Failed dependencies:
cloog-ppl >= 0.15 is needed by gcc-4.4.2-7.fc12.i686
cpp = 4.4.2-7.fc12 is needed by gcc-4.4.2-7.fc12.i686
glibc-devel >= 2.2.90-12 is needed by gcc-4.4.2-7.fc12.i686


Plus I don't know what command I should type in for installing the last line of the glibc-devel dependency either.

leigh123linux
24th January 2010, 12:59 PM
Sorry about the confusion. I was away during Xmas time, and was very busy.
I just try to do a excise in the book.
I was just trying to install Gcc-4.* then I got more failed dependencies than the book has anticipated in red text below. I would appreciate someone can walk-through this with me.


[Tom@Fedora-VM Packages]$ rpm -ivh gcc-4.*
warning: gcc-4.4.2-7.fc12.i686.rpm: Header V3 RSA/SHA256 signature: NOKEY, key ID 57bbccba
error: Failed dependencies:
cloog-ppl >= 0.15 is needed by gcc-4.4.2-7.fc12.i686
cpp = 4.4.2-7.fc12 is needed by gcc-4.4.2-7.fc12.i686
glibc-devel >= 2.2.90-12 is needed by gcc-4.4.2-7.fc12.i686
Plus I don't know what command I should type in for installing the last line of the glibc-devel dependency either.

Throw the book away ;)



su
yum install gcc