PDA

View Full Version : error while loading shared libraries libsyncevolution.so.0



piet85
15th December 2009, 04:59 AM
Hello at all,
I try running syncevolution, but it wont work for some reason. In command line I get this error: "syncevolution: error while loading shared libraries: libsyncevolution.so.0 cannot open shared object file: no such file or directory".
Syncevolution and evolution are installed in latest version (syncevolution: 0.9.3 evolution: 2.28.0). I found nothing helpful by searching after this bug. Would be great if anyone could help!

tinti
17th December 2009, 11:34 AM
did you find a solution, I have the same problem on F12 x86_64?

ln -s /usr/lib64/syncevolution/libsyncevolution.so.0 /usr/lib64/libsyncevolution.so.0 did it

airekans
17th December 2009, 03:08 PM
This is possibly caused by having not loaded the library in the memory.

Firstly, check whether your system contain the needed library file. May be you can use "rpm -ql pkg_name" to check.
If it is, then make sure the file has been loaded in memory. Type "# ldconfig -p" to check the list.
If it is not loaded, then use ldconfig to load it.
That the dynamic library cannot be finded is almost caused by this.

piet85
18th December 2009, 01:03 AM
Hey thank you, that solved my problem.
I just added the location where the libsyncevolution.so.0 is stored, to ld.so.conf and then run ldconfig and all works fine. (Don't know whether it is necessary to add the location, maybe it's enough to type ldconfig.)

airekans
18th December 2009, 02:54 AM
Whether it's necessary to add the location in /etc/ld.so.conf/ depends on where your library is stored.
By default, ldconfig will load things in /lib, /usr/lib, and locations you specified in /etc/ld.so.conf. So it works if you put a link in /lib or /usr/lib to the library, or just write the location in the setting file.
You had better read the manual of ldconfig to know about it.

Cheers.

piet85
18th December 2009, 03:57 AM
I searched for a manual and only found an inofficial one. There was described how to write the location of the library in the settings file and load it. But it was not mentioned which folders are set to be loaded by default. So that's the reason why I was not really sure. I guessed it would be some kind of like you wrote, but I didn't want to misinform Tinti, so i wrote that I'm not sure.
But it doesn't matter, in the end it works and I'm pretty sure for Tinti it'll work too, so all is fine now!:D