PDA

View Full Version : Python bug



gauchao
14th December 2009, 11:47 PM
I have been trying to run Yumex under F12, x86_64. It always crashes when it finishes to resolve the repositories and then the Automatic Bug Reporting tool blinks indicating a bug in python 2.6.2-2.fc12. Anyone else has seen the same bug? What have you done to solve it?

Demz
14th December 2009, 11:53 PM
i would think yumex is the problem here. what if you use yum in Terminal ? any crashes then?

hve you tried doing a yum clean all in Terminal? an then try yumex

what repo's do you have? yum repolist

gauchao
15th December 2009, 12:13 AM
Yum works fine in Terminal. I have the adobe-linux-i386, Fedora 12 - x86_64, livna (only for dvd playback)rpm.livna.org rpmfusion-free, rpmfusion-free-updates, rpmfusion-nonfree, rpmfusion-nonfree-updates, updates Fedora 12 - x86_64 - Updates enabled. Yum clean all followed by Yumex gives the same result...

Demz
15th December 2009, 12:40 AM
well in all Honesty you should be using the Adobe Flash player 64bit not the 32bit one ..sounds to me more of a yumex Problem than anything else http://forums.fedoraforum.org/showthread.php?t=205642

try removin the 32bit Flash an install the 64bit one

gauchao
15th December 2009, 01:13 AM
I am already using the alfa 64bit Flash. I have installed it from the tarball file from adobe. The repo is enabled because have installed adobe reader from it. Anyway, I could try to install a newer YUMEX from rawhide using YUM in terminal... what do you think? How do I enable the rawhide repo in yum?

---------- Post added at 04:11 PM CST ---------- Previous post was at 04:05 PM CST ----------

Sorry for the silly question: yum --enablerepo=rawhide install yumex...

---------- Post added at 04:13 PM CST ---------- Previous post was at 04:11 PM CST ----------

Nope, it didn't work. Upgraded to yumex 2.9.4-1.fc13, the same crash and the same bug reporting tool (python)...

Demz
15th December 2009, 02:04 AM
i dunno what else to suggest but to think there's a Problem with yumex. i suppose all you can do is look in redhat bugzilla for any similar Bugs reported to see what oir if there are any fix's

citojaso
18th December 2009, 02:32 PM
Have been pullin hair....my hair...trying to find an answer to my problem. Yumex crashes if it's run from terminal or menu. Auto bug report claims a problem in python. When i tell auto bug to report it never completes, it hangs on "getting backtrace".

I've reinstalled yumex, closed different repos, reinstalled python, tried different install of flash, all for nothing.

Still unable to use yumex.

Myope-Eagle
18th December 2009, 07:45 PM
I have exactly the same symptoms (yumex & abrt) on an Intel 32 bits laptop after the last update run of Fedora 12.

Before the update yumex was perfectly running.

I have also discovered that even drpython is no more working.

Thanks in advance for any suggestion

Demz
18th December 2009, 11:27 PM
could be a Bug in both python an Yumex

David Batson
19th December 2009, 02:51 AM
Just happened to me. Was working fine earlier today, then I performed the following updates via Yum Extender and now Yum Extender crashes with a Python error.

Redhat bugzilla is also down atm.


[david@localhost ~]$ rpm -qa --last | head -50
coreutils-libs-7.6-8.fc12 Fri 18 Dec 2009 06:26:08 PM MST
audit-2.0.4-1.fc12 Fri 18 Dec 2009 06:26:08 PM MST
coreutils-7.6-8.fc12 Fri 18 Dec 2009 06:26:06 PM MST
gnome-python2-libegg-2.25.3-14.fc12 Fri 18 Dec 2009 06:26:03 PM MST
gnome-python2-gtkhtml2-2.25.3-14.fc12 Fri 18 Dec 2009 06:26:02 PM MST
firefox-3.5.6-1.fc12 Fri 18 Dec 2009 06:26:00 PM MST
gnome-python2-extras-2.25.3-14.fc12 Fri 18 Dec 2009 06:25:54 PM MST
tar-1.22-10.fc12 Fri 18 Dec 2009 06:25:53 PM MST
gtk2-immodule-xim-2.18.5-3.fc12 Fri 18 Dec 2009 06:25:52 PM MST
nautilus-sendto-2.28.2-1.fc12 Fri 18 Dec 2009 06:25:51 PM MST
gnome-keyring-pam-2.28.2-1.fc12 Fri 18 Dec 2009 06:25:45 PM MST
gvfs-fuse-1.4.3-1.fc12 Fri 18 Dec 2009 06:25:44 PM MST
gvfs-smb-1.4.3-1.fc12 Fri 18 Dec 2009 06:25:43 PM MST
gvfs-archive-1.4.3-1.fc12 Fri 18 Dec 2009 06:25:43 PM MST
gvfs-obexftp-1.4.3-1.fc12 Fri 18 Dec 2009 06:25:42 PM MST
gvfs-gphoto2-1.4.3-1.fc12 Fri 18 Dec 2009 06:25:41 PM MST
audit-libs-python-2.0.4-1.fc12 Fri 18 Dec 2009 06:25:41 PM MST
attr-2.4.44-1.fc12 Fri 18 Dec 2009 06:25:40 PM MST
curl-7.19.7-2.fc12 Fri 18 Dec 2009 06:25:39 PM MST
brasero-nautilus-2.28.2-4.fc12 Fri 18 Dec 2009 06:25:38 PM MST
httpd-2.2.14-1.fc12 Fri 18 Dec 2009 06:25:36 PM MST
pixman-0.16.4-2.fc12 Fri 18 Dec 2009 06:25:34 PM MST
libtar-1.2.11-15.fc12 Fri 18 Dec 2009 06:25:33 PM MST
freeglut-2.6.0-1.fc12 Fri 18 Dec 2009 06:25:32 PM MST
postgresql-libs-8.4.2-1.fc12 Fri 18 Dec 2009 06:25:31 PM MST
httpd-tools-2.2.14-1.fc12 Fri 18 Dec 2009 06:25:30 PM MST
libgnomekbd-2.28.0-4.fc12 Fri 18 Dec 2009 06:25:28 PM MST
brasero-2.28.2-4.fc12 Fri 18 Dec 2009 06:25:16 PM MST
libcurl-7.19.7-2.fc12 Fri 18 Dec 2009 06:25:13 PM MST
xulrunner-1.9.1.6-1.fc12 Fri 18 Dec 2009 06:25:11 PM MST
libattr-2.4.44-1.fc12 Fri 18 Dec 2009 06:25:06 PM MST
brasero-libs-2.28.2-4.fc12 Fri 18 Dec 2009 06:25:05 PM MST
audit-libs-2.0.4-1.fc12 Fri 18 Dec 2009 06:25:05 PM MST
gvfs-1.4.3-1.fc12 Fri 18 Dec 2009 06:25:03 PM MST
gnome-keyring-2.28.2-1.fc12 Fri 18 Dec 2009 06:25:00 PM MST
gtk2-2.18.5-3.fc12 Fri 18 Dec 2009 06:24:50 PM MST

chepioq
19th December 2009, 08:11 AM
I also have the problem with yumex after the yesterday update.
I search and I find the cause of problem:
It is the gtk2 package (gtk2-immodule-xim-2.18.5-3.fc12 ,gtk2-2.18.5-3.fc12)
I downgrade to the previous version (gtk2-immodule-xim-2.18.4-3, gtk2-2.18.4-3.fc12) and yumex work, with warning:

/usr/lib/python2.6/site-packages/guihelpers/__init__.py:199: GtkWarning: gtk_scrolled_window_add(): cannot add non scrollable widget use gtk_scrolled_window_add_with_viewport() instead
self.add_from_file(filename)
eth0 (r8169) is connected
/usr/lib/python2.6/site-packages/yumexgui/gui.py:179: DeprecationWarning: Use the new widget gtk.Tooltip
self.tooltip = gtk.Tooltips()
/usr/lib/python2.6/site-packages/yumexgui/gui.py:206: DeprecationWarning: Use the new widget gtk.Tooltip
self.tooltip.set_tip(button, tooltip)

David Batson
19th December 2009, 08:26 AM
I also have the problem with yumex after the yesterday update.
I search and I find the cause of problem:
It is the gtk2 package (gtk2-immodule-xim-2.18.5-3.fc12 ,gtk2-2.18.5-3.fc12)
I downgrade to the previous version (gtk2-immodule-xim-2.18.4-3, gtk2-2.18.4-3.fc12) and yumex work, with warning:

Yep, that works. I get a security warning though to upgrade those packages. :p


yum downgrade gtk2*

citojaso
19th December 2009, 12:28 PM
Thanks chepioq! You came to the rescue just in the nick of time. I still have a couple of hairs left on my head.

chepioq
19th December 2009, 05:03 PM
I have a new information:
The problem is only with "gtk2-immodule-xim", I remove this package and I can update the gtk2 package.
My fedora 12 work fine...
What the utility of this package?

David Batson
19th December 2009, 05:47 PM
Thanks for the info, chepioq!

Here is a bug report on the issue: https://bugzilla.redhat.com/show_bug.cgi?id=548827

JK3MP
19th December 2009, 05:59 PM
Seems like yumex has been having a lot of problems. Nice fix. Bookmarked for future help. :)

David Batson
19th December 2009, 06:24 PM
In the bug report it was asked "What is the utility of gtk2-immodule-xim ?"

The description of the RPM says: "The gtk2-immodule-xim package contains XIM support for GTK+."
http://rpm.pbone.net/index.php3/stat/4/idpl/13387713/com/gtk2-immodule-xim-2.18.4-3.fc12.i686.rpm.html

Looking further, it appears this is primarily used for entering oriental characters with a western keyboard, as well as entering special Latin characters.
In Wikipedia it says...

in the X Window System, it is called an input method. The specific built-in implementation of X11’s input method support is called XIM, short for X input method, however support for input methods is also provided by input method modules in various other parts of Unix/Linux systems including GTK+ and Qt. SCIM is a common input method managing most methods (more than 130 including UIM ones) on GNU/Linux, followed by UIM.
-------------------
Although originally coined for CJK (Chinese, Japanese and Korean) computing, the term is now sometimes used generically to refer to a program to support the input of any language. To illustrate, in the X Window System, the facility to allow the input of Latin characters with diacritics is also called an input method.
http://en.wikipedia.org/wiki/Input_method

ajamison
20th December 2009, 11:13 PM
So then why is this package installed by default on a US system that does not use Oriental languages

chepioq
22nd December 2009, 09:04 PM
The new version of gtk2 (gtk2-2.18.5-4.fc12) from koji http://koji.fedoraproject.org/koji/buildinfo?buildID=148057 solve problem.
I re-install gtk2-immodule-xim-2.18.5-4.fc12 and yumex work fine

darkman088
1st April 2010, 10:05 PM
Hello guys,

I have the same problem with yumex, though I am using Fedora 11...

$ yumex
running
Current Settings
autorefresh: True
branding_title: 'Yum Extender NextGen'
color_install: 'darkgreen'
color_normal: 'black'
color_obsolete: 'blue'
color_update: 'red'
debug: False
disable_netcheck: False
disable_repo_page: False
history_limit: 15
plugins: True
proxy: ''
recentdays: 14
repo_exclude: ['debug', 'source']
win_height: 600
win_sep: 300
win_width: 1000
yumdebuglevel: 2
/usr/lib/python2.6/site-packages/guihelpers/__init__.py:199: GtkWarning: gtk_scrolled_window_add(): cannot add non scrollable widget use gtk_scrolled_window_add_with_viewport() instead
self.add_from_file(filename)
Can't detect the network connection state
Starting yum child process
YUM: Traceback (most recent call last):
YUM: File "/usr/share/yumex/yumex-yum-backend", line 61, in <module>
YUM: my = YumServer(debuglevel, plugins, offline, repos)
YUM: File "/usr/lib/python2.6/site-packages/yumexbackend/yum_server.py", line 208, in __init__
YUM: dscb = DepSolveProgressCallBack(ayum=self)
YUM: TypeError: __init__() got an unexpected keyword argument 'ayum'
ERROR: Fatal Error : backend-not-running
ERROR: backend not running as expected (yumex will close)
yum backend process is ended
Program Terminated

Originally, I didn't have that package for oriental characters - gtk2-immodule-xim and I have decided to install it:

Installing:
gtk2-immodule-xim i586 2.16.6-2.fc11 updates 56 k
Updating for dependencies:
gtk2 i586 2.16.6-2.fc11 updates 4.5 M
gtk2-devel i586 2.16.6-2.fc11 updates 4.1 M
gtk2-devel-docs i586 2.16.6-2.fc11 updates 3.2 M

But this didn't solve the problem and I am still getting the same error when trying to start yum. Could you help me PLEASE ?? Thanks...