PDA

View Full Version : "permission denied" on terminal login -fedora 12



micah1104
11th December 2009, 04:28 AM
whenever i try to login to the terminal (ctrl + alt + F2-F6), it will say "permission denied", clear the screen and start over, i even tried to login with root

any help?

Thank you

-fedora 12

it did not work before i upgraded to 12 from 11, i thought it would fix it...

i posted it on another forum, so you can see the replies on that one:

http://www.linuxforums.org/forum/redhat-fedora-linux-help/156512-permission-denied-terminal-login-fedora-12-a.html

scott32746
11th December 2009, 04:45 AM
Hello,
Are you trying to login root from the GUI ,, If so can not. Now ctrl + alt +F2 drops you down to login prompt. but maybe you still need to #ed out /etc/pam.d/gdm and in gdm-password
#auth required pam_succeed_if.so user != root quiet
for it to work
I am thinking that you are still in init 5 that it still does not let you login as root

micah1104
11th December 2009, 03:45 PM
#ed out /etc/pam.d/gdm and in gdm-password
#auth required pam_succeed_if.so user != root quiet

i tried these two commands

the first one gave me this: 'out: no such file or directory'

the second one gave me this: 'auth: command not found'

so what exactly am i supposed to do with these?

scott32746
11th December 2009, 06:57 PM
Sorry, let me tell you the correct way

# vi /etc/pam.d/gdm

look for auth required pam_succeed_if.so user != root quiet
add # infront of the line
Use J key to move down to the line make sure cursor is in front of the first letter then push A key then ( shift 3 ) #key
now do ESC :wq!

do the same for /etc/pam.d/gdm-passwd

NOTE: J and A is in lower case.
ALSO may like to back up the file first

# cp /etc/pam.d/gdm /etc/pam.d/gdm.BKUP
# cp /etc/pam.d/gdm-password /etc/pam.d/gdm-password.BKUP

EXAMPLE OF /etc/pam.d/gdm FILE AFTER COMPLETE

#%PAM-1.0
auth [success=done ignore=ignore default=bad] pam_selinux_permit.so
#auth required pam_succeed_if.so user != root quiet
auth required pam_env.so
auth substack system-auth

micah1104
23rd January 2010, 04:40 PM
I tried that too, It didn't work either, sorry I have not replied in a bit, I kinda forgot, but any other suggestions?

madhavdiwan
23rd January 2010, 07:08 PM
you are probably missing a package that allows you to have a terminal .. try this .. inside your graphical desktop .. open up a terminal .. if you have nautilus fully installed its simply a matter of right clicking on the uncluttered space on the desktop and choosing "open in terminal " , else try navigating through the gnome menus from Applications / System Tools / Terminal

once you are in a terminal become the root user temporarily .. by typing the " su - " command

then once you are the root user update your systems packages by using the yum command

I would suggest trying the following command " yum install *onsole* *erminal* *term* "
and follow the prompts

that should install all the console, ConsoleKit, and terminal programs that you may have had missing since fedora 11

if that does not work .. then something is broken .. not just missing. come back and let me know if the idea above helps .. else we can try something else. ( ps i looked at your other post , which is why i am suggesting this approach)

micah1104
24th January 2010, 06:54 PM
That did not fix my problem, it did install a bunch of Terminal emulators which I do not need...

---------- Post added at 11:54 AM CST ---------- Previous post was at 11:40 AM CST ----------

this is what it looks like:

Fedora release 12 (Constantine)
Kernel 2.6.31.9-174.fc12.i686.PAE on an i686 (tty2)

login: micah login:
password: Then it shows this:

Permission Denied

It just clears the whole thing and then goes back to the login: prompt, it does not say incorrect login, it shows Permission Denied and then the login: thing again, if this makes it any clearer, I am already able to use the command prompt on Gnome, everything else is works perfectly (su, man, cd, pwd, ls etc...)

Thanks

Micah

madhavdiwan
24th January 2010, 07:47 PM
hmm .. since su command works lets try this .. make a new user and try loginig in with that new users credentials .. this is to test if its just your account that has the issue or the installation itself.

use the following commands to make a new user

su -
adduser testlogin
passwd testlogin

then login as the testlogin user account to your terminal at ctrl-alt-f2

if this does not work.. then you might have PAM or SELlinux issues.
Selinux issues can be tested by turning selinux off temopararily using the command " setenforce 0 "

pam issues would have to be tracked via review of the system logs

micah1104
24th January 2010, 07:50 PM
I already tried adding a new user, and I have SELinux disabled because I had problems with it, put I know nothing about PAM

madhavdiwan
24th January 2010, 08:26 PM
let start from basics .. look at the logs:

from inside gnome .. start tailing /var/log/secure with the command

tail -f /var/log/secure

you should see something like this

[madhav@server2 Desktop]$ su -
Password:
[root@server2 ~]# tail -f /var/log/secure
Jan 24 12:09:37 server2 pam: gdm-password[10736]: pam_unix(gdm-password:session): session opened for user madhav by (uid=0)
Jan 24 13:36:12 server2 login: initgroups: Operation not permitted
Jan 24 14:22:41 server2 su: pam_unix(su-l:session): session opened for user root by madhav(uid=501)


then switch to ctrl-alt-f2 and try a login ..

when it fails switch back to desktop with a ctrl-alt-f1 and copy what the tail says into this post..

then run as root user tail -30 /var/log/messages and copy that here as well.

since this did not work in Fedora 11 and now does not work in fedora 12 chances are its a config file .. or a missing package.. the syslogs should be able to help figure out what is going on.

micah1104
24th January 2010, 11:07 PM
Jan 24 16:03:58 micah login: PAM pam_parse: expecting return value; [...raquired]
Jan 24 16:04:05 micah login: pam_time(login:account): garbled syntax; expected & or | (rule #1)
Jan 24 16:04:05 micah login: Permission denied

Jan 24 15:27:21 micah NetworkManager: <info> (wlan0): supplicant connection state: completed -> group handshake
Jan 24 15:27:21 micah NetworkManager: <info> (wlan0): supplicant connection state: group handshake -> completed
Jan 24 15:27:23 micah NetworkManager: <info> (wlan0): supplicant connection state: completed -> group handshake
Jan 24 15:27:23 micah NetworkManager: <info> (wlan0): supplicant connection state: group handshake -> completed
Jan 24 15:28:01 micah NetworkManager: <info> (wlan0): supplicant connection state: completed -> group handshake
Jan 24 15:28:01 micah NetworkManager: <info> (wlan0): supplicant connection state: group handshake -> completed
Jan 24 15:32:23 micah NetworkManager: <info> (wlan0): supplicant connection state: completed -> group handshake
Jan 24 15:32:23 micah NetworkManager: <info> (wlan0): supplicant connection state: group handshake -> completed
Jan 24 15:38:00 micah NetworkManager: <info> (wlan0): supplicant connection state: completed -> group handshake
Jan 24 15:38:00 micah NetworkManager: <info> (wlan0): supplicant connection state: group handshake -> completed
Jan 24 15:41:46 micah NetworkManager: <info> (wlan0): supplicant connection state: completed -> group handshake
Jan 24 15:41:46 micah NetworkManager: <info> (wlan0): supplicant connection state: group handshake -> completed
Jan 24 15:43:30 micah NetworkManager: <info> (wlan0): supplicant connection state: completed -> group handshake
Jan 24 15:43:30 micah NetworkManager: <info> (wlan0): supplicant connection state: group handshake -> completed
Jan 24 15:46:39 micah NetworkManager: <info> (wlan0): supplicant connection state: completed -> group handshake
Jan 24 15:46:39 micah NetworkManager: <info> (wlan0): supplicant connection state: group handshake -> completed
Jan 24 15:49:26 micah NetworkManager: <info> (wlan0): supplicant connection state: completed -> group handshake
Jan 24 15:49:26 micah NetworkManager: <info> (wlan0): supplicant connection state: group handshake -> completed
Jan 24 15:50:03 micah NetworkManager: <info> (wlan0): supplicant connection state: completed -> group handshake
Jan 24 15:50:03 micah NetworkManager: <info> (wlan0): supplicant connection state: group handshake -> completed
Jan 24 15:56:56 micah NetworkManager: <info> (wlan0): supplicant connection state: completed -> group handshake
Jan 24 15:56:56 micah NetworkManager: <info> (wlan0): supplicant connection state: group handshake -> completed
Jan 24 15:58:06 micah NetworkManager: <info> (wlan0): supplicant connection state: completed -> group handshake
Jan 24 15:58:06 micah NetworkManager: <info> (wlan0): supplicant connection state: group handshake -> completed
Jan 24 16:03:07 micah init: tty2 main process (1430) terminated with status 1
Jan 24 16:03:07 micah init: tty2 main process ended, respawning
Jan 24 16:04:05 micah init: tty2 main process (2553) terminated with status 1
Jan 24 16:04:05 micah init: tty2 main process ended, respawning
Jan 24 16:05:21 micah NetworkManager: <info> (wlan0): supplicant connection state: completed -> group handshake
Jan 24 16:05:21 micah NetworkManager: <info> (wlan0): supplicant connection state: group handshake -> completed

madhavdiwan
25th January 2010, 01:37 AM
well the first thing that sticks out is it looks like you have a misspelling inside one of your pam files..

the word should be required.. not raquired ----see the top of your last post

to find the misspelling :

from inside gnome open a terminal

become root user by typing
su -
and giving the root user's password at the prompt

the change directories to the etc/pam.d directory by issueing the command

cd /etc/pam.d

then find the spelling mistake by running the grep command like so

grep raquired *

the file name will be listed first , run this command against the filename :

cat filename-you found-with-the-mispelling-in-it

suggest you copy paste the output to this forum

then we can fix it

micah1104
25th January 2010, 03:22 AM
#%PAM-1.0
auth [user_unknown=ignore success=ok ignore=ignore default=bad] pam_securetty.so
auth include system-auth
account raquired pam_time.so
account required pam_nologin.so
account include system-auth
password include system-auth
# pam_selinux.so close should be the first session rule
session required pam_selinux.so close
session required pam_loginuid.so
session optional pam_console.so
# pam_selinux.so open should only be followed by sessions to be executed in the user context
session required pam_selinux.so open
session required pam_namespace.so
session optional pam_keyinit.so force revoke
session include system-auth
-session optional pam_ck_connector.so

here it is...

BugRocks1
25th January 2010, 06:12 AM
account raquired pam_time.so

There you go edit that line to required instead of raquired :)

micah1104
25th January 2010, 03:52 PM
Thank you SO much, It worked before, but then I do not know how it got changed, so it works now!!!