PDA

View Full Version : X Fails to load in Fedora 12



teancum144
10th December 2009, 11:49 PM
I recently installed Fedora 12 on my Toshiba Tecra laptop. It worked fine for a few days, then I uninstalled xscreensaver because I use gnome screensaver. When I rebooted, the system hung at the splash screen. I booted to the command line and did a
yum install xscreensaverand rebooted. However, X failed to load again. I have attached my complete Xorg.0.log as a "doc" file. Here is the some output that may be relevant:

(II) Cannot locate a core pointer device.
(II) Cannot locate a core keyboard device.
(II) The server relies on HAL to provide the list of input devices.
If no devices become available, reconfigure HAL or disable AllowEmptyInput.
...
(II) SELinux: Disabled by boolean
record: RECORD extension enabled at configure time.
record: This extension is known to be broken, disabling extension now..
record: http://bugs.freedesktop.org/show_bug.cgi?id=20500
(II) AIGLX error: dlopen of /usr/lib/dri/nouveau_dri.so failed (/usr/lib/dri/nouveau_dri.so: cannot open shared object file: No such file or directory)


I'm still somewhat of a beginner so I may have missed other relevant log entries, so I attached the log file.

Any insights?

tashirosgt
13th December 2009, 06:07 AM
Is it X that fails to load or the desktop? Does /var/log/gdm/0:log have errors? ( -If you use Gnome. If you use KDE there must be a similar log.)

teancum144
15th December 2009, 01:08 AM
I'm not sure if it is X or Gnome. I have attached the :0.log filed renamed as 0.log.doc

tashirosgt
15th December 2009, 06:08 AM
I don't see any fatal error in those logs. (I don't claim to be a real expert either, but I have been able to correlate errors in the logs with my own video problems in earlier Fedora versions.)

Another thing to check is /var/log/messages. Try to note the time carefully so you can match it with the time of the messages in the log. You might try booting in the text mode and then using the "startx" command to reproduce the error.

teancum144
15th December 2009, 11:00 PM
I uninstalled the Gnome Desktop via

yum groupremove "GNOME Desktop Environment"
then, I reinstalled the Gnome Desktop via

yum groupinstall "GNOME Desktop Environment"
The desktop still didn't start. Then I remembered that I had been trying to start the desktop as root, so I switched to an unprivileged user and typed startx and it worked.

MercuryShadow
16th December 2009, 12:08 AM
Try renaming your xorg.conf and restarting, and see if X starts up.

su -c 'mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bak'

teancum144
16th December 2009, 01:44 AM
As I said, I'm able to start x as an unprivileged user - just not as root. Interestingly, I don't have an xorg.conf file at the default location:
[root@localhost X11]# ls -l
total 28
drwxr-xr-x. 2 root root 4096 2009-08-25 11:06 applnk
drwxr-xr-x. 2 root root 4096 2009-12-04 15:04 fontpath.d
-rwxr-xr-x. 1 root root 1332 2009-10-27 13:25 prefdm
drwxr-xr-x. 2 root root 4096 2009-12-04 12:23 xdm
drwxr-xr-x. 5 root root 4096 2009-12-14 17:03 xinit
-rw-r--r--. 1 root root 547 2009-11-10 13:08 Xmodmap
-rw-r--r--. 1 root root 493 2009-11-10 13:08 Xresources

[root@localhost X11]# ls -a
. .. applnk fontpath.d prefdm xdm xinit Xmodmap Xresources

[root@localhost X11]# locate xorg.conf
/usr/share/man/man5/xorg.conf.5.gz