View Full Version : Fedora 12 boot issues

10th December 2009, 08:42 PM
Hi, I'll try to be thourough with my description...

I've upgraded my old F11 install to F12. Things were good for a few days. Then I did something, I must have installed a program or something that didn't take. While I don't know what caused the problem, here it is:

When starting Fedora, Grub starts, and Fedora starts to boot. It freezes right after starting wine service (Wine says OK). If I go through step by step, it freezes when I say yes to load "service local". I've changed the runlevel to 3 and can get to a prompt, and can startx (brings me into a KDE desktop, although I use Gnome). When I startx, I can see that it starts the "service local" so I'm not sure what the deal is. If I don't use runlevel 3, but do step by step startup, I can say "no" to the "service local", but it still freezes.

Anyone have any idea's? Is there a way I can see what order services are supposed to be starting in as it might be whatever service is after local? I've gone into ntsysv, but I don't really know what services I should try to disable..


13th December 2009, 05:45 AM
All I remember is that in /etc/rc.d there are directories for each runlevel, like rc3.d. In those directories are files that are processed by order of the numbering scheme in their names.

13th December 2009, 09:28 AM
The command

chkconfig --list

gives you a list of services and at what runlevels they are enabled/disabled.

14th December 2009, 01:53 PM
Thanks for your replies..

I checked the rc3.d and rc5.d folders, and notice that the last service in both is S99local, so I cant see it actually being that service, or it would freeze up at both runlevels.. I'm guessing that after the services are started, then X gets going? I'm not sure why I can startx manually, but it wont go in runlevel 5. Any ideas on what I could check? Also do you know a command I can use to startx but have Gnome instead of KDE which is loading now?

thanks again for your help!!


14th December 2009, 02:04 PM
S99local is pointing to /etc/rc.local,,, Take a look inside that
rc.local is always the last thing ran.
Maybe you are having a X problem or Gnome
try updating gnome