PDA

View Full Version : LCD monitor giving "out of range" message



RobertMoniot
8th December 2009, 08:53 PM
I have more or less solved this problem, but I did not easily find the key info by searching this or other forums, so I thought I'd post it here to assist others who may have the same problem. I do still have one question (see last paragraph).

I have a Dell Optiplex GX280. Video card is Intel 82915G/GV/910GL. Running Fedora 11 with latest updates.

The issue: I recently replaced my old 19" CRT monitor (Dell P992 FD Trinitron) with a 19" Pixo TFT LCD monitor. Upon booting, the BIOS screen and GRUB boot menu appeared OK, and if "quiet" kernel boot option was removed, the initial output from booting kernel also appeared. But then the display was replaced by the monitor's error message, approximately like so:
OUT OF RANGE
VGA IN: 1024x768
H.SYNC: + 168.8 kHz
V.SYNC: + 85.1 Hz
Clock: 184.0 MHz

I infer this was happening early in execution of the rc.sysinit script.

I was able to get X windows to display by reconnecting the old monitor and running gnome-display-properties (System menu, Preferences -> Display). I reduced the vertical refresh from 85 Hz to 75 Hz and voila, when I switched back to the new display it was happy with it. This is at 1280x1024 resolution. This step allowed my new monitor to work but only after I was logged in to an X session. The login screen still gave the monitor "out of range" error. I looked on the System menu under Administration for a tool to set this display setting system-wide, but didn't see one. It turns out that Fedora 11 does not install system-config-display by default. (May I ask why not???) Once I realized it existed, I used yum to install it, and then it appeared under System menu, Administration -> Display. In the Hardware tab I changed the Monitor Type to LCD Panel 1280x1024. I left the resolution at 1280x1024 and Millions of Colors. This created an xorg.conf file that basically worked but needed some tweaking, since it specified maximum hsync and vsync values that were too conservative. This caused the highest-resolution modes to be rejected by the X server as out of range, so I only got 1024x780 resolution. I changed the maximum HorizSync to 135.0 and maximum VertRefresh to 75.0. Also I used xvidtune to create a modeline for 1280x1024 which I inserted into the "Monitor" section. Here is the section after tweaking:

Section "Monitor"
Identifier "Monitor0"
ModelName "LCD Panel 1280x1024"
HorizSync 31.5 - 135.0
VertRefresh 56.0 - 75.0
Option "dpms"
Modeline "1280x1024" 135.00 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync
EndSection

Your mileage may vary. (The dpms option is for power management and is not relevant to this issue.) This xorg.conf file allowed the login screen to display after I logged out of my session, and X resolution 1280x1024 was accepted.

So now I was in the situation where booting to the X window login was OK, but during the boot process the monitor was displaying the "out of range" message. This happened regardless of whether it was a graphical boot (rhgb option) or text mode. The problem is that the console text or graphical boot mode is not the native low-res 80x24 but a higher-res vga mode. The vga mode is not controlled by the xorg.conf file, so my fix thereof was not relevant here. I tried various "vga=xxx" kernel boot options where xxx was one of the numbers specified in places like http://www.g-loaded.eu/2005/09/30/change-the-console-resolution/ but nothing I tried worked. Note that I could not use vbetest (also not installed in default Fedora 11) because it requires you to be in a console screen, and the console screen suffered from the same problem as the boot screen. Eventually I found the kernel boot option "nomodeset" which makes the console use the native 80x24 display (like the old days), with which my new monitor is happy.

It would be nice to find some way to get back to one of the higher-resolution vga console modes. So far I have not found a way to do this. I tried using vbetest to see what vga modes were OK for the monitor. I found a couple that displayed the test pattern correctly, such as [283] 1280x1024 (8:8:8) and [280] 1024x768 (8:8:8) which correspond (by adding 512) to kernel options "vga=795" and "vga=792" respectively. However, entering either of these kernel options at boot caused the "out of range" error message again. Any suggestions for how to achieve one of these video modes would be appreciated, but I can live with it as it is.