PDA

View Full Version : F12 gnome totem rhyhtmbox broken gstreamer



finnmetal
5th December 2009, 11:14 AM
Hi I just installed F12 and then went added rpm fusion and installed gstreamer bad ugly etc etc now totem and rhythmbox will not work, they wont even open, this is what I am getting if I run them from the console. Anyone see this or have any ideas ? I didnt find much over google and it appears to be the same problem. this is a x64 install.

*edit*
here are the gstreamer plugins that are installed:


[finnmetal@cueball ~]$ rpm -qa gstreamer*
gstreamer-0.10.25.1-1.fc12.x86_64
gstreamer-ffmpeg-0.10.9-1.fc12.x86_64
gstreamer-plugins-flumpegdemux-0.10.15-8.fc12.x86_64
gstreamer-plugins-schroedinger-1.0.8-3.fc12.x86_64
gstreamer-plugins-good-0.10.16-7.fc12.x86_64
gstreamer-plugins-ugly-0.10.13-1.fc12.x86_64
gstreamer-tools-0.10.25.1-1.fc12.x86_64
gstreamer-python-0.10.16-1.fc12.x86_64
gstreamer-plugins-bad-0.10.17-1.fc12.x86_64
gstreamer-plugins-base-0.10.25.1-1.fc12.x86_64

here is the console error

[finnmetal@cueball ~]$ totem
Warning: Unable to create "trees" RDF storage.
Performance can be improved by upgrading librdf.

(plugin-scanner:2644): GLib-GObject-WARNING **: cannot register existing type `GstBaseVideoCodec'

(plugin-scanner:2644): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

(plugin-scanner:2644): GLib-GObject-CRITICAL **: g_type_register_static: assertion `parent_type > 0' failed

(plugin-scanner:2644): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

(plugin-scanner:2644): GLib-GObject-CRITICAL **: g_type_register_static: assertion `parent_type > 0' failed

(plugin-scanner:2644): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

(plugin-scanner:2644): GStreamer-CRITICAL **: gst_element_register: assertion `g_type_is_a (type, GST_TYPE_ELEMENT)' failed

[finnmetal@cueball ~]$ rhythmbox
Warning: Unable to create "trees" RDF storage.
Performance can be improved by upgrading librdf.

(plugin-scanner:2647): GLib-GObject-WARNING **: cannot register existing type `GstBaseVideoCodec'

(plugin-scanner:2647): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

(plugin-scanner:2647): GLib-GObject-CRITICAL **: g_type_register_static: assertion `parent_type > 0' failed

(plugin-scanner:2647): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

(plugin-scanner:2647): GLib-GObject-CRITICAL **: g_type_register_static: assertion `parent_type > 0' failed

(plugin-scanner:2647): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

(plugin-scanner:2647): GStreamer-CRITICAL **: gst_element_register: assertion `g_type_is_a (type, GST_TYPE_ELEMENT)' failed


---------- Post added at 11:14 AM CST ---------- Previous post was at 11:06 AM CST ----------

It was the gstreamer-plugins-schroedinger-1.0.8-3.fc12.x86_64 plugin. a yum erase and everything is working again . Weird.

loomsen
6th December 2009, 01:09 AM
Hi.

Try removing gstreamer-plugins-ugly. Worked for me afterwards.


su -c 'yum erase gstreamer-plugins-ugly'