PDA

View Full Version : Problem with mplayer (installing)



Psquared
9th October 2004, 04:26 PM
I previously used Synaptic to install mplayer, but it would not play DVDs. I read about it a little and decided I probably did not have the entire package. I used yum to uninstall it, logged out and logged back in.

When I run "yum install mplayer" this is what I get. (I have enabled the dag repositories in my yum.conf)



Finding updated packages
Downloading needed headers
Resolving dependencies
......Unable to satisfy dependencies
Package mplayer needs libpostproc = 1.0-0.11.pre5.1.fc2.dag, this is not available.
[root@lizzy peyre]# yum search libpostproc
Gathering header information file(s) from server(s)
Server: Fedora Core 2 - i386 - Base
Server: Dag RPM repository for Fedora Core
Server: Fedora.us Extras (Stable)
Server: Livna.org - Fedora Compatible Packages
Server: macromedia.mplug.org - Flash Plugin
Server: NewRPMS.sunsite.dk for Fedora Core 1
Server: Fedora Core 2 - i386 - Released Updates
Finding updated packages
Downloading needed headers
Looking in available packages for a providing package
No packages found
Looking in installed packages for a providing package
Installed package: libpostproc.i386 0:1.0-0.11.pre5.1.fc2.fr matches with
libpostproc
1 results returned


Notice that the libpostproc file it looks for ends with .dag and the one installed ends with .fr. I plan to comment out the dag repos and try again.

I could not get Xine to play a DVD until I uninstalled mplayer. Now it works. However, I want the mplayer plugin for Firefox. Surely the two can play nice together. :D

Psquared
9th October 2004, 06:01 PM
I found the solution. Wrong version of libpostproc came from mixing repos.

http://www.redhat.com/archives/fedora-list/2004-January/msg04035.html

I did "yum remove libpostproc" and then did "yum install mplayer."