View Full Version : GRUB boot problems

28th February 2004, 08:20 AM
Hi everybody, :)

This is my problem:

I have 3 partitions , 1 Windows, 2 Fedora, 3 Documents.
In Windows, using Partition Magic, I deleted the 3rd partition, and in that place, I created two more partitions, one in NTFS and the other in FAT32. Now, in total, I have 4 partitions.

I use GRUB installed in the MBR to boot Windows XP and Fedora Core. Everything was just fine until I deleted that 3rd partition.

I think that I broke GRUB deleting that partition and making other partitions. Obviously, now, I can't boot any system and what appears to me is the GRUB minimal bash-like line screen.
I read a lot about how to fix this problem, but I couldn't resolve it.

Please, could someone help me...? :(

Thank you :)

28th February 2004, 10:02 AM
Insert the 1st Fedora CD and at the prompt enter linux rescue. When you get to the screen asking about how to mount your partitions, select skip becuase you don't want your partitions mounted during grub re-installation. When you get to the root prompt type:

chroot /mnt/sysimage
root (hd0,1)
setup (hd0)

Change the (hd0,1) to the boot partition. i.e. The first number is the hard disk number and the second is the partition number.
e.g. my /boot partition is on /dev/hda2 so my root would be: root (hd0,1) (numbering starts at 0).
The issue a three-finger salute and hopefully thing's are back to normal.

An equivalent command you could use is:

grub-install --root-directory=/boot '(hd0)'

Note with the --root-directory option, use this if you created a /boot partition else leave it out.

28th February 2004, 06:26 PM
Hi mhelios, thank you for your replie but I still couldn't fix my problem. I did exactly what you said, in my case:

grub> root (hd0,9)
Filesystem type is ext2fs, partition type 0x83
grub> setup (hd0)
Checking if "/boot/grub/stage1" exists....... no
Checking if "/grub/stage1" exists...... yes
Checking if "/grub/stage2" exists...... yes
Checking if "/grub/e2fs_stage1_5" exists...... yes
Running "embed /grub/e2fs_stage1_5 (hd0)"........ 15 sectors are embedded.
Running "install /grub/stage1 (hd0) (hd0) 1+15 p (hd0,9)/grub/stage2 /grub/grub.conf........ succeded
grub> quit

When I reboot my system, this is what I got:

GRUB Loading stage1.5
GRUB loading, please wait...
Booting ' Microsoft Windows XP SP1 '
rootnoverify (hd0,0)
chainloader +1

I could enter in my Windows XP automatically, but I could not see grub blue screen and obviously, I could not enter in Fedora Core.

Did I do something wrong, or, do I have to do something else to fix my problem? I think that I have to edit my grub.conf but I don't know where it is cause I can't find it in linux rescue mode. Or maybe, GRUB is reading another grub.conf. I really don't know what's going on here...


28th February 2004, 07:26 PM
Check my post above. I forgot to add a step in: `chroot /mnt/sysimage`.

Try this command after running the chroot:

grub-install /dev/hda

If that doesn't work, attach your /etc/grub.conf file.

1st March 2004, 11:15 PM
Oh yes... , finally I could do it, I could fix my problem, I mean... you could fix my problem !!!
You save me from reinstalling Fedora !!!

Thank you mhelios once again !!! :D


2nd March 2004, 03:36 AM
Great that you got it solved.....I have found, that after my MBR has been changed and GRUB is no longer there, I ONLY and JUST do the last thing you were told and it always fixes the problem.

Just reinstall GRUB with the install command and all goes back to normal. With this knowledge, you won't be afraid of messing up the MBR anymore because it can be repaired easily.

Hoever, if Windows will not boot, you might need to repair it's MBR first using it's recovery console. Then after that is OK, you re-install grub to the MBR and all will be fine.

MOST of the time, if the boot records get screwed up, the operating systems are just fine. it's just missing the "pointers"

2nd January 2005, 02:33 PM
After upgrading from fc2 to fc3.
I can not boot linux machine, because GRUB problem.
The machine show up a message that tells "Grub Loading stage 1.5" and "Grub loading,
Please Wait...".
I checked grub.conf. The file, grub.conf, is has no problem.
Boot partition is on /dev/hda1 and root directory is on /dev/hda3.
The kernel file and initrd files are on /boot directory.

What should I do? I don't want to reinstall the machine.
It makes me crazy. Please someone tells me what i have to do.

2nd January 2005, 03:04 PM
Have you tried what mhelios mentioned earlier?

3rd January 2005, 03:39 AM
Yes, I have tried everything mentioned earlier.
But, I don't have any solution in my case.

4th January 2005, 02:12 PM
Here is my grub.conf


title Fedora Core (2.6.9-1.667smp)
root (hd0,0)
kernel /vmlinuz-2.6.9-1.667smp ro root=LABEL=/ rhgb
initrd /initrd-2.6.9-1.667.img

title Fedora Core (2.6.9-1.667)
root (hd0,0)
kernel /vmlinuz-2.6.9-1.667 ro root=LABEL=/ rhgb
initrd /initrd-2.6.9-1.667.img

And here is my partition information :
/dev/hda1 /boot
/dev/hda3 /
/dev/hda2 /usr

I have been waiting for someome who can helps me.