PDA

View Full Version : FC 11 upgrade to FC12 and no sound from pulseaudio



p321
23rd November 2009, 09:48 PM
Hi all,
I need some help with pulseaudio setup.

My pulseaudio was working when I was using FC11 and it stops working after I
upgrade to FC12 using preupgrade.
The system sees audio device and alsa is working correctly.
No audio at all (system audio and mplayer) from Pulseaudio. I am using the
onboard Intel audio.

The verify from the alsamixer that the volume is not muted.
I also tries all the combination of profiles in the pavucontrol and in some of the profiles, I can see the output volume bar is moving, but still no sound

pulseaudio-0.9.19-2.fc12.x86_64
alsa-plugins-pulseaudio-1.0.21-2.fc12.x86_64

Attached is the pulseaudio log when playing video from mplayer.

Thank you in advance for your help.

markdk
24th November 2009, 08:39 AM
I found that after using preupgrade to go from FC11 to FC12 that sound was muted by default after the upgrade.
Using system/preferences/sound I unchecked the mute box and got sound, well a lot of crackling anyway. Playing with the sliders in system/preferances/advanced volume control got the sound back to a crackle free usable level.

mjrice
25th November 2009, 05:06 AM
Same problem, working fine w/F11 but no sound after install boot w/F12.

Don't seem to have this menu item:

system/preferances/advanced volume control

Is it something I must download?

Michael

Edit: Got mine working with alsamixer.

First time I've had to do that. Is this new?

Also, what are reasonable levels for Master and Speaker? I've got mine at 100%.

Michael

Edit: Seems I must use alsamixer to get sound every time I boot up.

Is there some way to make these changes (settings) permanent?

Michael

p321
25th November 2009, 11:49 PM
Thank you. I think I have the same issue where the audio was muted.

mjrice
26th November 2009, 12:57 AM
Hi p321,

I have another post for my sound problem. If you do a search for username "mjrice" you can see (and read) it.
Its topic/subject line is "Fedora 12 (x86)/new install/no sound"

If I get some feedback as to what the problem is, or hopefully a fix, I'll post here so maybe we can get your problem fixed also.

Michael

cathrynm
26th November 2009, 08:42 PM
I have 3 machines, of completely different sound hardware, and I had a problem getting pulse to start one one machine. I found that deleting the .pulse directory in the local home at least allowed me to start pulseaudio. That is I got the 'waiting' message when trying to bring up the sound configuration menu.

I think what happened is I copied in my homes from my backup, re-installed Fedora, but something from my ancient Fedora 8 pulseaudio install was killing Pulse Audio in the new machine.

mjrice
26th November 2009, 09:54 PM
Hi cathrynm,

I deleted my .pulse directory but it got recreated at restart. Sound still muted.

Think I'll do some searching for PulseAudio and see if I can figure out what's wrong. Maybe I'll learn something.

Michael

ursusca
26th November 2009, 10:02 PM
Hello,

I'm faced with a similar problem. I've upgraded to Fedora 12 from Fedora 11 using preupgrade utility.
Now I have no sound but microphone works fine.

lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)

amixer
Simple mixer control 'Master',0
Capabilities: pvolume pswitch pswitch-joined
Playback channels: Front Left - Front Right
Limits: Playback 0 - 65536
Mono:
Front Left: Playback 93389 [143%] [on]
Front Right: Playback 93389 [143%] [on]
Simple mixer control 'Capture',0
Capabilities: cvolume cswitch cswitch-joined
Capture channels: Front Left - Front Right
Limits: Capture 0 - 65536
Front Left: Capture 98304 [150%] [on]
Front Right: Capture 98304 [150%] [on]

arecord -l
**** List of CAPTURE Hardware Devices ****
card 0: Intel [HDA Intel], device 0: AD198x Analog [AD198x Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0

ursusca
27th November 2009, 10:49 PM
1. I've removed pulseaudio

yum remove pulseaudio
restarted computer and it helped.
2. I've installed pulseaudio again

yum install pulseaudio alsa-plugins-pulseaudio pulseaudio-esound-compat pulseaudio-libs pulseaudio-libs-glib2 pulseaudio-module-zeroconf pulseaudio-libs-zeroconf xmms-pulse pulseaudio-module-gconf wine-pulseaudio xine-lib-pulseaudio pulseaudio-utils pulseaudio-module-bluetooth gst-mixer padevchooser paman paprefs pavucontrol pavumeter

I've got sound too but skype didn't work properly:no sound, microphone works only.
3.I've removed pulseaudio again. I've got sound and skype woks properly.

I can't understand what is my problem now... skype or pulseaudio?

Please help me out on this,
Thanks in anticipation

mjrice
28th November 2009, 07:59 PM
The last (11/28/09) PulseAudio update fixed my problem.

Thanks all,

Michael

mikebg
30th November 2009, 11:36 PM
I still have no sound with Fedora 12.

I have followed the instructions to the letter.

I had a working sound system in Fedora-10 (which I can still boot into from a spare hard disk). It used pulseaudio and worked!

After upgrading from 10 -> 11 -> 12 over the course of a few days I have lost all sound via pulseaudio. The only thing which does work is 'Audio Configuration' (system -> administration -> sound card detection) which runs VERY SLOWLY but does play a little test tune.

I have tried to compare between the systems and cannot see what is different!

ursusca
1st December 2009, 10:01 PM
The last (11/28/09) PulseAudio update fixed my problem.

Thanks all,

Michael

The same solution for me :-)

mikebg
2nd December 2009, 08:29 AM
The last (11/28/09) PulseAudio update fixed my problem.

What version is that? I can't see anything later than what I have: pulseaudio-0.9.21-1.fc12.i686 (with a build date of 23rd Nov, not 28th Nov).

mjrice
2nd December 2009, 03:13 PM
[michael@localhost ~]$ pulseaudio --version
pulseaudio 0.9.21
[michael@localhost ~]$

Sorry, I gave a date that I received the update on my desktop, not a version number.

Michael

lordamus
12th January 2010, 03:16 PM
Same here after preuprade F11 to F12 sound default muted I opened then I can confirm lots of crackling especialy some other app tries to use sound.

mbratch
2nd February 2010, 06:46 PM
I did a fresh install of Fedora 12. I was on Fedora 8 (:-O). But at least Fedora 8 worked. Now I have no sound. I checked the mute settings, and nothing is muted. The sound config tool sees the hardware and tells me it exists. Doing an "aplay -L" from the root login shows the devices. Doing "aplay -L" from a regular user just shows "default". I don't know if that means anything...

My scanner no longer works either. And silly things don't work, like the .face files aren't recognized. I'm about ready to load my Fedora 8 back in.

apathetica
6th March 2010, 06:19 PM
1. I've removed pulseaudio

yum remove pulseaudio
restarted computer and it helped.


MyFC12 x64 KDE4 had sound. I had muted it many days, perhaps 2 weeks back and wasn't using the PC for days. Then yesterday I used the PC. Whenever i start the machine, i do a manual yum update. It was a huge 200MB+ update.

Today after surfing awhile I unmuted sound to watch flash streaming but there was no sound. Restarted the PC many time but still did not work. Then i uninstalled pulseaudio, restarted the PC and sound came back. Did not install again.

When it did not work, there were only 2 devices in Settings->System Settings->Multimedia. I did not record what they were. When it worked there are more device, including "HDA Intel (ALC889A Anaiog)" which output sound when i click "Test".

Actually this is not the first time it happened. The first time happened several months ago and i vaguely remember doing the same step.

I suspect something trigger the problem during the yum update. Sorry, i'm only a simple user. Just wanna post my experience and hopefully someone can help solve the problem for the community :)