PDA

View Full Version : can only "print to file"



mpajoh
21st November 2009, 10:10 PM
After installing a new printer, Brother HL-2170W, it was correctly recognized.
But now I can, for example in FireFox or Gedit, when trying to print the only option available is "print to file."

I had a similar problem many months back which somehow resolved itself without doing anything intentional on my part. Going back to that thread (http://forums.fedoraforum.org/showthread.php?t=222845) I tried the suggestions but nothing worked.

A few points:
-- I have SELINUX disabled.
-- Test pages print fine from the Printer Configuration.
-- this command "echo "This is a test" | lp -d HL-2170W-series" prints just fine.
-- Running lpstat -t returns:

scheduler is running
system default destination: HL-2170W-series
device for Brother: hal:///org/freedesktop/Hal/devices/usb_device_4f9_35_J9J834926_if0_printer_noserial
device for Cups-PDF: cups-pdf:/
device for HL-2170W-series: usb://Brother/HL-2170W%20series
Brother accepting requests since Sat 21 Nov 2009 02:32:41 PM CST
Cups-PDF accepting requests since Sat 21 Nov 2009 02:29:45 PM CST
HL-2170W-series accepting requests since Sat 21 Nov 2009 02:24:08 PM CST
printer Brother is idle. enabled since Sat 21 Nov 2009 02:32:41 PM CST
printer Cups-PDF is idle. enabled since Sat 21 Nov 2009 02:29:45 PM CST
printer HL-2170W-series is idle. enabled since Sat 21 Nov 2009 02:24:08 PM CST


Attached is the cups error file.
Thanks for all the help.

Masoud

CamoAnimal
22nd November 2009, 08:01 AM
It may sound silly, but even Fedora sometimes needs to be rebooted. If you have already tried this and had success then please mark the post as [SOLVED]...

If not please say so and I will make another suggestion.

mpajoh
22nd November 2009, 03:25 PM
Yes I have rebooted.
The problem remains even after reboot.

Thanks.

Edit: FWIW,
I just tried printing from Open Office and it worked fine.

Edit: Update:
After looking on internet, there as a suggestion to add:

gtk-print-backends = "lpr,file"
to /etc/gtk-2.0/gtkrc.
After doing that "print to lpr" option is added to the print dialogue, and works fine.
But I suppose this is only a band aid.
Is there a better solution?