PDA

View Full Version : FC2 and laptops using the Synaptics Touchpad...



k3ant
22nd May 2004, 03:04 PM
Laptops that use the Synaptics Touchpad that may be missing the tap function when used with FC2, or any distro (possibly!) that is using the 2.6 kernel, as I found this fix at the Mandrake forum for Mdk 10 Comm.

If your tap function is not working, add the following to you GRUB's kernel line:

psmouse.proto=imps

BTW, you can also pass this to the kernel during FC2's installation by using this command at the prompt:

linux psmouse.proto=imps

This will give normal tap function during the installation of FC2. Be sure to add this kernel command to GRUB when the time comes during FC2's installation.

Lots of luck...

I have been using this since FC2-Test2 and it has worked right through to the general release of FC2...

davidkaye
22nd May 2004, 08:45 PM
Thank you sooooooo much. I have been trying to figure that one out for weeks now. Not only does the tap-click work, but the scroll works, too. Strangely enough, the scroll works by default under Gentoo, but not under Fedora Core2.

mgartner
23rd May 2004, 10:55 AM
Thank you for this absolute useful information! Now I can use the touchpad as it should be! :D

LackeyLad
15th June 2004, 09:29 AM
i did this months ago but had to reinstall fedora.

Where exactly is the grub kernal line?

can anyone offer a file path and specific file that i need to add a line too to make the touchpad work?

k3ant
15th June 2004, 01:36 PM
The file you need modifiy is the /boot/grub/grub.conf. Here is what my section looks like for FC2:

title Fedora Core (2.6.6-1.427)
root (hd0,7)
kernel /boot/vmlinuz-2.6.6-1.427 ro root=LABEL=/1 psmouse.proto=imps selinux=0 acpi=on hdb=ide-cd
initrd /boot/initrd-2.6.6-1.427.img

Be aware - your kernel version may be different as compared to the one I have been using. Plus, other parameters may be different. But if you look, the kernel line actually does begin with the word 'kernel' - making it easy for newbees to remember, me included! To make the needed mods, you must be 'root', btw.

Also, your kernel line may, or may not have all of the kernel commands I use. Just add the psmouse.proto=imps, save the file, reboot the system and if you're lucky, you will again have tap function back. If you are NOT lucky, the way I read it, you will need to install the latest Synaptic driver package. I know nothing about this fix!

Enjoy!

Scoob_E
20th June 2004, 09:00 AM
Great tip! I have been trying to get this touchpad going for a while. I have been using a fix that only works part of the time, and unfortunatly I didn't make it into the group that got their's working. This worked like a charm for me

Thanks
Scoob

hay
11th October 2004, 06:23 AM
Thanks,

psmouse.proto=imps works. However, how to change to double tapping (I have single-tapping after adding the line)?

k3ant
11th October 2004, 12:24 PM
In KDE, open Control Center (kcontrol), go to PERIPHERALS/Mouse and under ICONS select "Double click to open files"...

In Gnome, go to the Desktop Settings, or Gnome Control Panel, however it may be worded, then select Mouse and then select the 'Double click..." option...

swanker
14th November 2004, 10:00 AM
THANKS A BUNCH!!! I had given up, (without much looking) on the touch pad. I have an hp laptop with the synaptics tp, and this makes the tap and the side scroller work. Thanks again

amitshruti123
19th August 2009, 12:24 PM
I tried psmouse.proto=imps on my DELL latitude D520 .. mouse tapping works fine for me after this but side scroller stopped working it was working without psmouse.proto=imps in my F11

glennzo
19th August 2009, 01:13 PM
Thread closed as it is 5 years old and very likely irrelevant to current releases.