PDA

View Full Version : Fedora 12 64bit Nvidia problem



f3arle551
19th November 2009, 04:41 PM
I tried to install the repos and yum kmod-nvidia like a lot of the tutorials say but each time they cannot be found. I also tried to get the .run package from nvidias website and run that in runlevel 3 since it does not like any of the GUI's and it fails and gives a "unable to build module error"... anyone know how i may be able to fix this or another way of installing Nvidia driver? I have a Geforce 7 series card.... or Geforce 7300 LE

Milena
19th November 2009, 05:33 PM
Hi

to install the .run package do:


su -c 'gedit /boot/grub/grub.conf'

and add
nouveau.modeset=0 to the kernel line after rhgb quiet:

kernel /boot/vmlinuz-2.6.31.5-127.fc12.x86_64 ro root=UUID=44935a8b-db50-4ed1-b4ee-f12a47976fc8 noiswmd LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=de rhgb quiet nouveau.modeset=0

restart and at the login screen press ctrl+alt+f2 for console, login as root and type init 3 and install your driver.

edit: don't forget you need binutils, gcc and kernel-devel to build the module (just in case you have not done that already)


su -c 'yum install gcc kernel-devel binutils'

f3arle551
19th November 2009, 05:36 PM
Hi

to install the .run package do:


su -c 'gedit /boot/grub/grub.conf'

and add
nouveau.modeset=0 to the kernel line after rhgb quiet:

kernel /boot/vmlinuz-2.6.31.5-127.fc12.x86_64 ro root=UUID=44935a8b-db50-4ed1-b4ee-f12a47976fc8 noiswmd LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=de rhgb quiet nouveau.modeset=0

restart and at the login screen press ctrl+alt+f2 for console, login as root and type init 3 and install your driver.

Thanks I will give that a try and post again if I have any problems

snhemanthm
19th November 2009, 06:14 PM
Hi,

The kmod-nvidia package from RPM Fusion is still in their updates-testing repo. So you will need to go to software sources and enable the RPMFusion nonfree updates-testing repo, then run yum install kmod-nvidia or yum upgrade kmod-nvidia.

aniketv
19th November 2009, 10:29 PM
Here is what I did on my F12 64 bit

I wrote a small script (lol actually just copied the commands ) and called it nvidia-initram-fix and placed it in /usr/local/bin


#!/bin/bash
mv /boot/initramfs-$(uname -r).img /boot/initramfs-$(uname -r)-nouveau.img
dracut /boot/initramfs-$(uname -r).img $(uname -r)
setsebool -P allow_execstack on
then i added "nouveau.modeset=0" to kernel line in /boot/grub/grub.conf and rebooted to runlevel 3 by appending "3" to the kernel line from the grub menu

I then installed the .run file from nvidia website and ran the script above, issued command "init 5" and nvidia was up and running with 3d and vdpau .

So next time you update kernel, its just running the above script after installing the Nvidia driver.

ozjd
19th November 2009, 10:40 PM
I tried to install the repos and yum kmod-nvidia like a lot of the tutorials say but each time they cannot be found. I also tried to get the .run package from nvidias website and run that in runlevel 3 since it does not like any of the GUI's and it fails and gives a "unable to build module error"... anyone know how i may be able to fix this or another way of installing Nvidia driver? I have a Geforce 7 series card.... or Geforce 7300 LE

Look at the nvidia how to in my signature.

BOZG1
19th November 2009, 10:52 PM
I tried to install the repos and yum kmod-nvidia like a lot of the tutorials say but each time they cannot be found. I also tried to get the .run package from nvidias website and run that in runlevel 3 since it does not like any of the GUI's and it fails and gives a "unable to build module error"... anyone know how i may be able to fix this or another way of installing Nvidia driver? I have a Geforce 7 series card.... or Geforce 7300 LE

I had the same problem until I checked the repos. You need to make sure testing repo is unabled.

zeiz
24th November 2009, 01:58 AM
I also got problems but this howto (http://forums.fedoraforum.org/showpost.php?p=1114769&postcount=1) was updated and I followed it exactly. Success. The only thing I'm not happy with is a message at boot, something like this: "unknown boot option 'nouveau.modeset=0'...ignoring"
everything works fine but the message...
I removed the string from /boot/grub/grub.conf and... felt into problems again, means it's necessary.
If so why the message appears?

Shielder
13th December 2009, 09:20 PM
I also got this message after having the "nouveau.modeset=0" option added to my grub menu. I suspect that the nvidia drivers are not loaded. I'll check again, but I think something is going wrong somewhere.

leigh123linux
13th December 2009, 09:32 PM
Thread closed as it it causing confusion.

Use the guide in my signature