PDA

View Full Version : Gnome indicator-applet for Fedora?



Cuvou
16th November 2009, 10:59 PM
Ubuntu has a pair of packages called indicator-applet and indicator-applet-session.

The latter (-session) applet is what shows your user name on the panel (like the switch users applet in Fedora), but it also shows an icon representing your current status in Pidgin, and clicking the applet lets you change your status in Pidgin as well as log out or switch users.

indicator-applet in Ubuntu 9.10 sits by default next to the notification area and shows an e-mail icon, and allegedly is supposed to tell you how many unread messages you have in your e-mail client. I've never configured my e-mail in Ubuntu as I rarely use that OS so I can't say for sure.

Is it feasible to get these applets ported over to Fedora? Would a deb-to-rpm converter work, or would there be a nightmare of dependency issues since these applets seem to be something Canonical made themselves and that's why only Ubuntu has them?

Or has anybody already created RPMs for them?

dmyersturnbull
17th November 2009, 05:11 AM
Hey, Cuvou.

Fedora package maintainers have not built RPMs for these two packages, but using RPMs is not required for simply using the software. Canonical has a project page here (https://launchpad.net/indicator-applet). Download the tarball, run the autoconf, make, and make install. If you're new to make and autoconf, read this tutorial (http://tldp.org/LDP/LG/current/smith.html) for an overview. You will probably need to hunt for dependencies. Always try the Fedora repos first for dependencies. If you have trouble finding any dependencies, feel free to follow-up your question.

Now, if you'd like to build an RPM for others to use, then this tutorial (http://www.g-loaded.eu/2006/04/05/how-to-build-rpm-packages-on-fedora/) is a good starting point. Do bear in mind, however, that building RPMs (or Debian packages) is not required for installing software. I would not recommend trying conversion tools, though others may have different opinions. Your best bet is building the RPM manually.

I hope that helps. Let us know if you get stuck or have further questions :)
óDouglas

Cuvou
17th November 2009, 07:13 PM
Thanks Douglas,

I know how to compile and manually install software. I like to keep my systems "clean" though and build RPMs for things instead, so that everything I add to the system is known by the package manager.

I'll look into putting together RPMs for these sometime in the near future.

Thanks again.

mariuszs
18th November 2009, 07:52 AM
+vote for RPM for this

Ubuntu is still more elegant as Fedora... Ubuntu Dust Gnome Theme rocks!!!

http://www.gnome-look.org/CONTENT/content-pre2/88790-2.jpg

vishytk
25th November 2009, 07:04 AM
here's the rpm package for F12

http://office.penguin-infotech.com:81/indicator-applet/

There is also a patched version of Empathy on ubuntu. The "Restart" option from indicator-applet-session does not seem to be working. It will be helpful if some one provides a fix for this.

cheers,
vishy

mariuszs
25th November 2009, 07:48 AM
Thanks :D Any chance to build x64 version?

I have problem with compliling evolution-indicator

checking for DEPS... configure: error: Package requirements (indicate >= 0.2.0
evolution-plugin
dbus-1
dbus-glib-1
libnotify
libcanberra
gtkhtml-editor
) were not met:

No package 'evolution-plugin' found
No package 'gtkhtml-editor' found

vishytk
26th November 2009, 10:16 AM
I don't have 64-bit fedora installed, so i cannot build x86_64 package. But it should be straight forward building on your own.

You will require devel packages for evolution (evolution-devel) and gtkhtml3 (gtkhtml3-devel)

cheers,
vishy


Thanks :D Any chance to build x64 version?

I have problem with compliling evolution-indicator

checking for DEPS... configure: error: Package requirements (indicate >= 0.2.0
evolution-plugin
dbus-1
dbus-glib-1
libnotify
libcanberra
gtkhtml-editor
) were not met:

No package 'evolution-plugin' found
No package 'gtkhtml-editor' found

mariuszs
26th November 2009, 02:12 PM
Thanks, this help. But without empathy-indicator this is useless :(

vishytk
26th November 2009, 02:52 PM
indicator is working with pidgin for me :)


Thanks, this help. But without empathy-indicator this is useless :(

Valent
26th January 2010, 08:47 PM
Thank you for this great RPM. We are looking into making your indicator-applet default for new version of Fedora Community Remix. Check it out: http://fcoremix.wordpress.com/

rockor
6th November 2010, 09:06 PM
the link given above for the rpm package doesn't seem to work....

could anybody give an alternative link or maybe mail the rpm to me.. plzzzz....
my email: champu123@yahoo.com....

thnx in advance....

Valent
6th November 2010, 09:19 PM
Until somebody makes this package official in Fedora repo we can't start using this package in Fusion Fedora Remix - http://fusionlinux.org/

rockor
8th November 2010, 05:48 AM
Hello, hello, anybody got the rpm???

Plz give a link... i need it...