PDA

View Full Version : how 2 hot plugging and mounting a USB memory disk??



magnetoza
6th October 2004, 02:11 PM
help plz..
i'm running fc2 workstation with option 2 boot from kernel 2.6.8-1.521 and 2.68-1.358..
I'm try in 2 get my usb memorystick so it is posiable 2 hotswap and mount the usb memorystick automacticly..Without have 2 reboot all the time. :confused: :confused:
i have tried using the submount rpm from sourceforge but can't get 2 work..

if somecan plz help me out...with what 2 do and get and what files that i need plz.
thankz alot in advance..
ross

wilhelm_eklund
6th October 2004, 06:10 PM
Hello!
I had this problem until yesterday, I use kernel 2.6.5-1 hur it should be about hte same, And I have a pcmcia-cardreader for flash memory.
::::::::::::::::::::::::::::::::::
Good-to-know-files:
/var/lib/pcmcia/stab <-- this files lets you see wheather the system has noticed that you inserted the card again

/sbin/cardctl <-- this program gives you the HW-parametres sent from the card to the kernel,

man 5 pcmcia <-- man-pages for pcmcia, Very useful

:::::::::::::::::::::::::::::::::::::::::
Anyway, what i did to find out where to find my card I did
# cat /var/lib/pcmcia/stab
and saw that it had the name hde. I also checked my hwbrowser and found the card under "hard drives". Then i simply mounted it.
#mkdir /mnt/usbflash
#mount /dev/hde1 /mnt/usbflash
then it worked fine for me, and if you want to hotplug it you can just re-mount it.

You can also try to experiment with cardctl, a program to view status of your pcmcia-card or restart it! (which i think was the essence of your qustion)
First become root by using
#su
then type
#/sbin/cardctl resume
this might work for you.

Asĺternatively you can check you /etc/fstab file
#cat /etc/fstab
if you have a line where you can se usb stick being mounted you can try
#mount -a
to re-mount all your mount-point, if they havve somehow been unmounted.

Good luck!

/Wille

magnetoza
7th October 2004, 10:43 AM
thankz 4 da info in last post.But not try 2 get a pcmcia card 2 work..
i can mount my usb memoryStick manually...but trying 2 setup it up,so that i can just hot swap/hot plug the usb MemStick..Instead of manual mount it all the time... plz and with any idea's 2 help me out :confused: ;) :confused:

yg_sun
8th October 2004, 02:23 PM
mount /dev/sda1 /mnt/usb