PDA

View Full Version : Custom kernel - Kernel-headers not built!



keven
4th November 2009, 03:23 PM
I'm building a custom kernel following the http://fedoraproject.org/wiki/Docs/CustomKernel reference. The document suggests that the kernel-headers RPM will be built as well - I have yet to find a combination that actually builds this RPM (I've tried on both Fedora 10 and Fedora 11).

I have tried various options to the "rpmbuild" command to no avail. I've also modified the kernel.SPEC file to set the "with_headers" variable to 1 (true).

Here is the rpmbuild command that I'm using:
rpmbuild --target i686 --without debug --with headers --with firmware -bb SPECS/kernel.spec

The kernel-PAE, kernel-PAE-devel, and kernel-PAE-firmware RPMs are created (as expected). These install, and the kernel boots successfully.

In the mean-time, I've hand-moved the /usr/include/{asm,asm-generic,linux} directories to "orig", and created soft-links to /usr/src/kernels/2.6.30.8-64.pps.fc11.i686.PAE/arch/x86/include/asm, /usr/src/kernels/2.6.30.8-64.pps.fc11.i686.PAE/include/asm-generic, and /usr/src/kernels/2.6.30.8-64.pps.fc11.i686.PAE/include/linux, which are packaged under the kernel-PAE-devel package. This works, and allows me to compile user-space programs which require new kernel headers, but it's obviously a kludge.

Any guidance would be appreciated.