PDA

View Full Version : Problem playing mp3 with songbird



nirvana09
24th October 2009, 03:39 PM
Hi

I am a newbie in Fedora Core 11 and installed songbird via songbird wiki website.
I want to play mp3 files with songbird (which is basically why i downloaded it cos i dont like amarok) but when i try to play a file, it gives this message:

"MediaCore Error: An id3 tag demuxer plugin is required to play this stream, but not installed"

i searched a lot on web but couldnt find a solution

can anybody help me please!!!!!

thanks

Sagitter
24th October 2009, 04:22 PM
Try so:

close songbird, then:




# yum install xmms xmms-mp3 xmms-faad2 xmms-pulse xmms-skins

nirvana09
24th October 2009, 05:39 PM
Isnt that for playing mp3 files with xmms player? I dont want to use that program.

How can i play mp3s with songbird??

glennzo
24th October 2009, 05:46 PM
http://www.mjmwired.net/resources/mjm-fedora-f11.html#mp3

nirvana09
24th October 2009, 05:52 PM
Still songbird does not exist in the link you posted. Does this mean that there is no way to play mp3s in songbird in fedora??

I still prefer a way to use songbird..

glennzo
24th October 2009, 05:54 PM
That link has nothing to do with SongBird and everything to do with being able to play *most* media formats with *most* of the media players.

nirvana09
24th October 2009, 05:57 PM
Yeah I realized it. But what about this "id3 muxer plugin" problem?? Anybody have an idea??

scottro
24th October 2009, 05:58 PM
The silly question, do you have mp3 support? (It's proprietary and I don't think it's included by default.).
The folks above have given suggestions for getting mp3 support--personally, I install mplayer from rpmfusion and get it that way--not sure how to *just* get mp3 support,

As mjmwired says (just reread Glennzo's link), there is no mp3 support included--that's your issue. I would add rpmfusion (there's a link in the mjmwired page) and maybe do yum search mp3.

Sagitter
24th October 2009, 06:11 PM
@Glennzo, @Scottro.

Thank you for having clarified the misunderstanding.

Sagitter

glennzo
24th October 2009, 06:11 PM
After you install the RPMFusion repositories try, from a terminal

su -c 'yum install gstreamer-plugins-ugly'
Then see if you can play the .mp3. I've just installed SongBird and am playing a random .mp3 file without issue. Of course, I have all the necessary multimedia requirements already installed.

nirvana09
24th October 2009, 06:56 PM
Hi

First of all thanks for all the feedback and help I really appreciate since I am a newbie in fedora..

I dont know how and when i did it but "gstreamer-plugins-ugly-0.10.12.2-fc11.i586 is already installed and latest version" but i still get the id3 demuxer plugin error

what about those "necessary multimedia requirements already installed" ?? maybe i am lacking such requirements..

glennzo
24th October 2009, 07:12 PM
Next step. Open a terminal and type

su -c 'yum install gstreamer-plugins-ugly gstreamer-plugins-bad gstreamer-ffmpeg gstreamer-plugins-good'
Close and restart SongBird. See if .mp3's play now.

nirvana09
24th October 2009, 09:21 PM
glennzo you are the man!! thanks a lot man.. i did what you said in the last message and now it is working.. ı tried it thousand times trying to fix it and now its done!!
but can you tell me what was the problem so that i can learn and not encounter it again. i am asking it because i am a newbie..
thanks to scottro and sagitter too..
now i can enjoy songbird in my fedora!! :)

glennzo
24th October 2009, 10:09 PM
I'm not the man. I've just been playing with this Fedora thing long enough so that I know how to get my .mp3's working. You need to understand that Fedora, by design, does not support many of the multimedia formats. Copyright laws, etc. As such, YOU, I and every other Fedora (and most other Linux) user needs to install that support. Learning how to do it is a matter of asking for help in forums like this one and a little research. A little practice doesn't hurt either (doing it over and over again). Now that you've gotten music working, make notes and keep them aside. Next time you need to do this you'll have something for reference. Have a look at my notes (Fedora 12 and other distros). Not very pretty but functional. Maybe even fairly accurate :p
http://www.johnson.homelinux.net


As an afterthought, I play with several distros. Arch Linux is the newest, from which I'm working as I type. I just updated this old laptop and totally messed it up. Upon reboot, no GUI. Just a black screen with no indication that booting would progress any further. To fix it, I used one of my desktop boxes and went to the Arch Linux wiki and read, read and read some more. Then end result is that I repaired the installation. All it took was a little time, research and determination. I'm back in business, up and running and happily playing with Arch again!

nirvana09
26th October 2009, 10:27 PM
Hi

Although i fixed the problem now i have a message "missing element input-selector. Check your gstreamer installation"

The thing is i had problems with sound in skype so i removed pulse and using alsa now.
what can i do now??

nirvana09
27th October 2009, 09:10 PM
i fixed the problem. i installed all of the gstreamer plugins available from yum and somehow its fixed now.

thanks again..