PDA

View Full Version : FC11 nVidia No Sound After RPMFusion nVidia Driver Load



basimmer
16th October 2009, 12:46 AM
No sound on FC11 fresh install after loading nVidia drivers followin the instructions found at http://fedoraunity.org/solved/video-solutions/nvidia-yum-kmod.

I am running a PAE kernel so I installed that version. The nouveau driver did load so I did
mkinitrd -f /boot/initrd-$(uname -r).img $(uname -r) as suggested, rebooted, and the nouneau driver was gone. The nVidia graphics part work great on both the VGA and the DVI connected to Sony TV via converter cable. It even correctly detected the Sony as the second screen.

The problem is no sound. I am using the middle plug in the 3 stack analog and I am sure the sound was running right after the Fedora Core 11 install. After the nNivida drivers were loaded; no sound.

I have searched the web and found no specific answer. I have tried several variations of what I saw for other systems / drivers to no avail. At this point I removed pulseaudio and am trying to run straight alsa to see if I can get just it running.

In the past on FC9, I believe I used /etc/modprobe.d/alsa.conf with options snd-hda-intel model=3stack-dig. I added index=0 based on current research. Auto and 3stack-6ch did not work either. I should note that on FC9 after a kernel upgrade and that latest nVidia driver, I lost the sound and never got it back. However, I did have it running fine on the same system with an earlier FC9 kernel and an earlier nVidia drive (I will never upgrade again if I can get it running).

Mobo: Gigabyte GA-73PVM-S2
alsa-info.sh info is at
http://www.alsa-project.org/db/?f=72cdc6ba07634050d0d93199d510af552d1a327c

Any help is greatly appreciated. For me sound issues are the most frustrating issue with Linux systems.

Brett