View Full Version : Anyone else having problems booting FC2?

4th October 2004, 10:09 AM
I'm a Linux newbie and have spent some disheartening time overcoming a number of issues (hardware & bugs) to finally get FC2 to install on my old Dell PentiumPro (64MB memory 9.1 G Seagate scsii drive). The install was on a completly clean system (formatted harddrive).

However after completing the install and rebooting... nothing. The bios installs then there is a single beep, a cursor and nothing...

I have looked for a similar issues but they all seem to relate to dual boot systems. I allowed the install to automatically set up the partitions.

Anyone got any ideas on how to fix this? :eek:

4th October 2004, 10:32 AM
(64MB memory)
1. 64mb?...i believe you need more memory, where did you install the bootloader? MBR?

2. dual boot? xp? win 2k? you said it was installed in clean hard drive.

3. provide more pc specs.

4th October 2004, 10:34 AM
I would either boot to the rescue disk or the 1st install disk to see if the install actually loaded. Then try to troublshoot from there. When you installed it, did you choose grub or lilo? It may be that the mbr didn't get installed. That would be the first thing to boot after bios.

4th October 2004, 10:59 AM
Taking a quick look at your PC specs, I get the feeling that your PC may not be able to run fedora in a graphical mode. The following is taken from the release notes (http://fedora.redhat.com/docs/release-notes/) for Fedora Core 2:CPU Requirements
This section lists the CPU specifications required by Fedora Core 2.

The following CPU specifications are stated in terms of Intel processors. Other processors (notably, offerings from AMD, Cyrix, and VIA) that are compatible with and equivalent to the following Intel processors may also be used with Fedora Core.

Minimum: Pentium-class

Fedora Core 2 is optimized for Pentium PRO (and later) CPUs, but also supports Pentium-class CPUs. This approach has been taken because Pentium-class optimizations actually result in reduced performance for non-Pentium-class processors.

Recommended for text-mode: 200 MHz Pentium-class or better

Recommended for graphical: 400 MHz Pentium II or better

Hard Disk Space Requirements
This section lists the disk space required to install Fedora Core 2.

The disk space requirements listed below represent the disk space taken up by Fedora Core 2 after the installation is complete. However, additional disk space is required during the installation to support the installation environment. This additional disk space corresponds to the size of /Fedora/base/stage2.img (on CD-ROM 1) plus the size of the files in /var/lib/rpm on the installed system.

In practical terms, this means that as little as an additional 90MB can be required for a minimal installation, while as much as an additional 175MB can be required for an "everything" installation.

Also, keep in mind that additional space will be required for any user data, and at least 5% free space should be maintained for proper system operation.

Custom Installation (Minimal): 620MB

Server: 1.1GB

Personal Desktop: 2.3GB

Workstation: 3.0GB

Custom Installation (Everything): 6.9GB

Memory Requirements
This section lists the memory required to install Fedora Core 2.

Minimum for text-mode: 64MB

Minimum for graphical: 192MB

Recommended for graphical: 256MB
Reading between the lines a bit here, I think that your hardware may be too old to run Fedora in a stable GUI mode. The only thing you'll really be able to use it for would be as a server (i.e. webserver, printer server etc).

4th October 2004, 12:40 PM
PC is Dell Dimension XPS Pro200n with 64MB memory and a 9.1 gig seagate scsii drive. I've had to steal another CD Rom to overcome one issue and I have updated the bios to fix another!

I formatted the hd before install and only want linux on this box. I did a custom installation including most bits I want to try out. I let the installer partition and format the drive and put the MBR on the boot partition. I did the installation in text mode and the whole installation went fine with no problems.
Drive, monitor mouse all detected OK.

I've done all the normal things like confirm the media etc..

When I reboot nothing.....

4th October 2004, 12:52 PM
Yep Checked that the installation does exist. One interesting thing is that I would expect to see grub.conf in the /etc/ directory... but it does not appear to be there. I installed grub.

I think it may struggle running in graphical mode, but I think because the system simply does not re-boot it must be something to do with the bootstap / MBR / grub but I have only a little but growing knowledge of these things!!

Aanyway I am doing a fresh re-install, I shall just selecting the server option an see if this improves my options... Please keep the ideas coming

tx all

4th October 2004, 12:59 PM
You really don't need to reinstall -


4th October 2004, 02:25 PM
Thanks Harryc, your idea came too late to save me from the reinstall. However things are not good but slightly different! I did a server install.

on reboot i got a Frozen GRUB prompt. I tried the technique in post you linked too and when I do the grub-install --recheck /sd0 (i also tried hd0) the device was not found.

fdisk -l shows

Device Boot Start End Blocks Id System
/dev/sda1 * 1 13 104391 83 Linux
/dev/sda2 14 1002 8586742 83 Linux
/dev/sda3 1083 1106 192788 02 Linux Swap

when I use the Rescue CD, I think it must find the kernel on /dev/sda2 because I dont see the boot directory. I still think it must be an MBR / GRUB issue but don't know how to progress this.... any more ideas?

4th October 2004, 02:44 PM
Scratch the last bit. Kernel is on /dev/sda1. I can see grub.conf and kernel file..

4th October 2004, 02:44 PM
Well, post your grub.conf and lets take a look at it.

4th October 2004, 08:48 PM
Well after 48hrs fighting one issue after another I have come to realize that the "bleeding Edge" is not the right place for a newbie. I simply do not have enough basic knowledge of Linux to provide you guys with the data needed to sort this one out.

I have now made a full install of Red Hat 9.0, and this went without any problems at all. FC2 has way too many issues for a newbie like me to be playing with it.

I just wanted to thank everyone who tried to assist me on this thread. I'll try again when FC3 is cooked and hopefully will have a little bit more sucess. Thanks again!

5th October 2004, 07:50 AM
I'm sorry to hear about that. See you for FC3 then?